1 2 3 4 Previous Next 49 Replies Latest reply on Mar 4, 2009 9:31 AM by Tracy

    Softmon.exe - Runtime error

    Apprentice

      Untitled.jpg

      Hello,

       

      I'm getting complaints of an error dialog box on a bunch of machines. It has a message title of MS Visual C++ Runtime Library - C:\Program Files\LANDesk\LDClient\softmon.exe.

       

      I have not been able to find a commonality of these machines.  Some are XP, some are Vista.

       

      One thing I did notice was that most of the machines are running 8.8.0.21 and some have been upgraded to 8.8.0.32.

       

      What should I be looking at?

       

      Thanks for any help,

       

      Murf

       

                

        • 1. Re: Softmon.exe - Runtime error
          phoffmann SupportEmployee

          Nice ...

           

          ... would suggest first of all to make sure whether you've got the latest SOFTMON.EXE ... for 8.8 that is ...

           

          oh - you're not service packed. Just noticed that your version 8.8.0.32 essentially means pre-SP1 ... one thing you may want to try is to grab SP2, and install just the client-side service pack on to a test client (that you can roll back - i.e. VMWare snapshot ideally) ... that'll give you a "one stop check" to figure out if SP2 will help you here (I seem to remember something like this that should be resolved...)

           

          Paul Hoffmann

          LANDesk EMEA Technical Lead

          • 2. Re: Softmon.exe - Runtime error
            Apprentice

            Thanks for the quick response Paul!

             

            I installed the SP2 client side and am still getting the error upon reboot.

             

            I guess this is just a lack of education on my part.  I thought that I was running SP2 on everything.  If I click on Help - About LANDesk Management Suite - It shows version 8.8.0.249, but when I click on more info, it shows that 8.8-SP2 is installed.

             

            What am I missing?

             

            Thanks again

            • 3. Re: Softmon.exe - Runtime error
              phoffmann SupportEmployee

              You either didn't upgrade your clients, or something during the upgrade went wrong - see the below for potential problems:

              - http://community.landesk.com/support/docs/DOC-4686

              - http://community.landesk.com/support/docs/DOC-4449

               

              I'm hoping you just forgot to redeploy your agents .

               

              Paul Hoffmann

              LANDesk EMEA Technical Lead

              • 4. Re: Softmon.exe - Runtime error
                Rookie

                We've just started getting the same error on multiple systems in the past two days.

                 

                We're running 8.8SP1 core and clients.

                 

                I've attached a screenshot.

                • 5. Re: Softmon.exe - Runtime error
                  Apprentice

                  This is now happening campus wide to a lot of machines.  I don't know what has changed on our core.  It looks like we installed .net 3.5 SP1 last Friday, but other than that, nothing.

                   

                  Thanks for the update.

                   

                  -Murf

                  • 6. Re: Softmon.exe - Runtime error
                    Ken Apprentice

                    As of this morning, I have been experiencing this same symptom on Windows XP systems (Vista seems to be running ok so far).

                     

                    My security and patch content updates every morning at 4 AM, and I noticed while running vulscan with the /showui=true switch that it is reporting failure during the spyware portion of the scan.  I've attached the vulscan.log file for reference.

                     

                    I deleted the files in the "C:\Documents and Settings\All Users\Application Data\vulScan" folder so as to have all files downloaded fresh from the core when I next ran vulscan.  I noticed that while the contents of that folder were deleted, softmon was able to run just fine (Agent Watcher restarted the service while I was troubleshooting).  However, as soon as the vulscan failure occurred, I also started to receive the Runtime Error from softmon every time Agent Watcher restarted it.

                    • 7. Re: Softmon.exe - Runtime error
                      Rookie

                      Same on my setup. I have some end user computers getting this and I now have a server getting this as well.

                      • 8. Re: Softmon.exe - Runtime error
                        Rookie

                        I continue to receive additional reports. I've attached a couple more pertinent screenshots.

                        • 9. Re: Softmon.exe - Runtime error
                          Apprentice

                          Is anyone having any success with this?  I have opened an issue with LANDesk support, but haven't yet heard back.  This is now happening on most of my machines.

                          • 10. Re: Softmon.exe - Runtime error
                            Rookie

                            According to LANDesk when I called, this may be due to a missmatch of versions for softmon and vulscan.  I was told to check the versions on problem machines, and stop the live scan of spyware service and restart the machine.  If the error does not persist, this version missmatch may be the issue and softmon should be updated.

                             

                            I am still looking into this, and have not had a chance to test this yet.

                            • 11. Re: Softmon.exe - Runtime error
                              Master

                              Anyone have error messages on the client machine in the Application Log of the Event Viewer pretaining to .NET ?

                               

                              Michael sorry but I cannot see one of your images clearly.

                              • 12. Re: Softmon.exe - Runtime error
                                Rookie

                                I am seeing the same error in my environment

                                We are at 8.8 SPA

                                All clients are Vista SP1

                                On a client that is receiving the error, SoftMon.exe is ver 8.80.2.8

                                Sitting in the LD support queue, listening to bad hold music now...

                                • 13. Re: Softmon.exe - Runtime error
                                  Ken Apprentice

                                  Corrie,

                                   

                                  I don't have any .NET errors in my event viewer.  The two screenshots below are the only two errors I found in the application event log, and nothing in the system event log except service start and terminated unexpectedly messages.

                                   

                                  Ken

                                   

                                  1000.JPG

                                  1001.JPG

                                  • 14. Re: Softmon.exe - Runtime error
                                    Apprentice

                                    No .net errors in my event viewer either.

                                     

                                    So far, this is what I have from LD support.  I think this is part of my issue, but not the whole thing.

                                     

                                    Are the agents setup to use LANDesk real time spyware scanning? One of the things that Softmon.exe does is the real time spyware scanning. The spyware definitions are loaded into memory by Softmon.exe and it monitors files and registry.

                                      Their are other files that are associated with security and patch operations like Antivirus and Patching. Vulscan.exe can also run a spyware scan but is not specifically associated with real time spyware scanning.

                                      Softmon.exe uses some of the other files from security and patch to load the spyware definitions into memory and constantly scan for them.

                                      When Vulscan.exe runs on a computer it will check with the core server to identify if there is a newer version of security and patch files. If it finds newer versions of the files Vulscan.exe will copy the new security and patch files to the client, shut down and restart with the new files.

                                      If a patch of the security files required a new version of Softmon.exe for compatibility between Softmon.exe and security and patch this will cause instability in Softmon.exe.

                                      Please do the following to resolve the issue:

                                      1) In the 32 bit console go to the agent configuration and click the button labeled rebuild all
                                      2) Right click on the agent and click to create a new advance agent
                                      3) Schedule the deploy of the advance agent (green button circle with 2 arrows)
                                      4) Deploy the agent out to your computers

                                      These steps will assure that the files all match.

                                    1 2 3 4 Previous Next