3 Replies Latest reply on Apr 1, 2004 10:40 AM by Support_1

    Failed: Flagged 'Service Only'

    ku Rookie
      Hello
      I need to autoinstall patch for antivirus program. Installation is machine related. I setup permission for autoinstall as '*' and I setup proper time-frame for autoinstall.
      But instead of installation there is only a line: Failed: Flagged 'Service Only' in log file.
      If I switch off 'Install via service' then installation starts ( and fails of course because of lack of user rights ). Can anybody help me what can be the reason for this. We have version 5.56.

      Thanks
        • 1. Re: Failed: Flagged 'Service Only'
          Support_1 Specialist
          You have 2 choices, either have the project be installed by the NetInstall Service. In this case you leave the box checked that says 'Install via Service' then the installation will occur when the service starts the service installer. You'll see the service polling in the log file named NISRV32.log

          The second option is to have the installation performed by the autoinstaller. In this situation you must set the project to TUS and the command must be set to 'machine related service executed' in the script editor. Now the user will begin the installation project but pass that command of for execution via the service.
          • 2. Re: Failed: Flagged 'Service Only'
            ku Rookie
            Thanks for reply, it's clearer now.
            I only need one small clarification. For this installation to occur ( via service ), the switch 'Keep agent resident' must be set to 'yes' ?

            If 'Keep agent resident' were switched off then installation wouldn't start  or start only after user logon and nilogin.bat is started ?

            Thanks
            • 3. Re: Failed: Flagged 'Service Only'
              Support_1 Specialist
              the 'keep agent resident' setting would only have any effect if you were using option 2.

              the agent and the service are 2 completely separate things and have nothing to do with one another.