0 Replies Latest reply on Jun 7, 2006 5:21 AM by DSMForum

    DCOM Objekt registriert sich nicht - SW Gaeb Tool Box v1.2

    DSMForum Master
      Hallo NI Gemeinde,

      ich moechte die SW Gaeb Tool Box v1.2 per Netinstall verteilen.
      Bei der Verteilung muss über Netinstall die GAEB-Toolbox (COM-Objekt)
      installiert (registriert) werden:

      Hierzu bei der Installation über Netinstall die Datei GAEB2K12.EXE
      ausführen. Dadurch installiert

      (registriert) sich die GAEB-Toolbox selber. Ob das COM-Objekt korrekt
      installiert wurde, lässt sich wie folgt

      überprüfen:

      Start -> Einstellungen ->Systemsteuerung -> Verwaltung ->Komponentendienste.

      Innerhalb der Komponentendienste den Pfad:

      Component Services -> Computer -> Arbeitsplatz -> DCOM-Konfiguration
      auswählen. Unter DCOM-Konfiguration muss

      der Eintrag GAEB2000 Toolbox Version 1.2 zu sehen sein.

      Leider bekomme ich die Registrierung des COM Objektes nicht hin.

      Weder per SPY noch als Run AS , Execute per Service (GAEB2K12.EXE
      /regserver) wird die Gaeb Tool Box registriert.

      Es geht nur wenn ich lokaler Admin bin! bei normale Anwender funktioniert es
      nicht!

      Kennt sich jemand mit dieser Problematik aus?

      Wie kann ich die Toolbox registrieren ohne dass ich lokaler Admin bin?

      Ich habe auch ein NI script gebastelt, das dem User lokale Admin Rechte
      gibt, danach Logoff , Anmelden, Toolbox installieren , Adminrechte weg,

      Funktioniert aber auch nicht., da NI oder OS nach dem Login nicht gleich
      mitbekommen das User jetzt Admin ist.

      Ich habe nach dem Login auch schon ein Sleep eingebaut...

      Fuer jede Hilfe bin ich dankbar!

      Gruss

      Timo






      ..