5 Replies Latest reply on Mar 20, 2009 8:33 AM by Silvercoupe

    PXE Rep Problem




      I have just come to capture an image using linux PE and received the following error( i have used this previously with no issues )

      no updatres have been made to the lndesk server or the PXE rep


      timed out waiting for a valid DHCP server response

      starting menu

      landesk : 6 , Could not resolve host

      and error occured retreiving menu files , cannot start boot menu

      taskmaster complete


      1. booted the card from the NIC
      2. stops at the Linux PE menu with the above error
      3. i have removed and added the PXE rep on the same server
      4. i have installed the PXE rep to a different server
      5. i have restarted the landesk server


      Sorry but i have no idea where the error logs are kept for further info. Any help would be great


      As i said this was working untill a few days ago ?



        • 1. Re: PXE Rep Problem

          Any ideas where to begin with this one guys ??


          Many thanks

          • 2. Re: PXE Rep Problem
            phoffmann SupportEmployee

            What do you use as DHCP server? I've seen Unix/Linux DHCP servers cause problems in this sort of scenario (we usually expect having a Microsoft DHCP server, and that's the only that's supported).


            That's the only thing that comes to mind on the quick as to why things would fail on getting a DHCP response.


            Alternatively, run a network trace, to see what host is being attempted to be resolved. Maybe a "phantom" DHCP server has left some artifacts of itself and is being attempted to be contacted (sounds unlikely, I admit, but I did see this once).


            Paul Hoffmann

            LANDesk EMEA Technical Lead

            • 3. Re: PXE Rep Problem

              I am using windows as my DHCP  i have resolved this by dropping the clients DHCP address and renewing  this and a restart of the DHCP server .. Strange !


              I have a question about PXE reps on remote sites will this work ?


              My core server is here in the UK


              I need to use OS deplyoment in our office in France .. Can i just install a PXE rep in France and create an image share for deployment in France

              copy the images from my UK share and ammend the scripts to point to the france share ?


              Will the PC's go straight to the PXE rep in there subnet and ignore the PXE rep in the UK


              Many thanks

              • 4. Re: PXE Rep Problem
                phoffmann SupportEmployee

                Yes, systems should always get their "own local" PXE rep, unless you've got some very weird networking issues.


                The simple "first come, first served" rule takes care of that.


                Paul Hoffmann

                LANDesk EMEA Technical Lead

                • 5. Re: PXE Rep Problem
                  Silvercoupe Apprentice

                  Hi delhuskie,


                  Sorry if you've already been down this path, but have you verified the correct drivers are in your LinuxPE image?  You might be able to pull the RAMDISK from the PXE rep but if the PE environment doesn't have the NIC driver for your hardware it will fail.  Are you trying this with new or different hardware than what used to work?