1 Reply Latest reply on Jun 8, 2006 2:35 AM by Frank.Scholer

    [SOLVED] Insert Disk with Batch File ??

    Michael1 Apprentice

      Hallo zusammen,

      seit geraumer Zeit bekomme ich Probleme  mit der Aufnahme von neuen PCs in
      die OSD Datenbank, was eigentlich früher immer funktioniert hat.

      Beispiel:

      Ein neuer PC wird eingescannt (per Boot Disk) und ich bekomme die
      Fehlermeldung Insert Disk with Batch File.Dazu muß gesagt werden, daß der PC
      vorher nicht nicht in der Datenbank vorhanden war!

      Nach einem Warmstart funktioniert alles reibungslos und ich kann den PC in
      der OSD Datenbank für eine Installation berechtigen.Das war vorher nicht so
      und ich hab für dieses Phänomen auch keine Erklärung, warum jetzt 2 Anläufe
      benötigt werden.



      Gestern hatte ich dann den Fall, daß ich ein Notebook neu installieren
      mußte, welches schon mal in der OSD Datenbank stand. Da es für ein anderes
      Subnetz benötigt wurde, habe ich den alten Eintrag in der OSD Datenbank
      gelöscht und habe versucht den Rechner neu zu scannen, was beim besten
      Willen nicht funktionieren wollte. Immer trat die besagt Meldung auf Insert
      Disk with Batchfile, worauf ich mehrere Warmstarts machte.

      Es hat alles nichts geholfen.

      Dann habe ich mal versucht das Notebook mit einer anderen Dockingstation
      einzuscannen (die Hardware könnte ja defekt sein), was funktionierte, aber
      leider erschien der Rechner nicht in der OSD Datenbank.



      So langsam weiß ich nicht mehr weiter, da an der Konfiguration nichts
      geändert wurde.

      Im Eventlog auf dem OSD Server ist mir mal aufgefallen, daß die Datenbank
      (MSDE) irgendwann einen falschen oder doppelten Mac Adresseneintrag hatte,
      was aber nicht weiter gestört hat.



      Hat jemand eine Idee, warum ich plötzlich solche Probleme habe, obwohl
      nichts geändert wurde.

      Könnte es sein, daß die OSD Datenbank fehlerhaft ist?

      Interessanterweise ließ sich danach ein anderer PC Typ (Desktop) problemlos
      scannen und tauchte in der Datenbank auf.

      Gruß

      Michael





      ..
        • 1. Re: [SOLVED] Insert Disk with Batch File ??
          Frank.Scholer Master
          Hallo Michael,

          das Verhalten, das du beschreibst, ist kein Fehler sondern gehört so
          (auch wenn's ein bissi komisch ist - ich geb's zu...)

          Ich versuch's mal einigermaßen kurz zu erklären:
          Wenn du nen Rechner mit ner (mit dem OSD Bootdisketten Assistent
          erstellten) Diskette bootest, bootest du ja ein DOS mit
          NDIS2-Netzwerkkarten Treiber. Auf diesem Treiber setzt ein Progrämmchen
          auf, das ein BootProm emuliert.

          Wenn der Rechner jetzt in der DB den Status inaktiv hat, kriegt er das
          BootImage HDBOOT (er soll ja von Diskette booten), soll er OSD-mäßig was
          tun, kriegt er den Namen eines der "richtigen" Bootimages (z.B. NEU.PX),
          bei denen es sich auch wieder um Images von DOS-Disketten handelt.

          Da man aber auch DOS raus nicht nochmal DOS booten kann, wird dem (oben
          angesprochenen Progrämmchen) der Name eines Batchfiles mitgegeben, das
          er in dem heruntergeladenen Bootimage starten soll (Prorun.bat).

          Bei den PX-Files funzt das auch, aber in dem HDBOOT-Image gibt's so'n
          File nicht (ist nur ein Binary, das einfach den Festplatten-Bootsektor
          anspringt) und deswegen motzt DOS, dass man die Diskette einlegen seoll,
          wo dieses Batchfile drin ist...

          Lange Rede, kurzer Sinn: Immer wenn ein Rechner in OSD drin ist, und den
          Status inaktiv hat (z.B. nach dem ersten "einscannen") und du bootest in
          mit ner NDIS-Disk, tritt das beschriebene Phänomen auf.

          Übrigens: wenn du ein Notebook in ne Docking-Station packst, verwendet
          OSD logischerweise die MAC-Adresse der in der Docking Station
          eingebauten Netzwerkkarte! Da musst du aufpassen (so lassen sich nämlich
          auch deine anderen Phänomene erklären)...

          HTH, Gruß Frank

          Michael schrieb:
          > Hallo zusammen,
          >
          > seit geraumer Zeit bekomme ich Probleme  mit der Aufnahme von neuen PCs in
          > die OSD Datenbank, was eigentlich früher immer funktioniert hat.
          >
          > Beispiel:
          >
          > Ein neuer PC wird eingescannt (per Boot Disk) und ich bekomme die
          > Fehlermeldung Insert Disk with Batch File.Dazu muß gesagt werden, daß der PC
          > vorher nicht nicht in der Datenbank vorhanden war!
          >
          > Nach einem Warmstart funktioniert alles reibungslos und ich kann den PC in
          > der OSD Datenbank für eine Installation berechtigen.Das war vorher nicht so
          > und ich hab für dieses Phänomen auch keine Erklärung, warum jetzt 2 Anläufe
          > benötigt werden.
          >
          >
          >
          > Gestern hatte ich dann den Fall, daß ich ein Notebook neu installieren
          > mußte, welches schon mal in der OSD Datenbank stand. Da es für ein anderes
          > Subnetz benötigt wurde, habe ich den alten Eintrag in der OSD Datenbank
          > gelöscht und habe versucht den Rechner neu zu scannen, was beim besten
          > Willen nicht funktionieren wollte. Immer trat die besagt Meldung auf Insert
          > Disk with Batchfile, worauf ich mehrere Warmstarts machte.
          >
          > Es hat alles nichts geholfen.
          >
          > Dann habe ich mal versucht das Notebook mit einer anderen Dockingstation
          > einzuscannen (die Hardware könnte ja defekt sein), was funktionierte, aber
          > leider erschien der Rechner nicht in der OSD Datenbank.
          >
          >
          >
          > So langsam weiß ich nicht mehr weiter, da an der Konfiguration nichts
          > geändert wurde.
          >
          > Im Eventlog auf dem OSD Server ist mir mal aufgefallen, daß die Datenbank
          > (MSDE) irgendwann einen falschen oder doppelten Mac Adresseneintrag hatte,
          > was aber nicht weiter gestört hat.
          >
          >
          >
          > Hat jemand eine Idee, warum ich plötzlich solche Probleme habe, obwohl
          > nichts geändert wurde.
          >
          > Könnte es sein, daß die OSD Datenbank fehlerhaft ist?
          >
          > Interessanterweise ließ sich danach ein anderer PC Typ (Desktop) problemlos
          > scannen und tauchte in der Datenbank auf.
          >
          > Gruß
          >
          > Michael
          >
          >
          >
          >
          >


          ..