2 Replies Latest reply on Jun 8, 2006 2:38 AM by DSMForum

    Compaq EVO D510

    DSMForum Master
      Hallo,

      wir wollen Win XP auf mehreren Compaq EVO 510 mit OSD 3.1 aufsetzen. Leider
      wird die Netzkarte nicht unter XP erkannt (PXE-Boot funktioniert aber ohne
      Probleme). Neue Treiber von Compaq sind auch vorhanden. Leider sind die
      Treiber mit Verzeichnisstruktur:

      INF-File
      |---windows\drivers\ia32\

      Die Treiber kann ich nun im OSD mit der richtigen Struktur in die "lan.zip"
      schieben. Beim Auspacken werden aber halt alle Files ohne Unterverzeichnisse
      nach c:\drivers\lan entpackt und die Installation der Netzkarte scheitert.

      Hat jemand einen Tip, wie wir den Treiber autom. installiert bekommen, z.B.
      Entpacken der lan.zip inkl. Verzeichnisstruktur?

      Danke im voraus

      Bernd


      ..
        • 1. Re: Compaq EVO D510
          Frank.Scholer Master
          Hallo Bernd,

          das LAN.ZIP wird innerhalb der Datei ProSetup.bat die im Verzeichnis
          BCTFTP\Setup\WXPPROD (bei deutschem XP) liegt entpackt.
          Die betreffende Zeile ist:
          "IF EXIST c:\drivers\lan.zip C:\$bcsetup\pkunzip.exe -o
          c:\drivers\lan.zip c:\drivers\lan > NUL"

          Diese solltest du ändern auf:
          "IF EXIST c:\drivers\lan.zip C:\$bcsetup\pkunzip.exe -o -d
          c:\drivers\lan.zip c:\drivers\lan > NUL"

          Mit dem -d wird pkunzip mitgeteilt beim Entpacken die Unterverzeichnisse
          zu berücksichtigen. Ob das dann allerdings auch so funzt (sprich das XP
          Setup da reinguckt) weiss ich nicht (Versuch macht kluch... ;-)

          Als Alternative (sollte es nicht hinhauen) kannst du ja versuchen das
          OEMSETUP.INF zu editieren und die Referenzen auf die Unterverzeichnisse
          rauszunehmen...

          HTH, Gruß Frank

          Bernd Thalmann wrote:

          > Hallo,
          >
          > wir wollen Win XP auf mehreren Compaq EVO 510 mit OSD 3.1 aufsetzen. Leider
          > wird die Netzkarte nicht unter XP erkannt (PXE-Boot funktioniert aber ohne
          > Probleme). Neue Treiber von Compaq sind auch vorhanden. Leider sind die
          > Treiber mit Verzeichnisstruktur:
          >
          > INF-File
          > |---windows\drivers\ia32\
          >
          > Die Treiber kann ich nun im OSD mit der richtigen Struktur in die "lan.zip"
          > schieben. Beim Auspacken werden aber halt alle Files ohne Unterverzeichnisse
          > nach c:\drivers\lan entpackt und die Installation der Netzkarte scheitert.
          >
          > Hat jemand einen Tip, wie wir den Treiber autom. installiert bekommen, z.B.
          > Entpacken der lan.zip inkl. Verzeichnisstruktur?
          >
          > Danke im voraus
          >
          > Bernd
          >
          >
          >


          ..
          • 2. Re: Compaq EVO D510
            DSMForum Master
            Hallo,

            >Mit dem -d wird pkunzip mitgeteilt beim Entpacken die Unterverzeichnisse
            >zu berücksichtigen. Ob das dann allerdings auch so funzt (sprich das XP
            >Setup da reinguckt) weiss ich nicht (Versuch macht kluch... ;-)

            Das funktioniert leider nur, wenn man die UNATTEND.TXT entsprechend um
            diesen "weiteren" Pfad erweitert.

            >Als Alternative (sollte es nicht hinhauen) kannst du ja versuchen das
            >OEMSETUP.INF zu editieren und die Referenzen auf die Unterverzeichnisse
            >rauszunehmen...

            Ich hatte den gleichen Fall vor kurzem mit der EVO D300M Serie. Die Compaq
            Treiber für die integrierte Intel Netzwerkkarte hatten leider in der INF
            Datei die beschriebenen Pfadangaben.

            Ich habe an der Stelle die INF Datei angepasst -- lief dann auch so
            problemlos*:

            INF Datei: neti557x.inf

            - vorher:
            [SourceDisksFiles]
            net82557.din = 1,\WINDOWS\DRIVERS\IA32
            e100bnt5.sys = 1,\WINDOWS\DRIVERS\IA32
            e100b325.sys = 1,\WINDOWS\DRIVERS\IA32
            Prounstl.exe = 1,\WINDOWS\DRIVERS\IA32
            IntelNic.dll = 1,\WINDOWS\DRIVERS\IA32

            - nach Anpassung:
            [SourceDisksFiles]
            net82557.din = 1
            e100bnt5.sys = 1
            e100b325.sys = 1
            Prounstl.exe = 1
            IntelNic.dll = 1

            Hier kann mann auch wunderbar sehen, welche Dateien man überhaupt in die
            ZIP Datei packen muss - auch für andere Treiberinstallationen hifreich ;o)


            * bis auf die Tatsache, daß bei der von mir verwendeten, aktuellsten
            Version (sowohl von intel.com als auch compaq.com) das Zertifikat für die
            Treibersignierung ungültig war und die Treiber nicht installiert wurden.
            Diesen Fehler konnte ich beheben, indem ich eine "ältere" Treiberversion
            verwendete (gab's damals noch bei compaq.com)...


            Gruss,

            Markus Michalski
            ..