2 Replies Latest reply on Dec 13, 2006 11:59 PM by DennyKirchhof

    NIINST32.EXE startet automatisch beim Systemstart

    DennyKirchhof Apprentice
      Hallo zusammen

      ich habe mal wieder nen kleines Problem. Beim uns im Netzwerk ist seit heute mittag etwas nicht ganz koscher.

      Seit ca. 11:45 Uhr wird auf allen Clients in einem Netzwerk mit ca 250 Rechnern die Datei NIINST32.EXE ausgeführt. Hierzu muss ich sagen, dass die User keine Möglichkeit haben diese Anwendung zu starten. Es gibt keinen Link zu dieser Anwendung und die Option "Ausführen" ist für die User deaktiviert.

      Dieser Prozess verursacht eine enorme CPU-Last(Rechnertyp abhängig 50-99%). Es wird kein interaktiver Netinstall-Dienst gestartet. Beendet man diesen Prozess über den Taskmanager kann man mit den PCs wieder ganz normal weiterarbeiten.

      Curioserweise wird dieser Prozess auch nach einem System-Neustart erneut gestartet.

      Kann es evtl damit zusammenhängen, dass ich den Server auf welchem Netinstall installiert läuft, heute Mittag(nach 11:45 Uhr) neu gestartet habe?

      Auch hatte ich ein kleines Problem mit der "Nidb.nid"-Datei. Musste sie aus einer VolumeShadowCopy-Sicherung von heute morgen 07:00 wieder neu herstellen, da mir die .nid- und ba2-Datei im Work-Verz. verloren gegangen sind. Nach der Herstellung der .nid-Datei lief die DB wieder einwandfrei.

      Kann sich jemand einen Reim aus den von mir geschilderten Problemen machen oder versteckt sich evtl ein Virus hinter diesem Prozess?

      Für schnelle Hilfe wäre ich dankbar.


      Gruß

      Denny
        • 1. Re: NIINST32.EXE startet automatisch beim Systemstart
          Frank.Scholer Master
          Hallo Denny,

          ohne Logfiles ist jetzt natürlich schwer was genaues zu sagen - aber nen Verdacht hab ich doch:
          Also erstmal vorweg: mit dem Reboot kann's nix zu tun haben...

          Ich denke, das Problem hängt mir der zerschossenen NI-Datenbank zusammen. Der Prozess NIINST32.EXE ist in dem Fall der AutoInstaller, der versucht die Datenbank auszuwerten und dabei augenscheinlich größere Schwierigkeiten hat (warum auch immer - hier würde ein Blick ins NIAI32.LOG sicher Erhellung bringen).

          Der AutoInstaller wird ja vom NetInstall Agent (NIAGNT32.EXE) gestartet durch das Login-Script (vermute ich). Du könntest also vorübergehend mal den Aufruf des Agents aus dem Login-Script auskommentieren, um in Ruhe troubleshooten zu können.

          Es könnte natürlich auch sein, dass es der Service Installer (der durch den NI Service beim Systemstart gestartet wird) ist - das siehst du aber im Taskmanager, unter welchem Account der Prozess auseführt wird (User oder Service-Konto). Wenn's der Service-Installer ist, würde ich erstmal im NetInstall-Share eine Datei mit dem Namen "Update.$$$" anlegen. Das ist so ne Art "Not-Aus" für NI. Und dann musst du vermutlich jemand fragen, der sich gut mit NI auskennt und da mal nen Blick drauf wirft (ist ein bißchen arg kompliziert das alles hier zu schreiben).

          Vielleicht kommst du ja damit schonmal weiter...

          Viel erfolg und Gruß
          Frank
          • 2. Re: NIINST32.EXE startet automatisch beim Systemstart
            DennyKirchhof Apprentice
            Hallo Frank,

            nen Koll hat gestern abend noch die komplette VolumeShadowCopy-Sicherung zurückgespielt. Das Problem scheint nun behoben. NIINST32.EXE wird nicht mehr ausgeführt.

            Danke für deine schnelle Antwort.

            Gruß

            Denny