8 Replies Latest reply on Apr 13, 2007 3:57 AM by Torben

    Distribution einrichten

    Marcel66 Rookie
      Hallo

      Habe bei mir v6 installiert und mal ein Software-Paket erstellt. Ich möchte nun die Distribution einrichten. Dies funktioniert leider nicht. Ich habe dem angemeldeten User volle Rechte auf den enteo$-Share gegeben und der Distributionsservice wird mit dem lokalen System-User ausgeführt.

      Kann mir da jemand weiterhelfen? Muss ich noch weitere Konfigurationen vornehmen?
        • 1. Re: Distribution einrichten
          CalumField1 Expert
          Tag,

          Die Distribution läuft nach die Installation eigentlich völlig automatisiert ohne, dass man irgendwelche Rechte an Verzeichnisse ändern muss.

          Beim Installation von V6 muss man ja das Konto für das Distributiondienst angeben (Distro Dienst erhält ja Schreib/Lese rechte auf das enteo$ Share).
          Netinstall Users benötigen lediglich lese Zugriff auf das enteo$ Share.


          Läuft dann uberhaupt der Distribution Dienst - was für Meldungen bekommst Du?
          Was sagen die Logdateien?

          Gruß

          Calum
          • 2. Re: Distribution einrichten
            Marcel66 Rookie
            Hallo

            Der Dienst läuft. Wenn ich z.B. den Distributionsstatus auf Site-Ebene anschaue hat die Distribution auch funktioniert. Aber wenn ich unter Manage Software ein neues Software-Paket erstelle, Verteilung vorbereiten wähle und dann Distribution einrichten wähle, passiert gar nichts.

            In welchen Logfiles bekomme ich dazu mehr Informationen?

            Vielen Dank für deine Hilfe.
            • 3. Re: Distribution einrichten
              CalumField1 Expert
              Tag,

              die Logs findest du in %programfilesdir%
              etinst
              ilogs.
              Es gibt nun diverse Logs, wie zB.  -

              FpsDist_Prepare65963.log_00000000004.log
              fpsdistributionserviceSVC_0000000003.log
              FpsDist_Nid65963.log_00000000004.log


              Weiterhin gibt es den Dienst enteo Distribution Dienst - services.msc - prufen ob diese läuft.


              Gruß

              Calum
              • 4. Re: Distribution einrichten
                Torben Rookie
                Hallo,

                das Problem mit dem Distributionsstatus habe ich auch. Wenn ich ein neues Packet erstelle wird es entweder recht schnell im Status als Aktuell angezeigt oder es passiert nichts und der Status bleibt über Stunden "Paket nicht vorhanden".
                • 5. Re: Distribution einrichten
                  CalumField1 Expert
                  Tag,

                  Die Einstellungen für das Distributionsdienst sind unter:
                  Manage Infrastruktur | Distributionseinstellungen

                  Dort steht Pollinginterval für Paket - Vorbereitung - 30mins.


                  Ich habe gerade ein Testscript erstellt, und dies war innerhalb 10 Mins repliziert worden.

                  - Erstelle noch ein Script
                  - Verteilung vorbereiten
                  - Distribution einrichten
                  - Paket Freigeben
                  (- Distributiondienst neustarten)

                  und das Skript sollte ja ziemlich zeitnäh repliziert werden.



                  Gruß

                  Calum
                  • 6. Re: Distribution einrichten
                    Torben Rookie
                    Ja die Einstellungen sind mir bekannt.
                    Dennoch warte ich das ein "OS Configuration Packages" bei dem ich um 10.00 Uhr gesagt habe "Distribution einrichten" sich repliziert. Nun ist es 13.00 Uhr und das Paket ist nicht vorhanden.
                    Gestern z.B. habe ich ein Paket erstellt bei dem sich das Verhalten mit deinen Aussagen deckt "...dies war innerhalb 10 Mins repliziert worden."
                    Doch ab und an läuft die Replizierung halt nicht.

                    Evtl. hat das mit einem anderen Fehler zu tun. Ich hatte dem Support gemeldet das mein Server auf 100% CPU-Last läuft. Der Prozess mgmtagnt.exe (1 von den 8) läuft oft mit 90-99 % CPU-Last.
                    • 7. Re: Distribution einrichten
                      CalumField1 Expert
                      Tag,

                      also ich kann nur ein Teil zustimmen -beim Replikation kommt es auch bei mir zu eine höhe CPU-Läst.

                      Gestern Nachmittag habe ich Windows 2003 als test freigegeben und heute morgen habe ich XP freigegeben, und beide waren wohl innerhalb 30 Minuten (ohne den Distribution Dienst neustarten zu müssen) repliziert worden.

                      Um die Fehler oder nicht optimale Konfiguration nachzugehen schlage ich folgendes vor :

                      Distribution Dienst Einstellungen prufen
                      Log dateien anschauen
                      Nachdem der OS freigegeben worden ist - Distribution Dienst neustarten.



                      Gruß

                      Calum
                      • 8. Re: Distribution einrichten
                        Torben Rookie
                        Hallo,

                        ob es an meiner Konfiguration lag glaube ich nicht da ich die Installation mit dem Enteo-Support durchgegangen bin.
                        Die Last kommt von "OSD Service" evtl. ist dieser bei der Installation nicht sauber gewesen.
                        Also habe ich den Server noch einmal aufgesetzt und im Moment sieht es ganz gut aus.
                        Replizieren funktioniert und die CPU-Last ist auch normal. (ich hoffe das bleibt so)