8 Replies Latest reply on Mar 31, 2009 10:33 AM by Silvercoupe

    Office 2k7 hangs after "Start Now"

    Silvercoupe Apprentice

      Yesterday afternoon I built an Office 2007 package following the BKM from LANDesk .  I added my test box and clicked "Start Now".  In the task window on the console the machine status was "Active", but nothing was occuring on the test box.  I let it sit for over an hour before I left for the day.  When I came in this morning the target machine had gone to sleep and the task reported "Failed, Cannot find agent", which tells me that at some point the task tried to run.

       

      I restarted the task this morning and it went through immediately.  Office 2k7 installed and immediately rebooted (wish I could get rid of that reboot with the Customization Tool), but the task reported as failed, even though the message stated successfull install but reboot required.

       

      I saw some changes I wanted to make in the delivery and feedback so I made the changes and re-hashed the package.  I removed Office 2007 from the target box, rebooted and clicked "Start Now" on the task.  Now it's doing the same thing as yesterday afternoon, task is just sitting at Active and nothing is happening on the test box.

       

      Package is configured as=

       

      Primary File=Setup.exe

      Addiotnal files=All additional folders and MSP on webshare

       

      Delivery method=

       

      Download from Source

      No MultiCast

      No Dynamic Bandwidth Throttling

      Display Progress with Deferral

       

       

      Can anyone shed some light on what might be causing the task to just hang out?

       

      Thanks,

       

      Mike

        • 1. Re: Office 2k7 hangs after "Start Now"
          Silvercoupe Apprentice

          One more thing:  while waiting for Office to begin the install I was able to successfully deploy a different package to the same test box.  So I know the box is up and responding.  I have had this "hanging" happen before on other packages so I don't think it's specifically related to Office 2k7.

          • 2. Re: Office 2k7 hangs after "Start Now"
            Silvercoupe Apprentice

            Great, I'm making a habit of answering my own questions.....

             

            So I found out what's happening.  I decided to recreate the package completely.  I set up a MC Cache Only job to push it down to our local domain rep.  Did the same thing, just sat there.  I checked the Task log on the CORE and in the last 10 minutes it has only calculated the Hash of 8 of the 200+ files on the web share.

             

            Am I doing something wrong or is this truly out of the ordinary?  The server does not appear to be under any significant load so this process should be very fast.

            • 3. Re: Office 2k7 hangs after "Start Now"
              Silvercoupe Apprentice

              OK now I'm worried... 3 responses to this discussion, all from me.

               

              I saw in another discussion that LDREDIRECT could be the issue.  Will contact Tech Support and see if that's the fix.

              • 5. Re: Office 2k7 hangs after "Start Now"
                mrspike SSMMVPGroup

                My bet is if you are having hashing issues it is the ldredirect as you said.  We had the same issue and it solved it.

                • 6. Re: Office 2k7 hangs after "Start Now"
                  Silvercoupe Apprentice

                  Jack,

                   

                  For the most part, however I have a newer version of LDDWNLD than the one referenced in the patch.  It looks like I do need to update my TMC file.

                   

                  I wound up going a different route with the deploy of O2K7.  I packaged it up as a single self-extracting file and created a Windows Script Host deploy package that uses a VBS to do the install.  I like using VBS because I can more accurately control multiple-stage installations.  In this case I unpack the self-contained file, run SETUP.EXE with a custom MSP file, then I run the SAVEASPDF converter for O2K7 then some additonal commands to copy shortcuts to ALLUSERS.  The VBS works great for this because the task doesn't report successful until the entire script completes.  I've had issues with other self-contained EXEs that also run commands (WINRAR) where once the "unpacking" stage finishes, LANDesk thinks the installation is done.

                   

                  I've got an open case with Support and they have provided me the LDREDIRECT patch.

                  • 7. Re: Office 2k7 hangs after "Start Now"
                    Employee

                    that level of effort hasn't been necessary with most of the office 2007 deployments I've been on, but it does sometimes happen. Zipping is done from time to time, and can make a difference where there's more cpu than network.

                    • 8. Re: Office 2k7 hangs after "Start Now"
                      Silvercoupe Apprentice

                      The other reason I chose to go this route was to ensure the install point was always available (I unpack the install files to a local folder before installing).  Correct me if I'm wrong, but if the package is MCast to the workstation and run from SDMCACHE, 2 days later the install point is no longer there.  I know in the ADMIN setup for O2K7 you can set up alternate install points, but do these still function AFTER the software is installed?  If an add-on was pushed that needed the original install files, or a service pack etc., would the alternate install points be searched since SDMCACHE would have purged itself?