3 Replies Latest reply on Jul 9, 2007 10:54 AM by SebastianAlmer

    Problem beim Paket löschen

    ischaefer Rookie
      Hallo,

      ich habe ein seltsames Problem, wenn ich ein Paket löschen möchte. Ursprünglich war das Paket in einem Software Set als Komponente freigegeben.
      Beim Aufruf „retire Paket“ gab es beim löschen der aktiven Policies eine Fehlermeldung:

      Error #-536608565: the schema tag `SwSetComponentPolicy` of the policy is unknown.


      Wenn ich versuche, das Paket zu löschen, kommt dann natürlich der Fehler, das das Paket noch aktive Policies hat. Ein Return/Retire Produktion bring immer wieder obigen Fehler. Was kann man da wohl machen ?

      Beste Grüsse

      Ingo
        • 1. Re: Problem beim Paket löschen
          AchimBock Apprentice
          Hallo,

          Wenn Sie ein SW Paket löschen wollen, darf es 1. nicht mehr als Komponente eines SW Sets verwendet sein UND 2. es darf keine Policies für das SW Paket mehr geben - dabei ist es egal, ob das SW Paket "selbst" zugewiesen ist oder "indirekt" als Komponente eines zugewiesenen SW Sets.
          Hilft das weiter?

          Viele Grüße,

          Achim Bock
          • 2. Re: Problem beim Paket löschen
            ischaefer Rookie

            Hallo,

            Wenn Sie ein SW Paket löschen wollen, darf es 1. nicht mehr als Komponente eines SW Sets verwendet sein UND 2. es darf keine Policies für das SW Paket mehr geben - dabei ist es egal, ob das SW Paket "selbst" zugewiesen ist oder "indirekt" als Komponente eines zugewiesenen SW Sets.
            Hilft das weiter?

            Viele Grüße,

            Achim Bock



            Hallo,

            Ein retire Paket macht bzw. sollte ja genau das machen. Es währe ziemlich unhandlich, wenn man beim löschen alle Policies per Hand löschen will.
            Was ist, wenn ein Software Set mehrer Revisionen hat, mit diesem Paket
            als Komponente ?

            (Mit den Revisionen  bin ich eh noch nicht eins. Beim OSD, wo ich sie gebrauchen könnte, gibt es keine und wo ich keine will, muss ich sie benutzen. )

            Beste Grüsse

            Ingo
            • 3. Re: Problem beim Paket löschen
              SebastianAlmer Apprentice
              Supergutes Topic!

              Bei mir ist das Problem, dass ich öfters mal Pakete habe, die in SoftwareSets eine Komponente waren. Dann hab ich das Softwareset gelöscht und wollte danach das Paket löschen, was mit genau dem gleichen Fehler nicht mehr ging. Der Ordner im Repository ist übrigens verschwunden und beim Klick auf "Gehe zu Projektverzeichnis" kommt natürlich ein Fehler.

              Den Fehler hab ich auch in mehreren Umgebungen und enteo-Support konnte mir noch nicht weiterhelfen...

              @Achim: Danke für den Hinweis, aber dummerweise ist das Paket jetzt schon verwaist und ich bekomm es nicht mehr aus der Umgebung raus...