3 Replies Latest reply on Nov 23, 2007 12:41 AM by ronny.dressler

    Unable to resolve component, marked as external

    RWA Specialist
      Hi zusammen,

      ich habe hier ein bischen Probleme. Auf manchen Maschinen scheint der Service Probleme zu haben, Komponenten-Projekte aufgrund der GUID zu finden (siehe Logauszug).
      Interessanterweise scheint auch der Manager (auf dem NI Server selbst aufgerufen) damit Probleme zu haben. Start ich den Manager und gehe auf Projekt mit Komponenten, zeigt er mir nur GUIDs. Öffne ich mal eine Datenbank wo die Komponenten drin liegen und gehe wieder zurück auf das Aurufskript, kann er sie auf einmal auflösen...
      Bei der Anzeige vom Manager ist mir das noch relativ egal, aber der Client kann die Komponenten nicht finden/auflösen und somit wird nichts mehr installiert... sehr ärgerlich.

      Jemand eine Idee?

      (NI Version 5.85)

      14:56:20 1    xniDM: Implicitly permitting installation to components of 'Citrix PS 4.5 (w2k3 de)', {5FEBCA98-F156-4756-ABFB-E6AF4E5FAC99}.
      14:56:20 1    xniDM: Permitting installation for {62303C6E-1AE0-4B9D-87B0-5F9FC49D44F5}.
      14:56:20 1    xniDM: Unable to resolve component, marked as external...
      14:56:20 1    xniDM: Permitting installation for {99BD432F-2CDB-4024-8CAE-2F6E38B70A55}.
      14:56:20 1    xniDM: Unable to resolve component, marked as external...
      14:56:20 1    xniDM: Permitting installation for {6AAF5639-F5BB-4A28-ACBB-CF879A7B5A7C}.
      14:56:20 1    xniDM: Unable to resolve component, marked as external...
      14:56:20 1    xniDM: Permitting installation for {F2FC4AED-B240-4090-8A60-B15A338007AF}.
      14:56:20 1    xniDM: Unable to resolve component, marked as external...
      14:56:20 1    xniDM: Permitting installation for {278B3334-442D-4785-9A4A-67F55BEC2F6F}.
      14:56:20 1    xniDM: Unable to resolve component, marked as external...


      Grüße,
      René
        • 1. Re: Unable to resolve component, marked as external
          RWA Specialist
          Lustigerweise habe ich eben eine Art "Workaround" gefunden.

          2 alte Maschinen liefen noch wunderbar durch. Der einzige Unterschied zu den neuen Maschinen (ausser der Hardware): die alten waren als Testmaschinen in NI definiert.
          Hab einfach mal aus Verzweiflung eine der neuen Maschinen ebenfalls als Testmaschine definiert... und schwups.. die Installationen laufen an...

          Sehr seltsam. Soweit ich mich an die Schulungen von damals erinnern kann, ist der Einzige Unterschied einer Testmaschine, das Sie aus dem Workverzeichnis installiert werden, korrekt?

          NTFS Rechte von Work und Install sind die gleichen... Was könnte das denn noch sein?
          • 2. Re: Unable to resolve component, marked as external
            klaus.messmer Apprentice
            Hey,

            also das die Namen der Projekte aus "Fremd-Datenbanken" in der Komponentenliste nicht angezeigt werden habe ich auch, nur das der Client die Pakete nicht findet ist sehr seltsam... Findet er die Projekte gleich zu Beginn im Logfile, an der Stelle wenn alle Datenbanke abgeklappert werden?

            Du verwendest A&D?
            • 3. Re: Unable to resolve component, marked as external
              ronny.dressler Apprentice
              Ich habe das gleiche Problem hier. Allerdings auch noch keine Lösung.
              Im Gunde habe ich nach der Umstellung auf 5.85 nur noch stress mit A&D
              SW wird hier nicht mehr installiert ...