9 Replies Latest reply on Nov 27, 2007 11:59 AM by Frank.Scholer

    OSD 3.20 & Windows 2003 x64 - Teil 2

    nonnenmacherh Apprentice
      Hi *,

      so jetzt startet das ISO-File per PXE, aber es will partout nicht die Schritte Partitionierung und Formatierung durchführen....
      ich habe mal 'nur' Partitionieren und formatieren eingestellt aber statt der erwarteten Schritte kommt:


      Starting OSD...
              1 file(s) copied.


      ProUtil64 1.2.1
      (c) 2006 Network Competence Service GmbH

      Usage:
      ProUtil64  -t ......
      ProUtil64  -w
      .
      .
      .
      -b:bootsrv If given, ignore OSD bootserver.......

      Downloading setup-files from OSD server

      ProUtil64 1.2.1
      (c) 2006 Network Competence Service GmbH

      Usage:
      ProUtil64  -t ......
      ProUtil64  -w
      .
      .
      .
      -b:bootsrv If given, ignore OSD bootserver.......

      ProUtil64 1.2.1
      (c) 2006 Network Competence Service GmbH

      Usage:
      ProUtil64  -t ......
      ProUtil64  -w
      .
      .
      .
      -b:bootsrv If given, ignore OSD bootserver.......

            1 file(s) copied.

      ====> REBOOT  
        • 1. Re: OSD 3.20 & Windows 2003 x64 - Teil 2
          Frank.Scholer Master
          Hallo Heiko,

          wenn die Usage von PROUTIL kommt, dann heißt das, dass die Datei GETOSDFILES.CMD nicht richtig gepatcht wurde (der Aufruf zum Patchen dieses Files steht in der STARTNET.CMD).

          In aller Regel liegt das daran, dass die erforderlichen Netzwerktreiber nicht geladen sind.

          Mach doch mal folgendes: brich die Batch-Verarbeitung per STRG + C ab und mach ein IPCONFIG. Was siehst du dann? Mit der Info kann ich dir dann ggfs. weiterhelfen.

          Ach ja, wäre auch interessant zu wissen, welche Netzwerkkarte du genau in dem System hast (educated guess: Broadcom ;-)

          Gruß Frank
          • 2. Re: OSD 3.20 & Windows 2003 x64 - Teil 2
            nonnenmacherh Apprentice
            Hallo Frank,

            jetzt ging mir Deine Antwort zu schnell.....

            also es ist ein DELL PowerEdge 1950 mit 2x Broadcom BCM5708C NetXtreme II Gigabit (onboard) und PERC5-Raidcontroller.
            IP bekommt er, denn wenn ich mitt Ctrl-C abbreche und IPConfig eingebe erhalten beide Interfaces eine IP (manual DHCP)...

            die GETOSDFILES.CMD von R:\ sieht wie folgt aus:
            === GETOSDFILES ====== GETOSDFILES ====== GETOSDFILES ====== GETOSDFILES ===
            :: Create refresh file
            ECHO.>%RAMDRIVE%\SEND

            :: Upload refresh file for extended tags
            PROUTIL.EXE -w #@sip*######### #@caa#######.xt %RAMDRIVE%\SEND

            :: Download setup files
            ECHO Downloading setup-files from OSD server
            ECHO.
            PROUTIL.EXE -t #@sip*######### #@t140*##################\PATCH.LST %RAMDRIVE%\PATCH.LST
            MD %RAMDRIVE%\$BCSETUP
            PROUTIL.EXE -t #@sip*######### #@t140*################## %RAMDRIVE%\$BCSETUP -l:%RAMDRIVE%\PATCH.LST -c:%RAMDRIVE%\OSDVARCACHE.BIN

            :: Patch TAGINFO.INI
            IF EXIST %SYSTEMDRIVE%\I386\TAGINFO.INI COPY %SYSTEMDRIVE%\I386\TAGINFO.INI %RAMDRIVE%\$BCSETUP
            IF EXIST %SYSTEMDRIVE%\AMD64\TAGINFO.INI COPY %SYSTEMDRIVE%\AMD64\TAGINFO.INI %RAMDRIVE%\$BCSETUP
            PROUTIL.EXE -a %RAMDRIVE%\$BCSETUP\TAGINFO.INI -c:%RAMDRIVE%\OSDVARCACHE.BIN

            :LBL_PART
            IF NOT "#@t130*" == "TRUE" GOTO LBL_FORMAT
            ECHO Starting OSD action partitioning
            ECHO.
            CALL %RAMDRIVE%\$BCSETUP\BCPART.CMD

            :LBL_FORMAT
            IF NOT "#@t131*" == "TRUE" GOTO LBL_SETUP
            ECHO Starting OSD action formatting
            ECHO.
            CALL %RAMDRIVE%\$BCSETUP\BCFORMAT.CMD #@t149*########

            :LBL_SETUP
            IF NOT "#@t132*" == "TRUE" GOTO LBL_END
            ECHO Starting OSD action setup
            ECHO.
            CALL %RAMDRIVE%\$BCSETUP\PROSETUP.CMD

            :LBL_FINAL
            CALL %RAMDRIVE%\$BCSETUP\PROFINAL.CMD

            :LBL_END
            === GETOSDFILES ====== GETOSDFILES ====== GETOSDFILES ====== GETOSDFILES ===

            stimmt sieht nicht so wirklich gepatched aus.... woran kann es liegen?

            Gruß
            Heiko
            • 3. Re: OSD 3.20 & Windows 2003 x64 - Teil 2
              Frank.Scholer Master
              Hallo Heiko,

              immerhin ist der Treiber schonmal OK.

              Vemutlich liegt's also (wieder mal) an den zwei Netzwerkkarten. Weil die Anfrage an OSD zum Patchen wird vermutlich über das Interface gesendet, das NICHT in OSD registriert ist (und daher kann OSD die Datei dann auch nicht patchen, weil sie diesen Rechner - den sie ja an der MAC versucht zu idenitifizieren - garnicht kennt). Murphy lässt grüßen...

              Das Allereinfachste wäre mal die zweite Karte im BIOS einfach zu deaktivieren und nochmal zu schauen, ob's dann tut. Müsste eigentlich funzen und ist - wenn du nicht sehr viele Server installieren musst - der schnellste Weg.

              Wenn das keine Option für dich ist, dann muss man versuchen per Script herauszufinden, welches die in OSD verwendete Karte ist. Da gibt's einige Ansätze (z.B. per ODBC die OSD-DB abfragen) und die zu verwendende MAC dann den PROUTIL-Aufrufen per Kommandozeilen-Parameter mitzugeben, aber so richtig geschmeidig (und unaufwändig) ist keiner dieser Ansätze :-(

              HTH, Gruß Frank
              • 4. Re: OSD 3.20 & Windows 2003 x64 - Teil 2
                nonnenmacherh Apprentice
                Hm,

                ich habe schon mal zum Test als Konfiguration meine "(PE)Windows XP 32-bit" gestartet und dort klappt das Partitionieren und Formatieren trotz beider NICs... strange...

                Ok, jedenfalls macht er nach dem disable des zweiten NICs weiter!
                auch wenn ich jetzt vor dem nächsten Rätsel stehe:
                Starting OSD action partitioning

                'R:\$BCSETUP\BCPART.CMD' is not recognized as an internal or external command, operable program or batch file.
                Starting OSD action formatting

                'R:\$BCSETUP\BCFORMAT.CMD' is not recognized as an internal or external command, operable program or batch file.
                Starting OSD action setup

                Wenn ich in R:\$BCSETUP gucke, hat die Schweinebacke die Files nicht kopiert...aber warum... mal gucken....

                Danke erst mal Heiko
                • 5. Re: OSD 3.20 & Windows 2003 x64 - Teil 2
                  nonnenmacherh Apprentice
                  Ok, auch der Fehler ist gefunden... aus Irgendeinem Grund waren die aus der PATCH.LST raus....
                  • 6. Re: OSD 3.20 & Windows 2003 x64 - Teil 2
                    nonnenmacherh Apprentice
                    ich werde noch irrsinnig....

                    dafür hat er jetzt die GETOSDFILES.CMD wiedermal nicht gepatched....
                    kann es sein, dass das ein Timing-Problem ist?

                    Wie ich drauf komme:
                    Breche ich mir CTRL+C ab und starte sie STARTNET.CMD nochmals starte klppt das Patchen des Files GETOSDFILES.CMD ...?!?!?!
                    • 7. Re: OSD 3.20 & Windows 2003 x64 - Teil 2
                      Frank.Scholer Master
                      Das kann schon sein (das mit dem Timing Problem). Dann solltest du aber eigenltich normalerweise sowas kriegen wie "Port 68 in use...".

                      Kann aber keinesfalls schaden, vor dem Patchaufruf mal einen SLEEP von ein paar Sekunden (15 oder so) einzubauen...
                      • 8. Re: OSD 3.20 & Windows 2003 x64 - Teil 2
                        nonnenmacherh Apprentice
                        kaum war in der startnet.cmd eine Zeile eingefügt:

                        ......
                        .........
                        ............
                        call oc2.bat

                        echo waiting 15 Seconds
                        @ping 127.0.0.1 -n 15 -w 1000 >nul


                        uns schon waren die IP-Probleme weg!
                        • 9. Re: OSD 3.20 & Windows 2003 x64 - Teil 2
                          Frank.Scholer Master
                          :-))

                          Alles wird gut...

                          Viele Grüße, Frank