8 Replies Latest reply on Nov 27, 2007 11:58 PM by phumbert

    Autoadmin Logon unter XP 64bit

    phumbert Specialist
      Hat es schon jemand geschafft bei einem 64bit Windows XP mit einem Domain-Account einen AutoAdminLogon durchzuführen? (Wir nutzen NI 5.85)

      Mein Problem ist, dass ich zunächst einen AutoAdminLogon mit dem lokalen Administrator durchführe (funzt), und danach soll sich ein Domain-Account noch mal an der Workstation anmelden um die restliche Software zu installieren (funzt leider nicht).

      Die Keys für den Autologin habe ich vom 32bit Windows genommen und per Befehl extra auf 64bit Hive nutzen gesetzt. Jetzt bleibt er immer in der Anmeldemaske stehen, und im Domain-Feld der Windows Anmeldemaske bleibt immer der lokale Rechnername stehen, ich weis echt nicht mehr wo ich schauen soll, denn auch in dem Wow6432Node habe ich die Einstellungen parallel vorgenommen ...

      Hat jemand einen Tip für mich?
        • 1. Re: Autoadmin Logon unter XP 64bit
          klaus.messmer Apprentice
          Hey Ho,

          ich hatte was ähnliches unter nem Windows Server 2003 x64. Das funktionierte mit AutoAdminLogon unter HKLM\SW\MS\WinNT\CV\Winlogon nur wenn man einen Neustart machte. Vielleicht ist das ähnlich...

          Ich teste gleich nochmal mit XP x64. Muß mur ne Mühle aufsetzen... ;-)

          Greetz
          • 2. Re: Autoadmin Logon unter XP 64bit
            phumbert Specialist
            Nö leider nicht, die Anmeldung klappt leider nie, außer man meldet sich einmal manuell an, dann funktioniert der AutoAdminLogon immer ...
            • 3. Re: Autoadmin Logon unter XP 64bit
              Frank.Scholer Master
              Hallo Peter,

              bisher hatte ich keine Probleme mit dem AutoAdminLogon unter xp64, allerdings liest man immer mal wieder davon, wenn man ein bißchen rumgoogled...

              Unter http://www.passmark.com/forum/showthread.php?t=1319 ist da auch was davon beschrieben und da gibt's so ein kleines Tool, das wohl auch nix anderes macht, als die Regwerte zu setzen (aber ggfs. an der richtigen Stelle?). Kannst das ja mal ausprobieren...

              HTH, Gruß Frank
              • 4. Re: Autoadmin Logon unter XP 64bit
                phumbert Specialist
                Hi Frank!

                Wenn's so einfach wäre ...

                Rausgefunden habe ich schon, dass sowohl im Key HKLM\SW\MS\WinNT\CV\Winlogon als auch im Key HKLM\SW\Wow6432Node\MS\WinNT\CV\Winlogon AutoAdminLogon auf 1 gesetzt werden muss, damit Windows überhaupt versucht einen AutoAdmin Logon durchzuführen.

                Mein Problem ist aber, dass er das Domain-Feld nicht mit der Domäne füllt, sondern immer den lokalen Rechnernamen behält (mit dem Tool das Du gefunden hast funktionierts immerhin einmal, beim zweiten Reboot ist dann aber mit dem gleichen "Feature" Schluss).

                Wenn ich remote auf die Registry gehe, sehe ich klar und deutlich dass die DefaultDomainName richtig gesetzt ist, ich weis nicht was Billyboy da macht ...

                Gruß

                Peter
                • 5. Re: Autoadmin Logon unter XP 64bit
                  phumbert Specialist
                  Hab's rausgefunden.

                  Der Befehlt "RegReadValue" ist nicht 64bit fähig, und wenn man in einem Projekt das nach dem AutoAdminLogon ausgeführt wird versucht das Domänenfeld anhand der Installationsdomäne zu setzen, geht das dann schief.

                  Den "unfähigen" 64bit Befehlt habe ich jetzt mit einer WMI Abfrage ausgeschlossen.

                  Ich denke da bisher noch nicht alles mit 64bit so rund läuft, ist diese Abfrage für manche ganz schön hilfreich ...


                  WMIGetIndexData('\\.\root\cimv2','WIN32_COMPUTERSYSTEM','0','_NI_COMPUTERSYSTEM_')
                  SystemType
                  EndProc
                  If %_NI_COMPUTERSYSTEM_SystemType%='x64-based PC'
                  !Hier Befehl einfügen
                  !
                  If %_NI_COMPUTERSYSTEM_SystemType%='x86-based PC'
                  !Hier Befehl einfügen
                  !
                  • 6. Re: Autoadmin Logon unter XP 64bit
                    oBi Apprentice
                    hi,

                    alternativ kann man die regedit.exe eines x64 auch in z.b. regedit64.exe umbenennen. mit einem execute regedit64.exe /s deinregfile.reg die winlogon werte setzen.

                    cheers

                    obi
                    • 7. Re: Autoadmin Logon unter XP 64bit
                      Frank.Scholer Master
                      Hi Peter,

                      ich würde vorschlagen, du machst auf jeden Fall nen Call auf bei enteo wegen dem Problem mit dem RegReadValue...

                      Grüße Frank
                      • 8. Re: Autoadmin Logon unter XP 64bit
                        phumbert Specialist

                        hi,

                        alternativ kann man die regedit.exe eines x64 auch in z.b. regedit64.exe umbenennen. mit einem execute regedit64.exe /s deinregfile.reg die winlogon werte setzen.

                        cheers

                        obi



                        Also das hat bei mir nicht funktioniert, die Keys sind dann immer im Wow6432Node gelandet -> mglw. weil der Execute von dem 32bit Prozess der Niinst32.exe aufgerufen wird ... (vermute ich einfach).

                        @Frank:
                        Ich wäre lieber froh, wenn Enteo den Call wegen des abstürzenden Managers bei dem Spy von Mentor Graphics WG2005SP3 schnell behebt, aber ich werde das natürlich auch noch erst richtig prüfen (evtl. liegt der Fehler ja doch an mir) und ggf. weiterleiten. Der RegLoad Befehl ist ja auch nicht 64bit fähig (das wusste der Support schon, und hat gesagt es sind eben noch nicht alle Befehle 64bit fähig).
                        Immerhin ist der Call für den CheckPlatform Befehl (da kann man ja nicht zwischen XP und XPx64 unterscheiden) jetzt als Feature Request bei den Entwicklern ...