6 Replies Latest reply on May 1, 2008 2:47 AM by dei

    Performance-Probleme mit NetInstall-Client

    muag Rookie
      Hallo zusammen,

      Ich wollte mal fragen, wie es denn bei euch so mit der Performance auf der Client-Seite ausssieht?

      Wir setzen momentan NetInstall v6.1 ein und stossen immer wieder auf die folgenden Probleme:
      - Hoher CPU-Load: Das System ist komplett ausgelastet bzw. alle Aktionen   
        verzögern sich enorm. Insbesondere wenn sich der NetInstall-Client
        aktuallisiert.
      - Windows-Login: Die Windows-Anmeldung kann bis zu 10min. dauern und dies
        obwohl wir den AutoInstaller auf 5min. gesetzt haben.

      Gruss,
      Rainer
        • 1. Re: Performance-Probleme mit NetInstall-Client
          dei Specialist
          Hi,

          um herauszufinden was genau die hohe CPU-Load erzeugt, ist ein Call beim Support inklusive Logfiles der einfachste weg. Du kannst vorher aber mal folgende Dinge prüfen:

          - Ist Patchmanagement im Einsatz?
          - Ist der CMDB-Cache sehr groß gewurden?
          - Ist nach dem CMDB-Cache löschen das Problem für eine kurze Zeit weg?

          Grüße
          • 2. Re: Performance-Probleme mit NetInstall-Client
            muag Rookie
            Hallo Dirk,

            Erstmals vielen Dank für Deine Tipps.

            Für das Patchmgmt verwenden wir bei uns WSUS. In der EMMC habe ich das
            Modul auf der Hauptorganisation bereits deaktiviert gehabt. Nun habe ich es
            neu auch noch deinstalliert.

            Betreffend des CMDB-Caches, hier verwende ich die Standardoptionen und
            der Cache ist auf der Client-Seite ~3-4MB gross. Jedoch hat mich die Grösse
            des "RepositoryCaches" erstaunt bzw. dieser ist mehrere GBs gross. Für was
            brauche ich diesen auf der Client-Seite und kann man diesen deaktivieren
            oder kontinuierlich löschen?

            Zur Call-Eröffnung, diesbezüglich habe ich mich bereits beim Support gemeldet inkl.
            Log-Files, leider jedoch noch keine Antwort bekommen.

            Danke schön und Gruss,
            Rainer
            • 3. Re: Performance-Probleme mit NetInstall-Client
              dei Specialist
              Hi,

              der Repository reserviert sich automatisch ein gutes Stück deines freien Speichers um sicherzustellen das die Software auch heruntergeladen werden kann und nicht eine fast volle Festplatte das Software-Management lahm legt. Die Größe ist in der Infrastruktur einstellbar und richtig sich entweder nach dem noch freien Platz auf der Festplatte oder einem fixen Wert.

              Grüße
              • 4. Re: Performance-Probleme mit NetInstall-Client
                Frank.Scholer Master
                Hallo Rainer,

                di schreibst, dass du den AutoInstaller auf 5 Minuten gesetzt hast. Damit meinst du (heffentlich) die Verzögerung beim Start und nicht das Polling-Intervall, oder?

                Ansonsten: lasst ihr das Login-Script synchron laufen (also dass der Desktop erst dann erscheint, wenn die Login-Scripts beendet sind)? Ich weiß jetzt garnicht sicher, ob sich das so verhält, aber es könnte ja sein, dass wenn das der Fall ist (synchroner Ablauf), dass der Desktop erst dann erscheint, wenn der Autoinstaller durch ist. Wenn ihr da eh schonmal ne fünfminütige Verzögerung drin habt, vielleicht ist das dann die Ursache.

                Und: in den Logs gibt's ja immer genaue Zeitangaben zu jeder Aktion. Gibt es dort Auffälligkeiten, wo eine NI-Komponente ne besonders lange "Denkpause" einlegt (irgendwelche Timeouts o.ä.). Wenn du die Logs mal daraufhin durchschaust ob 60 oder 90 Sekunden Pause zwischen zwei aufeianderfolgenden Zeile sind, das könnte auch ein Hinweis auf die Ursache sein...

                Und letztendlich ist Dirks Frage sehr entscheidend: wenn du den CMDB-Cache mal manuell löschst (eSICore und alle abhängigen Dienste stoppen, Cache-Verzeichnis löschen, eSICore wieder starten), geht es dann schneller? Wenn ja, deutet das auf ein Problem in v6 beim ClientSync hin, wenn nein, isses eher eine andere Einstellung (z.B. die o.a. Verzögerung beim Autoinstaller-Start)...

                HTH, Gruß Frank
                • 5. Re: Performance-Probleme mit NetInstall-Client
                  CarolaB Apprentice
                  Hallo,

                  auch mir sind einige Performanceeinbußen auf Clients bekannt.
                  Virenscanner Exclutions sind bereits angelegt.

                  Was auffällig, ist der NetReflect-Client:
                  Dieser schaufelt alle 3-4Sekunden, 3,3KB durch die Gegend.
                  Dabei prüft er unnötigerweise immer wieder die selbe Dateistruktur.

                  Attached Logfile kann mit Procmon.exe von Sysinternal geöffnet werden.
                  • 6. Re: Performance-Probleme mit NetInstall-Client
                    dei Specialist
                    Hi,

                    das was du in deinem Logfile siehst ist denke ich der Ablauf welcher enteo Reflect immer wieder die Liste der gerade laufenden Applikationen aktualisiert. Speziell vermute ich das es sich hier um die Status-Area-Icon (Tray-Icon) Programme handelt. Vielleicht reagiert darauf der Checkpoint-Filter etwas alergisch?

                    Grüße