8 Replies Latest reply on Jun 27, 2017 8:04 PM by bretzeli

    OSD 3.20 getosdfiles.cmd wird nicht gepatch

    f.pauli@sz-sb.de Rookie
      Hallo,

      leider versuche ich mich bisher vergebens mit unserer OSD installtion mit WIndows PE. Netzwerk ist vorhanden, sleep eingebaut aber er will die getosdfiles.cmd nihct patchen. Die Broadcom G II habe ich als ALias im \Net\BC\BCNET.INF eingetragen, müssen die Treiber auch dort hinterlegt werden.
      Ich weis nicht mehr weiter.

      Gruß
      Florian
        • 1. Re: OSD 3.20 getosdfiles.cmd wird nicht gepatch
          Frank.Scholer Master
          Hallo Florian,

          frage ist, warum er die GETOSDFILES.CMD nicht patchen will...
          1. die Netzwerkkarte wird nicht von PE erkannt. Um das zu testen, breche nach der Netzwerk-Initalisierung einfach mal das Script per STRG + C ab und mach ein ipconfig.

          2. Wenn du Netz hast, könnte eventuell dasselbe Problem vorliegen wie in [URL="http://forum.enteo.com/showthread.php?t=5611"]diesem Thread besprochen.

          Allerdings schreibst du ja, dass du OSD 3.20 hast. Da wäre jetzt die Version (also der Build) wichtig, weil das neue PROUTIL nicht mit ner OSD Infrastruktur Build 188 und älter funktioniert (und meines Wissens auch kein Backport gemacht wurde)...

          HTH, Gruß Frank
          • 2. Re: OSD 3.20 getosdfiles.cmd wird nicht gepatch
            bretzeli Expert
            Ja, aber bei den PE setup nur die Startnet_pe20.bat nicht die startnet.bat (die fuer pe 2005). Wo ist das file auf dem client?


            Hallo Florian,

            frage ist, warum er die GETOSDFILES.CMD nicht patchen will...
            1. die Netzwerkkarte wird nicht von PE erkannt. Um das zu testen, breche nach der Netzwerk-Initalisierung einfach mal das Script per STRG + C ab und mach ein ipconfig.

            2. Wenn du Netz hast, könnte eventuell dasselbe Problem vorliegen wie in [URL="http://forum.enteo.com/showthread.php?t=5611"]diesem Thread besprochen.

            Allerdings schreibst du ja, dass du OSD 3.20 hast. Da wäre jetzt die Version (also der Build) wichtig, weil das neue PROUTIL nicht mit ner OSD Infrastruktur Build 188 und älter funktioniert (und meines Wissens auch kein Backport gemacht wurde)...

            HTH, Gruß Frank

            • 3. Re: OSD 3.20 getosdfiles.cmd wird nicht gepatch
              Frank.Scholer Master
              @bretzteli: Bist du jetzt im Thread "verrutscht"?
              • 4. Re: OSD 3.20 getosdfiles.cmd wird nicht gepatch
                bretzeli Expert
                Florian:

                NEUERE proutil.exe holen (Irgend aus einem Setup) und in Dein PE 2.0 Setup kopieren
                Patchen der Files startnet.cmd und GETOSDFILES.* auf Deiner Admin Maschine wo Du die PE 2.0 Images generierst (Mit dem VB-Script).

                So sollte das getosfiles.* aussehen (Beachte am Schluss die -n:G Option)
                Nur das neuere PROUTIL kann dies. DHCP Request Antwort ueber Broadcast
                statt nur im gleichen Subnetz,


                :: Create refresh file
                ECHO.>%RAMDRIVE%\SEND

                :: Upload refresh file for extended tags
                PROUTIL.EXE  -w  #@sip*######### #@caa#######.xt %RAMDRIVE%\SEND -n:G

                :: Download setup files
                ECHO Downloading setup-files from OSD server
                ECHO.
                PROUTIL.EXE -t  #@sip*######### #@t140*##################\PATCH.LST %RAMDRIVE%\PATCH.LST -n:G
                MD %RAMDRIVE%\$BCSETUP
                PROUTIL.EXE  -t  #@sip*######### #@t140*################## %RAMDRIVE%\$BCSETUP -l:%RAMDRIVE%\PATCH.LST -c:%RAMDRIVE%\OSDVARCACHE.BIN -n:G

                :: Patch TAGINFO.INI
                IF EXIST %SYSTEMDRIVE%\I386\TAGINFO.INI COPY %SYSTEMDRIVE%\I386\TAGINFO.INI %RAMDRIVE%\$BCSETUP
                IF EXIST %SYSTEMDRIVE%\AMD64\TAGINFO.INI COPY %SYSTEMDRIVE%\AMD64\TAGINFO.INI %RAMDRIVE%\$BCSETUP
                PROUTIL.EXE  -a %RAMDRIVE%\$BCSETUP\TAGINFO.INI -c:%RAMDRIVE%\OSDVARCACHE.BIN  -n:G

                :: Reset error file
                IF EXIST %RAMDRIVE%\ERROR.TXT DEL %RAMDRIVE%\ERROR.TXT

                :LBL_PART
                IF NOT "#@t130*" == "TRUE" GOTO LBL_FORMAT
                ECHO Starting OSD action partitioning
                ECHO.
                CALL %RAMDRIVE%\$BCSETUP\BCPART.CMD
                IF EXIST %RAMDRIVE%\ERROR.TXT GOTO LBL_END

                :LBL_FORMAT
                IF NOT "#@t131*" == "TRUE" GOTO LBL_SETUP
                ECHO Starting OSD action formatting
                ECHO.
                CALL %RAMDRIVE%\$BCSETUP\BCFORMAT.CMD #@t149*########
                IF EXIST %RAMDRIVE%\ERROR.TXT GOTO LBL_END

                :LBL_SETUP
                IF NOT "#@t132*" == "TRUE" GOTO LBL_END
                ECHO Starting OSD action setup
                ECHO.
                CALL %RAMDRIVE%\$BCSETUP\PROSETUP.CMD
                IF EXIST %RAMDRIVE%\ERROR.TXT GOTO LBL_END

                :LBL_FINAL
                CALL %RAMDRIVE%\$BCSETUP\PROFINAL.CMD

                :LBL_END






                https://community.ivanti.com/message/224393#224393


                [QUOTE=f.pauli@sz-sb.de;16160]Hallo,

                leider versuche ich mich bisher vergebens mit unserer OSD installtion mit WIndows PE. Netzwerk ist vorhanden, sleep eingebaut aber er will die getosdfiles.cmd nihct patchen. Die Broadcom G II habe ich als ALias im \Net\BC\BCNET.INF eingetragen, müssen die Treiber auch dort hinterlegt werden.
                Ich weis nicht mehr weiter.

                Gruß
                Florian
                • 5. Re: OSD 3.20 getosdfiles.cmd wird nicht gepatch
                  f.pauli@sz-sb.de Rookie

                  Hallo Florian,

                  frage ist, warum er die GETOSDFILES.CMD nicht patchen will...
                  1. die Netzwerkkarte wird nicht von PE erkannt. Um das zu testen, breche nach der Netzwerk-Initalisierung einfach mal das Script per STRG + C ab und mach ein ipconfig.

                  2. Wenn du Netz hast, könnte eventuell dasselbe Problem vorliegen wie in [URL="http://forum.enteo.com/showthread.php?t=5611"]diesem Thread besprochen.

                  Allerdings schreibst du ja, dass du OSD 3.20 hast. Da wäre jetzt die Version (also der Build) wichtig, weil das neue PROUTIL nicht mit ner OSD Infrastruktur Build 188 und älter funktioniert (und meines Wissens auch kein Backport gemacht wurde)...

                  HTH, Gruß Frank



                  Hallo Frank,

                  danke für die Antwort,

                  wir haben, die 194 im Einsatz.
                  Netzwerkverbindung ist vorhanden.
                  Was ich gestern noch sehen habe, wenn das Proutil aufgerufen wird , wird ein BC versendet der aber nicht beantwortet wird.
                  Ich schau mir mal jetzt Deine zwiete Lösung an.


                  Wo kann ich mit das proutil , mit dem Schalte -n:G downloaden?


                  Gruß
                  Florian
                  • 6. Re: OSD 3.20 getosdfiles.cmd wird nicht gepatch
                    Frank.Scholer Master
                    Hallo Florian,

                    Wo kann ich mit das proutil , mit dem Schalter -n:G downloaden?


                    wende dich am einfachsten an den Support oder mache es wie [URL="http://forum.enteo.com/showpost.php?p=16176&postcount=7"]hier beschrieben...

                    HTH, Gruß Frank
                    • 7. Re: OSD 3.20 getosdfiles.cmd wird nicht gepatch
                      f.pauli@sz-sb.de Rookie

                      Hallo Florian,

                      wende dich am einfachsten an den Support oder mache es wie [URL="http://forum.enteo.com/showpost.php?p=16176&postcount=7"]hier beschrieben...

                      HTH, Gruß Frank



                      Hallo Frank,

                      habe es aus dem 3.25 einpackt und leider immer noch ein Problem.
                      Proutil32: Probleme with dhcp server. Exit

                      Netwerkkarte hat zwei Anschlüsse aber einer ist im Bios deaktiviert.
                      Kann ich die Datei nciht vorher patchen?


                      Gruß
                      Florian
                      • 8. Re: OSD 3.20 getosdfiles.cmd wird nicht gepatch
                        f.pauli@sz-sb.de Rookie
                        Hallo Frank,

                        jetzt bin ich weiter.
                        Alte Konstellation DHCP(mit 43 und 60) und TFTP/BOOTP OSD Infrastruktur einem XP.
                        Neu:
                        DHCP eigener Rechner ohne 43 und 60. TFTP/Bootp und DHCPProxy auf dem XP Rechner. Jetzt funktioniert da zeugs.

                        Florian