11 Replies Latest reply on Feb 27, 2009 2:25 AM by DSMForum

    [SOLVED] Netzwerktreiber einbinden

    DSMForum Master
      Ich möchte mit OSD 6.2 Windows XP installieren und habe dazu ein WinPE 2.1 als Boot Environment angelegt und die PreOS Actions auf dieses WinPE umgestellt.

      Es funktioniert auch soweit, dass ein neuer Rechner partitioniert und formatiert sowie die Installation angestoßen wird. Nach Ende der Installation habe ich allerdings einen Rechner, der (ziemlich sicher) keine installierte Netzwerkkarte hat (ich kann nur die IP-Adresse anhand der DHCP-Einstellungen nachvollziehen, pingen kann ich diese Adresse nicht; ich kann mich aus irgendwelchen Gründen nicht anmelden). Die Post OS Action ist zu diesem Zeitpunkt nicht ausgeführt und das passiert auch nicht mehr.

      Kurz vor Ende der Installation ist noch ein Fenster, das nach Enteo aussieht (wie nach dem Booten von WinPE), in dem ich kurz ein 'error initializind network (1/5) erspähen konnte.

      An welcher Stelle muss ich jetzt einen Netzwerktreiber ergänzen: in WinPE einen passenden Vista-Treiber oder in der Software-Library einen XP-Treiber (das hatte ich eigentlich) oder noch was anderes?

      In das WinPE-Image hatte ich einen XP-Treiber eingebunden, das war aber möglicherweise unsinnig!?
        • 1. Re: [SOLVED] Netzwerktreiber einbinden
          dennisbender Apprentice
          Probier doch mal ein PnP Projekt !?
          • 2. Re: [SOLVED] Netzwerktreiber einbinden
            DSMForum Master
            Der Schilderung liegt ein existierendes 'Driver Package', das ist ja ein PnP-Projekt für Windows XP zugrunde (dieses habe ich aus einem installierten Rechner mit gleicher Hardware heraus erzeugt). Sollte das funktionieren oder muss ich WinPE noch irgendwie ergänzen?
            • 3. Re: [SOLVED] Netzwerktreiber einbinden
              dennisbender Apprentice
              PE ist da doch schon durch, kann mir nicht vorstellen das du da noch was machen musst. Eher bei den XP Treibern.
              • 4. Re: [SOLVED] Netzwerktreiber einbinden
                ChristophSteckelberg Expert
                Was sagt die Funktion "Passt Treiber zu Computer" (rechte Maustaste auf das Treiberpaket, dann Auswahl des fraglichen Rechners)
                Sind alle Knubbel grün ?
                • 5. Re: [SOLVED] Netzwerktreiber einbinden
                  christian.schmidt@porsche Apprentice
                  Hallo admin,

                  ich würde dir empfehlen, ein neues Treiberpaket mit frischen Treibern von der Herstellerhomepage zu bauen und diese dann Deinem Rechner zuweisen. Wie schon oben von Christoph beschrieben kannst du dann mit "Passt Treiber zu Computer" erkennen (wenn alle "Lämpchen" grün sind), daß der Treiber ordentlich eingebunden werden sollte. PE brauchst Du nicht zu patchen, die Installation hat ja funktioniert.

                  Das beschriebene Verhalten kann übrigens auch dann vorkommen, wenn der Domainjoin nicht funktioniert, da dann wahrscheinlich der enteo-User auf dem Client keine Rechte hat. Also einfach mal an der Maschine anmelden und dort nachschauen, ob eine Netzwerkkarte vorhanden ist...

                  Gruß

                  Christian
                  • 6. Re: [SOLVED] Netzwerktreiber einbinden
                    DSMForum Master
                    [QUOTE=christian.schmidt@porsche;18617]
                    Das beschriebene Verhalten kann übrigens auch dann vorkommen, wenn der Domainjoin nicht funktioniert, da dann wahrscheinlich der enteo-User auf dem Client keine Rechte hat. Also einfach mal an der Maschine anmelden und dort nachschauen, ob eine Netzwerkkarte vorhanden ist...

                    Gruß

                    Christian

                    Danke schon 'mal. Möglicherweise beißt sich die Katze da in den Schwanz (oder verstehe ich da noch 'was falsch): ohne Netzwerkkarte komme ich nicht in die Domäne!? Außerdem habe ich das Problem, dass ich mich nicht an dem frisch installierten Rechner anmelden kann, weder mit leerem Passwort noch mit dem im OS Configuration Package hinterlegten (wenn alle Stricke reißen erstelle ich auch ein neues OS Configuration Package mit leerem oder 100%ig sicherem Passwort).
                    • 7. Re: [SOLVED] Netzwerktreiber einbinden
                      DSMForum Master

                      Was sagt die Funktion "Passt Treiber zu Computer" (rechte Maustaste auf das Treiberpaket, dann Auswahl des fraglichen Rechners)
                      Sind alle Knubbel grün ?



                      'Passt Treiber zu Computer' meckert bei 'Treiber-Zuweisung existiert'; muss ich das beim PnP-Projekt unter 'Paket zuweisen' noch erledigen?
                      • 8. Re: [SOLVED] Netzwerktreiber einbinden
                        Michi Expert
                        Hallo Admin,

                        ja, du musst den Treiber noch zuweisen.
                        Ich weiss jetzt nicht wie deine Struktur aufgebaut ist.
                        Entweder du weist den Treiber einer OU zu,
                        oder einer Installationsgruppe.
                        Falls Du den Treiber gleich "Managed Users & Computers" zuweist,
                        kann es sein, dass Clients den Treiber installieren die gar nicht mit Enteo installiert wurden, und kurzzeitig einen Timeout bekommen.
                        Aber ohne die Zuweisung wird der JoinDomain nicht funktionieren.
                        Zusätzlich brauchst Du auch einen User, der die Berechtigung hat einen Client in die Domäne aufzunehmen. Das muss kein DomainAdmin sein, aber mindestens Mitglied der Konten Operatoren.

                        Gruß,
                        Michi
                        • 9. Re: [SOLVED] Netzwerktreiber einbinden
                          DSMForum Master
                          Ich habe den Treiber 'mal 'New Users & Computers' zugewiesen und es hat geklappt (auch wenn in der eMMC der Teil als nicht installiert angezeigt wird), d.h. der Rechner wird jetzt komplett mit Netzwerkkarte installiert und kommt auch in die Domäne.

                          Ein Problem bleibt noch: Bis zur Migration meiner zahlreichen Pakete aus der enteo-v5.85-Welt möchte ich, dass nur die Betriebssystem-Installation mit enteo v6 läuft und dann Service und Agent auf den "alten" enteo-Server zeigen.

                          Momentan wird ein Teil des Clients für enteo v6 installiert (so wird eine fehlende Site und ein Fehler mit dem Depot gemeldet). Entsprechend zeigt die Default Post OS Action in der eMMC noch einen Fehler: [2] Client installation failed: Failed to determine current site.'

                          Wie ändere ich die Default Post Action am besten (oder nehme ich sie besser aus der Betriebssysteminstallation heraus?)?
                          • 10. Re: [SOLVED] Netzwerktreiber einbinden
                            ChristophSteckelberg Expert
                            Es kommt darauf an, wie Du in der alten Welt Deine Agents verteilst. Wenn Du das bisher auch über ein Loginskrtipt machst, dann kannst Du die Default Post OS Action komplett aus Deinem OS-Set entfernen. Der Agent wird dann natürlich erst installiert, wenn sich ein User anmeldet.

                            Wenn nicht, würde ich die Default Post OS Action kopieren, im neuen Paket die Script.inc ändern (Achtung: Dies ist ein Windows Shellskript, also sind keine Escript-Befehle möglich) und im Skript mit geeigneten Mitteln (Installclient.exe, nilogin.cmd, niagnt32.exe /install vom alten Server aus oder gar kein Post OS Action und den Agent über cmdlines.txt antriggern) den Client installieren.
                            • 11. Re: [SOLVED] Netzwerktreiber einbinden
                              DSMForum Master
                              es klappt soweit, etwas Feintuning bekomme ich selbst hin. Vielen Dank!