1 2 Previous Next 15 Replies Latest reply on Aug 6, 2009 9:43 AM by MichaelLink

    Policy Instanz wird nicht ausgeführt

    TorstenStreng Expert
      Hallo!

      Ich habe auf einer bestimmten OU nur eine Policy zugewiesen. Darin befinden sich über 200 Systeme. Leider wird diese auf einigen wenigen nicht ausgeführt. Die Logfiles sagen folgendes:

      mgmtagnt_SYSTEM_......log

      13:34.17.009  2 mgmtagnt.exe  Core services handler called with control code 4
      13:34.17.009  2 mgmtagnt.exe  Queueing unnamed control code 0x00000004 to core service IOCP

      NiInst32_ClientSync_.......log

      13:16:08.575 2 CMSClntLib: Calling webservice (SynchronizeClient)
      13:16:09.044 2 CMSClntLib: Connection to the server was interrupted
      13:16:09.044 2 CMSClntLib: Error-Code: -1
      13:16:09.060 2 CMSClntLib: The server answered with an exception, resending the request.
      13:16:09.060 2 CMSClntLib: Waiting 10 seconds...
      13:16:19.059 2 CMSClntLib: Sleeping done..
      13:16:19.059 2 CMSClntLib: Calling webservice (SynchronizeClient)
      13:16:19.513 2 CMSClntLib: Connection to the server was interrupted
      13:16:19.528 2 CMSClntLib: Error-Code: -1
      13:16:19.528 2 CMSClntLib: The server answered with an exception, resending the request.
      13:16:19.528 2 CMSClntLib: Waiting 20 seconds...
      13:16:39.528 2 CMSClntLib: Sleeping done..
      13:16:39.528 2 CMSClntLib: Calling webservice (SynchronizeClient)
      13:16:39.996 2 CMSClntLib: Connection to the server was interrupted
      13:16:39.996 2 CMSClntLib: Error-Code: -1
      13:16:39.996 2 CMSClntLib: Server is unreachable, aborting
      13:16:39.996 2 CMSClntLib: An error occurred during synchronize, performing only cleanup

      Kann das jemand deuten?

      Gruß
      T.
        • 1. Re: Policy Instanz wird nicht ausgeführt
          MichaelLink Apprentice
          Hallo Thorsten,

          da scheinen einige Clients Probleme mit der Verbindung zum BLS zu haben. Ich vermute, die Policy-Instanz wird bei diesen Clients gar nicht ausgeliefert (Briefsymbol fehlt).

          Kannst Du mal in das bls_clientmanagement.log-File auf dem BLS schauen und um 13:16 herum schauen, ob da irgendwelche Exceptions auftreten und falls ja, diese hier mal posten ? Ansonsten wäre Report-Level 0 auf einem betroffenen Client nützlich, dann wird glaub ich auch der Exception-Text des BLS gelogged.

          Grüsse

          Michael
          • 2. Re: Policy Instanz wird nicht ausgeführt
            TorstenStreng Expert
            Hallo Michael,

            ein bls_clientmanagement.log kann ich auf dem BLS nicht finden. Die Instanz ist aber bei allen Clients ausgeliefert, bis auf einem.

            Ich befürchte das es mit dem Austausch des Enteo Clients zu tun hat. Hierbei handelt es sich nämlich um Maschinen, die noch Enteo 5.8 aufgesetzt wurden. Ich glaube der Kollege, der die Aktion durchgeführt hat, hat vergessen die Netsupport Schlüssel aus der Registry zu entfernen. Allerdings habe ich auf einem System den Client nochmal entfernt, alle Netsupport Schlüssel gelöscht und nochmal die ClientInstall.exe ausgeführt. Leider mit dem gleichen Ergebnis

            Gruß
            Torsten
            • 3. Re: Policy Instanz wird nicht ausgeführt
              LjokajK Expert
              Hi,

              der Michal meint sicher das BLS_ClientAdmin.log.
              Poste doch mal das LOG-File.
              Bzgl. des Entfernen des alten ENTEO-Clients...

              Hast du auch die dienste unter services deinstalliert? Und auch unter C:\Programme das NetInst-Verzeichnis komplett gelöscht?
              • 4. Re: Policy Instanz wird nicht ausgeführt
                TorstenStreng Expert
                Hi!

                Ja alles gelöscht! Auch die Dienste und das Verzeichnis gelöscht. Die NiAMH.dll umbenannt, weil im Zugriff, neu gestartet, danach auch gelöscht. Hat ja alles schon über 200 mal problemlos funktioniert.

                Ein Logfile vom entfernen des alten Enteo Clients? Hab ich nicht mehr da ich ja das Verzeichnis gelöscht habe. Aber daran liegt es auch nicht. Das paßt schon!

                Sorry....finde aber auch kein BLS_ClientAdmin.log

                Gruß
                T.
                • 5. Re: Policy Instanz wird nicht ausgeführt
                  LjokajK Expert
                  dieses LOG muss es aber geben. bin leider nicht im Büro sondern unterwegs.
                  Ich weiss jetzt nicht auswendig wie es heisst, glaub blsadministrationclient.log

                  Wenn in dem LOG nichts zu erkennen ist, dann musst du das Logging auf DEBUG umstellen. Weisst du, wie du das machen musst?
                  • 6. Re: Policy Instanz wird nicht ausgeführt
                    TorstenStreng Expert
                    Ich hab jetzt die Festplatten nach bls*.log durchsucht.
                    Es existieren nur....

                    blsclient_webservice.log
                    blsadmin_webservice.log
                    blsinstallation_webservice.log
                    blsupdate.log
                    • 7. Re: Policy Instanz wird nicht ausgeführt
                      MichaelLink Apprentice
                      Ich meinte das blsclient_webservice.log. Das muss immer existieren, ansonsten hast du keinen funktionierenden BLS :-)

                      Grüsse

                      Michael
                      • 8. Re: Policy Instanz wird nicht ausgeführt
                        LjokajK Expert
                        Jepp, genau das ist das LOG.
                        Aber mach doch mal vorher folgendes, bevor du das LOG rein postest.....

                        1. geh auf deinen ENTEO-Server und öffne die web.config unter C:\Inetpub\MgntPoint\blsAdministration

                        2. Gehe zu

                             

                        setze dort den level value auf "DEBUG". Standardmäßig steht dieser auf "ERROR"

                        3. Löse nun einen ClientSync auf einem PC aus. Nach dem der Installer auf dem Client fertig ist, schaust du in das BLS-Client-LOG rein und suchst den PC-Namen in dem LOG, auf dem du den Client-Sync ausgelöst hast. Dort solltest du dann auf jeden Fall eine Meldung bekommen, ob die Instanz erstellt wurde und wenn nicht, warum. Dies kannst du ja dann hier rein posten.

                        Viele Grüsse
                        Kurt
                        • 9. Re: Policy Instanz wird nicht ausgeführt
                          TorstenStreng Expert
                          Guten Morgen!

                          Die Umstellung auf DEBUG hat keine Änderung im Logfile gebracht.
                          Hier der Eintrag:
                          2009-08-06 10:03:29,664 [1] INFO  Enteo.BlServer.Summary - ***IP Adresse*** Anonymous en 188ms Client 1.0.0.0 SynchronizeClientRequest(Computer=0, User=0, 0 Deltas, 0 Revisions)

                          Was mir noch aufgefallen ist auf den betroffenen Systemen.

                          ersupextSvc_SYSTEM_......log (Pfade von mir ersetzt)

                          09:57.55.305  2 mgmtagnt.exe  Extension ....\NetInst\magntext\ersupext.dll has version 6.2.1.2890
                          09:57.55.336  2 ersupext.dll  The autoinstaller (service) has already been started during this computer session
                          09:57.55.336  2 ersupext.dll  Successfully created run/runonce jobs thread with TID 6528
                          09:57.55.336  E Warning (Module:mgmtagnt.exe, Severity:0x03): ersupext.dll  Failed to retrieve current location
                          The data for the pseudo handle specific state is invalid.
                          09:57.55.336  E Warning (Module:mgmtagnt.exe, Severity:0x03): ersupext.dll  Configuration information could not be retrieved
                          The data for the pseudo handle specific state is invalid.
                          09:57.56.336  E Warning (Module:mgmtagnt.exe, Severity:0x03): ersupext.dll  Failed to retrieve current location
                          The data for the pseudo handle specific state is invalid.
                          09:57.56.336  E Warning (Module:mgmtagnt.exe, Severity:0x03): ersupext.dll  Configuration information could not be retrieved
                          The data for the pseudo handle specific state is invalid.
                          09:57.57.336  E Warning (Module:mgmtagnt.exe, Severity:0x03): ersupext.dll  Failed to retrieve current location
                          The data for the pseudo handle specific state is invalid.
                          09:57.57.336  E Warning (Module:mgmtagnt.exe, Severity:0x03): ersupext.dll  Configuration information could not be retrieved
                          The data for the pseudo handle specific state is invalid.
                          09:57.58.336  E Warning (Module:mgmtagnt.exe, Severity:0x03): ersupext.dll  Failed to retrieve current location
                          The data for the pseudo handle specific state is invalid.
                          09:57.58.336  E Warning (Module:mgmtagnt.exe, Severity:0x03): ersupext.dll  Configuration information could not be retrieved
                          The data for the pseudo handle specific state is invalid.
                          09:57.59.351  2 ersupext.dll  No need to create a local user group for trusted users. We don't run in Vista or higher.
                          09:57.59.367  2 ersupext.dll  Successfully logged on for outbound connections
                          09:57.59.367  2 ersupext.dll  Network throughput is 2504
                          09:57.59.367  2 ersupext.dll  The computer is not a test workstation
                          09:57.59.367  2 ersupext.dll  The computer is not a laptop
                          09:57.59.367  2 ersupext.dll  Now invoking CSM client for an update check and download
                          09:58.06.726  2 ersupext.dll  CSM: Process should continue, Reason:No update is required
                          09:58.06.726  2 ersupext.dll  CSM system status code is 'The operation completed successfully.'
                          10:03.07.712  2 ersupext.dll  The polling timer has been triggered
                          10:03.07.712  2 ersupext.dll  Now invoking CSM client for an update check and download
                          10:03.14.978  2 ersupext.dll  CSM: Process should continue, Reason:No update is required
                          10:03.14.978  2 ersupext.dll  CSM system status code is 'The operation completed successfully.'
                          10:03.14.978  2 ersupext.dll  --> AutoInstaller has to be started
                          10:03.14.978  2 ersupext.dll  szNiBinDir is .....\NetInst
                          10:03.14.978  2 ersupext.dll  szFullPath is .....\NetInst\NiInst32.exe
                          10:03.14.978  2 ersupext.dll  szAlternateDir is (null)
                          10:03.14.978  2 ersupext.dll  szDir is .....\NetInst
                          10:03.14.978  2 ersupext.dll  Created service user process .....\NetInst\NiInst32.exe with command line NiInst32.exe /SERVICE and PID 10116

                          • 10. Re: Policy Instanz wird nicht ausgeführt
                            LjokajK Expert
                            irgendwas ist da an dem Client buggy......

                            Die NCP-Dateien auf den betroffenen clients sind auch die aktuellen?

                            Wie hast du denn den Agent auf den Clients deinstalliert? Vor allem die services? Wie hast du die entfernt?

                            Leider bin ich wieder mal unterwegs. Ich kann dir aber gerne mal eine kleine Anleitung zukommen lassen, wie man einen Client / Server komplett ENTEO-befreit. :-)
                            • 11. Re: Policy Instanz wird nicht ausgeführt
                              TorstenStreng Expert
                              5.8er Agent deinstallieren:

                              1. niagnt32.exe /uis
                              2. Alle NetSupport Schlüssel in der Registry löschen
                              3. Die NiAMH.dll umbennen
                              4. Reboot
                              5. Das Verzeichnis %ProgramFiles%\Netinst löschen
                              6. Die Konten für enteo Runtime und Service zur Admin Gruppe hinzufügen
                              7. Die InstallClient.exe vom enteo Share ausführen

                              Den 6.2er hab ich etwas anders entfernt und neu installiert da es
                              sich um einen prod. Citrix Server handelt der nicht ohne weiteres gebootet werden kann.

                              1. niagnt32.exe /uis
                              2. Alle NetSupport Schlüssel in der Registry löschen
                              4. sc delete esicore
                              5. sc delete ersupext
                              6. sc delete swusageservice
                              7. Das Verzeichnis %ProgramFiles%\Netinst löschen (es sind einige Files im Zugriff, die bleiben halt da)
                              8. Die InstallClient.exe vom enteo Share ausführen
                              • 12. Re: Policy Instanz wird nicht ausgeführt
                                LjokajK Expert
                                irgendwas ist da an dem Client buggy......

                                Die NCP-Dateien auf den betroffenen clients sind auch die aktuellen?

                                Wie hast du denn den Agent auf den Clients deinstalliert? Vor allem die services? Wie hast du die entfernt?

                                Leider bin ich wieder mal unterwegs. Ich kann dir aber gerne mal eine kleine Anleitung zukommen lassen, wie man einen Client / Server komplett ENTEO-befreit. :-)
                                • 13. Re: Policy Instanz wird nicht ausgeführt
                                  LjokajK Expert
                                  Ähm, du hast vergessen, das Verzeichnis ENTEO unter C:\Programme\Gemeinsame Dateien zu löschen......

                                  Bzgl. der NIAMH.dll....
                                  Kleiner Tip.Öffne die Registry....

                                  HKLM\SW\MS\WindowsNT\CurrentVersion\Windows
                                  Dort findest du eine Zeichenfolge "AppInit_DLLs". Dort steht die NIAMH.dll drin. Diesen eintrag löschen. Dann kannst du auch alle Daten von ENTEO löschen.

                                  Und zum Installieren des Clients würde ich die Variante "Computer Managen" fahren.

                                  Nach dem Löschen der Registry-Einträge einen Neustart machen, sonst kannst du auch einige Dateien nicht löschen. Hab ich 100 Mio Mal schon gemacht, klappt einwandfrei.
                                  • 14. Re: Policy Instanz wird nicht ausgeführt
                                    TorstenStreng Expert
                                    Das Enteo Verzeichnis liegt bei uns woanders aber ok.
                                    Danke für den Tip mit der NIAMH.dll aber ob ich die in der Registry lösche oder umbenenne kommt auf's gleiche. Booten muß ich so oder so, zumindest bei nem Server. Vorher ist löschen nicht möglich. Mit PC's kenn ich mich nicht aus, da mag es auch so gehen.
                                    1 2 Previous Next