3 Replies Latest reply on Sep 17, 2009 1:17 PM by _Mel_

    Linux Boot / Acronis: Unknown task number received: 6

    Nico-B Apprentice
      Hallo Zusammen

      Ich habe soeben eine Enteo v6.2 Installation aufgesetzt, um Tests zu machen, bevor wir unsere v6.1 aktualisieren.

      Beim Versuch einen Rechner (Fujitsu-Siemens Esprimo E5720) per Image aufzusetzen treten folgende Probleme auf:

      1. Mit dem Boot-Environment von v6.2. erhalte ich einen schwarzen Bildschirm, nachdem die Maschine per PXE das boot Environment heruntergeladen hat, und ausführt.

      2. Ich habe nun das alte Bootenvironment von 6.1 exportiert, und in 6.2 importiert (das Bootenvironment Package heisst "Linux 32 bit Boot Environment", ich weiss nicht ob dies so bei der v6.1 dabei war). Mit dieser Version habe ich das Anzeige-Problem nicht, es kommt aber folgende meldung, nachdem Enteo mehrere Sachen geladen hat:

      [HTML]
      "Linuxbootclient       Unknown task number received: 6"
      [/HTML]

      Kann jemand mit diesem Fehler etwas anfangen? Welche Logfiles sind zu kontrollieren?

      Gruss Nico
        • 1. Re: Linux Boot / Acronis: Unknown task number received: 6
          _Mel_ Master
          die Linuxbootenvironments von der 6.1 funktionieren mit der 6.2 nicht mehr, weil sich die kommunikation zwischen osdclient und osdproxy verändert hat.

          wenn man das osdproxyrpclogging für getnexttask einschaltet, dann sieht man welche tasks der osdproxy rausschickt.

          funktionieren beide linuxbootenvironments aus der 6.2 nicht ?
          bei schwarzem bildschirm kann man's auch mal mit textmodus versuchen.
          dazu von dem bootenvironment eine kopie machen und aus der pxelinux.cfg\default datei den vga=... und den fbcon=... eintrag rauswerfen.
          • 2. Re: Linux Boot / Acronis: Unknown task number received: 6
            Nico-B Apprentice
            Hallo Mel

            Vielen Dank für die Tips.

            Das Boot Environment mit den experimental Treibern kommt effektiv weiter, bleibt aber mit: "unable to send basic inventory" stehen.

            Das "normale" Boot Environment bleibt nach umstellung auf Text Mode mit "ACPI: PCI Root Bridge [PCI0] (0000:00)" stehen.

            Wie aktiviere ich das "osdproxyrpclogging"? Konnte dazu nichts finden...

            Ich habe zum Test einem VmWare Server das Image zugewiesen, und auf diesem wurde es geladen, scheint also ein Treiberproblem zu sein.

            Gruss und danke, Nico
            • 3. Re: Linux Boot / Acronis: Unknown task number received: 6
              _Mel_ Master
              was die logfiles angeht: es gibt in der registry unter HKLM\software
              etsupport\extendedlogfilesettings\osdproxyrpcclient
              einträge für die einzelnen funktionen des osdproxy.
              da kann man entweder den defaultwert auf einen wert zwischen 0 und 3 setzen (0 = maximales logging; 3 = aus) oder den defaultwert leer lassen und das loglevel pro funktion einstellen.
              (in den powertoyz ist auch ein tool dabei um das einzustellen)

              wenn er bis "unable to send basic inventory" kommt, dann müßte die kommunikation mit dem osdproxy schonmal funktioniert haben - denn das versucht er nur nach aufforderung vom proxy zu senden.

              um auf dem client mehr logging zu bekommen kann man in der pxelinux.cfg\default den parameter loglevel=0 einbauen. und wenn man enablelogin auf 1 setzt, dann hat man auch ne chance alles zu lesen (den client muß man dann von hand starten und danach kann man mit strg-pgup/pgdown scrollen)

              und auf den osdproxy mal logging einschalten, ob beim empfang des basicinventory was schiefgeht und deshalb ein fehler geworfen wird.
              evtl findet sich auch was im osdproxy_webservice-logfile