1 2 Previous Next 16 Replies Latest reply on May 4, 2010 6:21 AM by timtaylor

    Niagnt32 und Windows7

    schetter@mpikg.mpg.de Apprentice
      Hallo,

      wir starten den Niagnt32 über das Loginskript, was aber fehlschlägt. Ausgeführt über Kommandozeile (Admin) kommt der Fehler "error writing in local database", offensichtlich klappt der Regeintrag nicht......

      Wenn ich in NetInstall "Manage Computer" aktiviere, klappt es aber klaglos, der Dienst wird installiert. UAC und Firewall sind aus, welches Windows7 Problem steckt dahinter??

      Liebe Grüße

      Alex
        • 1. Re: Niagnt32 und Windows7
          Michi Expert
          Hallo Alex,

          wie rufst Du die Clientinstallation auf?
          Versuche doch mal \\server\share
          iagnt32.exe /install /bin /force

          Gruß,
          Michi
          • 2. Re: Niagnt32 und Windows7
            schetter@mpikg.mpg.de Apprentice

            Hallo Alex,

            wie rufst Du die Clientinstallation auf?
            Versuche doch mal \\server\share
            iagnt32.exe /install /bin /force

            Gruß,
            Michi



            Danke für den Hinweis Michi,

            ja, so rufe ich das Ganze auf. Übrigens konnte ich es nicht einmal als Domänen-Admin starten, bis ich die lokale UAC-Richtlinie "Run all Administrators in Admin Approval mode" abgeschaltet habe. Jetzt brauche ich nur noch die Richtlinie die mir das Ausführen über das Login-Skript erlaubt.....

            Grüße

            Alex
            • 3. Re: Niagnt32 und Windows7
              Michi Expert
              Hallo,

              Du brauchst für die Site, der sich der Client zuordnet einen aktiven SIS.
              Dieser wird per Standard nicht installiert.
              Wenn Du auf die Site einen rechten Mausklick machst und auf Eigenschaften gehst, kommt ein Fenter mit dem Reiter "Enteo Runtime Service".
              Dort kannst Du den SIS auf dem Server installieren und starten.
              Danach sollte die Client Installation auch laufen.
              Denn der SIS ist dazu da um die UAC abzunicken wenn ein User kein lokaler Admin ist. Denn auch als angemeldeter Admin arbeitest du bei aktiver UAC mit "normalen" Rechten.

              Nachtrag:
              Auf dem Server läuft danach auch ein gestarteter Dienst Namens "Enteo Service Installation Service"

              Gruß,
              Michi
              • 4. Re: Niagnt32 und Windows7
                Markus.Zierer Expert
                Hallo,

                um enteo auf einem Rechner mit Vista od. W7 (bzw. Server 2008 und 2008 R2) fehlerfrei betreiben zu können, MÜSSEN die Vorgaben, wie Sie in dem entsprechenden Whitepaper (Running enteo on Vista oder so ähnlich) gemacht wurden umgesetzt werden.

                Werden diese Vorgaben ignoriert, darf man sich nicht wundern irgendwelche Probleme zu haben.
                • 5. Re: Niagnt32 und Windows7
                  schetter@mpikg.mpg.de Apprentice
                  [QUOTE=Markus.Zierer;23099]Hallo,

                  um enteo auf einem Rechner mit Vista od. W7 (bzw. Server 2008 und 2008 R2) fehlerfrei betreiben zu können, MÜSSEN die Vorgaben, wie Sie in dem entsprechenden Whitepaper (Running enteo on Vista oder so ähnlich) gemacht wurden umgesetzt werden.

                  Werden diese Vorgaben ignoriert, darf man sich nicht wundern irgendwelche Probleme zu haben.

                  Hallo Markus,

                  das empfinde ich jetzt als Polemik. Von welchem Whitepaper sprichst Du? findet man das auf der enteo-Seite oder bei Frontrange? Ich finde es jedenfalls nicht.....

                  Viele Grüße

                  Alex
                  • 6. Re: Niagnt32 und Windows7
                    ChristophSteckelberg Expert
                    Das WP ist über v5.x und Vista. Der Support hat mir mitgeteilt, dass es für die v6 irrelevant wäre, und dass heute nur noch ein SIS benötigt wird.
                    • 7. Re: Niagnt32 und Windows7
                      Markus.Zierer Expert
                      Hallo,

                      Also das betreffende Whitepaper hab ich angehängt.

                      @Christoph
                      Das ist interessant. Diese Aussage habe ich so noch nicht gehört. Jedenfalls konnte ich auch eine v6 Testumgebung nicht ohne die, im Whitepaper genannten Änderungen erfolgreich in Betrieb nehmen. Seitdem hab ich's nicht mehr probiert. Ich kann mir aber nicht vorstellen, dass sich an der notwendigkeit etwas geändert hat, da ja der Mechanismus der UAC faktisch gleich geblieben ist. Und das bedeutet auch, dass jede Änderung an Systemrelevanten Dingen zumindest durch einen Klick auf "OK" abgenickt werden müsste. Einzige Ausnahme: Wenn die Installation vom TrustedInstaller von MS selbst durchgeführt wird, ist dies nicht notwendig. Ich werde das bei Gelegenheit mal verifizieren.
                      • 8. Re: Niagnt32 und Windows7
                        timtaylor Apprentice
                        Hallo zusammen,

                        im Moment befassen wir uns ebenfalls mit W7 und der Installation des Clients.
                        Dank der vielen Tips und dem Hinweis des SIS klappt die Installation des Client ohne Probleme, jedoch haben wir noch das Problem, das die Installation nur dann "reibungslos" geht, wenn sich ein zb. Domänen-Admin anmeldet.
                        Meldet sich ein Dom-Benutzer an versucht sich der Client erneut zu installieren.
                        Schließlich bricht die Installation ab mit der DOS-BOX
                        ----------------------------------------------------------
                        enteo Client has to be installed or updated

                        Installing enteo Client...

                        Starting enteo Client for the first time...
                        Error: Installation of enteo Client failed - please check Logfiles in Temp-Direc
                        tory
                        Drücken Sie eine beliebige Taste . . .

                        Kurios dabei ist, dass der Auto-Installer danach startet und ohne Probleme durchläuft.
                        Im Log finde ich hierzu Warnungen, die zeigen, dass der Benutzer nicht auf die HKLM zugreifen kann.


                        14:23:39.866 E     Warning (Module:NiCfgPrv, Severity:0x03):
                        Couldn´t open registry key 'SOFTWARE\NetSupport\NetInstall\AutoInstallSettings in HKEY_LOCAL_MACHINE'
                        Zugriff verweigert

                        14:23:39.866 E     Warning (Module:NiCfgPrv, Severity:0x03):
                        Couldn´t open registry key 'SOFTWARE\NetSupport\NetInstall\AutoInstallSettings in HKEY_LOCAL_MACHINE'
                        Zugriff verweigert

                        14:23:39.866 E     Warning (Module:NiCfgPrv, Severity:0x03):
                        Couldn´t open registry key 'SOFTWARE\NetSupport\NetInstall\SiteProperties in HKEY_LOCAL_MACHINE'
                        Zugriff verweigert

                        14:23:39.866 E     Warning (Module:NiCfgPrv, Severity:0x03):
                        Couldn´t open registry key 'SOFTWARE\NetSupport\NetInstall\SiteProperties in HKEY_LOCAL_MACHINE'
                        Zugriff verweigert

                        14:23:39.866 E     Warning (Module:NiCfgPrv, Severity:0x03):
                        Couldn´t open registry key 'SOFTWARE\NetSupport\NetInstall\SiteProperties in HKEY_LOCAL_MACHINE'
                        Zugriff verweigert

                        14:23:39.866 E     Warning (Module:NiCfgPrv, Severity:0x03):
                        Couldn´t open registry key 'SOFTWARE\NetSupport\NetInstall\SiteProperties in HKEY_LOCAL_MACHINE'
                        Zugriff verweigert

                        14:23:39.866 E     Warning (Module:NiCfgPrv, Severity:0x03):
                        Couldn´t open registry key 'SOFTWARE\NetSupport\NetInstall\SiteProperties in HKEY_LOCAL_MACHINE'
                        Zugriff verweigert

                        14:23:39.866 E     Warning (Module:NiCfgPrv, Severity:0x03):
                        Couldn´t open registry key 'SOFTWARE\NetSupport\NetInstall\SiteProperties in HKEY_LOCAL_MACHINE'
                        Zugriff verweigert

                        14:23:39.866 E     Warning (Module:NiCfgPrv, Severity:0x03):
                        Couldn´t open registry key 'SOFTWARE\NetSupport\NetInstall\InstallSettings in HKEY_LOCAL_MACHINE'
                        Zugriff verweigert


                        Mach ich was falsch ?

                        Gruß Tim
                        • 9. Re: Niagnt32 und Windows7
                          Markus.Zierer Expert
                          hallo,

                          natürlich kann der Benutzer nicht auf HKLM Keys schreiben. Deswegen ist er ja Benutzer. Das geht nur mit Adminrechten.
                          • 10. Re: Niagnt32 und Windows7
                            timtaylor Apprentice
                            Hallo Markus,

                            danke für die Antwort.
                            Mit stellt sich die Frage, warum muss der User nocheinmal in die Registry schreiben, wenn doch der Client bereits installiert ist ?

                            Gruß Tim
                            • 11. Re: Niagnt32 und Windows7
                              Markus.Zierer Expert
                              Hallo,

                              ich hab mir den ganzen Post nochmal komplett durchgelesen. Also soweit ich das sagen kann, wird, sofern du das DefaultPostOS Package beim Clientsetup benutzt, der enteo Client sowieso schon installiert. Alles was Du dann noch per LogOn Script machen musst, ist einfach niagnt32.exe starten.

                              Wenn Du die Clientinstallation nochmal neu anstösst, läuft die im Kontext des angemeldeten Benutzers ab. Und da das in diesem Fall ein Dom-User ohne Adminrechte ist, fällt das Client Setup auf die Nase. Der SIS hilft dir in diesem Zusammenhang auch nicht weiter, weil die Installation ja nicht von NetInstall angeschoben wird, sondern über das LogOn Script. Und wenn NI nix von ner Installation weis, kann es auch nichts unternehmen um die Installation zu unterstützen.
                              • 12. Re: Niagnt32 und Windows7
                                timtaylor Apprentice
                                Hallo Markus,

                                danke für die Info.
                                Nun weiss ich zumindest wo der Schuh drückt, da ich gar nicht mit dem DefaultPostOS Package arbeite.
                                Wir nutzen zum Test von W7 ein vorhandes Image (enteo unabhängig)
                                Sobal das Image wiederhergestellt ist sagen wir in der EMMC Client installieren.

                                Gruß Tim
                                • 13. Re: Niagnt32 und Windows7
                                  Markus.Zierer Expert
                                  ja in dem Fall ist es klar. Die Installation des Clients MUSS mit Adminrechten erfolgen. Da das bei euch nicht der Fall ist, erklärt sich der Fehler somit.

                                  Bei der 6er sollte es aber möglich sein den Client bereits im Image mit drin zu haben. Selbst wenn die Binaries outdated sein sollten, müsste der sich von selbst aktualisieren.

                                  Wir nutzen zum Test von W7 ein vorhandes Image (enteo unabhängig)
                                  Sobal das Image wiederhergestellt ist sagen wir in der EMMC Client installieren.



                                  Lass mich raten: per ImageX eine Image vorbereitet, welches per WDS verteilt wird. Oder ?
                                  • 14. Re: Niagnt32 und Windows7
                                    timtaylor Apprentice
                                    hiho.

                                    ne mit Acronis ein ganz normales image. das via Restore wieder zurückgespielt wurde.

                                    Dann wie gesagt, enteo Client installieren über das emmc
                                    1 2 Previous Next