4 Replies Latest reply on May 27, 2010 12:27 AM by Ratzratz

    Fälschlicherweise wurde ein passendes Gerät am Computer gefunden

    Ratzratz Expert
      Hallo,

      ich habe das Problem, daß USB-Geräte, auch nachdem sie nicht mehr eingesteckt sind, immer noch vom enteo als angeschlossen erkannt werden.
      D.h. wenn man "Passt Treiber zu Computer" auf einen entsprechenden PC loslässt, ist "Ein passendes Gerät am Computer gefunden" weiterhin grün.

      Es hilft auch nichts, wenn man den Registrierungsschlüssel des USB-Geräts unter "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_xxxx&Pid_xxxx" löscht, den Windows XP verwendet, um sich irgendwann einmal eingesteckte USB-Sachen zu merken.

      Im Gegensatz zu einer normalen Softwarepolicy kann ich eine Treiberpolicy auf dem PC nicht einfach löschen. Außer ich entferne die komplette Zuweisung, was aber nicht Sinn der Sache ist.

      Wie mache ich enteo klar, daß bei nicht mehr eingestecktem USB-Gerät keine Treiberpolicy mehr für den PC erzeugt werden soll?

      Gruß
      Matthias
        • 1. Re: Fälschlicherweise wurde ein passendes Gerät am Computer gefunden
          gerhard.nuesslein Apprentice
          hallo,

          eine Policy ist doch dann erzeugt worden, als der Treiber installiert wurde. Auch bei entferntem usb-gerät bleibt doch der Treiber weiterhin auf dem Rechner installiert - die Policy ist damit doch auch richtig 'compliant' - oder verstehe ich die Frage falsch? Treiber werden doch auch nach entfernter Policy nicht deinstalliert. Oder soll dies nach deiner Aussage passieren?

          Gruß Gerhard
          • 2. Re: Fälschlicherweise wurde ein passendes Gerät am Computer gefunden
            Ratzratz Expert
            Hallo Gerhard,

            Du hast natürlich insofern recht, daß die Treiber auch nach Abziehen des USB-Geräts (in meinem Fall ein spezielles USB-Datentransferkabel) noch auf dem System verbleiben und somit in der eMMC diese Richtlinie korrekterweise grün bleibt.
            Mir geht es darum, daß ich diese Treiberinstallationen per VMware teste. Wenn ich einen neuen Versuch zum Treiberausrollen nach Einstecken des Geräts mache, wird ja die Treiberinstallation gestartet und das ganze Prozedere läuft ab (enteo-Meldung, daß PNP-Manger abgebrochen werden soll, Treiberinstallation läuft los, Grünwerdung in eMMC etc.).
            Wenn ich nun nicht ganz zufrieden bin mit dem Resultat, fahre ich die VM zum letzten Schnappschuss zurück und teste die Treiberausrollung nochmal nachdem ich meine Änderungen vorgenommen habe.
            Von dem Schnappschuss-Zurückfahren bekommt enteo jedoch nichts mit und lässt die Treiberrichtlinie auf grün.
            Bei einer normalen Softwarerichtlinie ist das kein Problem. Die lösche ich einfach und der Zustand der VM ist wieder konsistent mit dem Zustand in der eMMC.
            Eine Treiberrichtlinie wird aber automatisch erzeugt und kann nicht nach Zurückfahren auf einen alten Schnappschuss entfernt werden. Ich kann also den Zustand der VM nicht so einfach mit dem Zustand im eMMC konsistent machen (d.h. Treiberrichtlinie nach Zurückfahren auf alten Schnappschuss wieder entfernen).

            Gruß
            Matthias
            • 3. Re: Fälschlicherweise wurde ein passendes Gerät am Computer gefunden
              Markus.Zierer Expert
              Hallo,

              ja das ist ja klar. Wenn Du die VM auf nen alten Snapshot zurücksetzt, woher soll enteo denn das mitbekommen ? Da wirst Du nicht drum herum kommen, dass Du die Treiberpolicy immer manuell entweder löschst und neu erstellst oder halt auf Neuinstallation stellst.

              Das ist so halt nicht vom Design her vorgesehen, weil es im täglichen Betrieb so auch nicht passieren sollte.
              • 4. Re: Fälschlicherweise wurde ein passendes Gerät am Computer gefunden
                Ratzratz Expert
                Hallo Markus,

                sowas hab ich mir schon fast gedacht.
                Trotzdem Danke.

                Gruß
                Matthias