12 Replies Latest reply on Dec 1, 2010 12:55 AM by Volker84

    Fehler beim Ausführen von NiAgnt32.exe

    Volker84 Rookie
      Hallo Zusammen,

      kann mir jemand helfen?
      Bekomme jedes mal beim ausführen von NiAgnt32.exe einen Fehler bei der Standortbestimmung.

      Siehe Bild.
        • 1. Re: Fehler beim Ausführen von NiAgnt32.exe
          NicoS1 Master
          Hallo Volker,

          schau in deine Client Install Logfiles. Die liegen im TEMP Order deines Benutzers unter dem du die Installation durchführst. Dort siehst du auch die Standortbestimmung detailierter.

          Gruß
          Nico
          • 2. Re: Fehler beim Ausführen von NiAgnt32.exe
            Volker84 Rookie
            Hallo Nico,

            hab mir mal die Logfiles angeschaut.
            Da drin steht das er sich keiner Site zuordnen kann.
            Das Komische daran ist aber das ich via enteo das OS installieren konnte.

            habe nachfolgend noch den Teil des Logfiles


            13:38:46.020 2    NiCfgPrv: --> Trying to find sites...
            13:38:46.020 1    NiCfgPrv: checking registry: using advanced site determination
            13:38:46.020 1    NiCfgPrv: Checking Haigerloch.Theben AG...
            13:38:46.020 1    NiCfgPrv: Checking Master-Site.Theben AG...
            13:38:46.020 E    Warning (Module:NiCfgPrv, Severity:0x02): No primary site
            13:38:46.036 E    Error (Module:NiCfgPrv, Severity:0x06): Fehler bei der Ermittlung des aktuellen Standorts.
            Dieser Client ist keiner Site zugeordnet. (NICFGPRV.00CB)
            14:11:34.380 1   NiCfgPrv: > Action 'Initializing NetInstall Config Provider [0x0005] ...' completed with 4 warnings and 1 errors (Action took 1968344 ms.)
            14:11:34.380 1  Closing main window...
            14:11:34.380 1  Closing main window...
            14:11:34.380 1  > Action 'Client Installer' completed with 4 warnings and 1 errors (Action took 1968485 ms.)
            • 3. Re: Fehler beim Ausführen von NiAgnt32.exe
              ReneScheruebl Apprentice
              Das ist klar. Die Site-Bestimmung fängt erst bei der Installation des enteo Clients an. OSD funktioniert rein mit dem OSD Proxy.

              Überprüfe in der eMMC die eingestellten IP-Kreise. Dein Client muss im IP-Kreis passen, damit dieser gefunden wird.
              Weiters solltest du überprüfen, ob die NiCfgLcl und NiCfgSrv Files auch ÜBERALL (an jedem Standort) aktuell sind.

              Für weitere Fragen stehe ich gerne zur Verfügung.
              • 4. Re: Fehler beim Ausführen von NiAgnt32.exe
                RWA Specialist
                Du kannst auch mal den Loglevel auf 0 stellen, dann solltest du genauer sehen wie die einzelnen Sites überprüft werden und was nicht passt.
                (Auf dem Client NiMoni starten -> Protokolldatei-Optionen -> Debug)
                • 5. Re: Fehler beim Ausführen von NiAgnt32.exe
                  NicoS1 Master
                  Da der Enteo Client noch nicht installiert ist, glaub ich nicht, dass er eine NiMoni drauf hat, die diese Einstellung beinflusst ;-)

                  Ich bin mir nicht ganz sicher, aber ich meine bei der ClientInstallation zieht das LogLevel das du für deine MasterSite eingeschalten hast.

                  Zur Not kontrolliere einfach mal deine Sites händisch. Je nachdem wie du deine Sites konfigurierst... ob per IP-Adresse, Name oder AD-Site... irgendwas muss unter "Computer Zuordnung" drin stehen was auf keinen Fall auf deinen Client zutrifft.

                  Alternativ würde ich noch empfehlen eine sog. Ausfallsite zu definieren. Diese legst du in deiner Infrastruktur direkt in der Root an am besten und nennst diese "ZZZ_Ausfallsite", damit sie ganz am Ende steht... mit Konfiguration auf dein Master Depot. Dem ganzen gibst du bei der Computerzuordnung "IP_NAME Von * bis *" mit. Quasi eine Einstellung, dass alle Clients dort rein fallen. Allerdings geht Enteo geht die Siteliste von oben nach unten alphabetisch durch, was bedeutet, dass ein Client sich in der Regel seiner Richtigen Site zuordnet da diese ja vor "ZZZ_[...]" kommt. Sollte aber mal irgendwas sein, dass ein Site-Server ausfällt oder der Computer mit einer IP kommt die du nicht in deiner Konfiguration berücksichtigt hast (z.B. bei VPN Benutzern), ordnen Sie sich trotzdem der Ausfallsite zu.
                  • 6. Re: Fehler beim Ausführen von NiAgnt32.exe
                    Volker84 Rookie
                    Also so wie es aussieht liegt es an der NIC.
                    Haben 8 gleiche Rechner über Enteo installiert und bei zwei Rechnern funktioniert es nicht.
                    Bei beiden Rechnern sind die NIC´s aus der gleichen Charge.
                    • 7. Re: Fehler beim Ausführen von NiAgnt32.exe
                      RWA Specialist
                      Um was für eine NIC handelt es sich denn, wäre vllt. auch für andere interessant.

                      Und die NiMoni kann man auch aus dem enteo-Share aufrufen wenn sie nicht lokal liegt (was bei einem Fehler bei der Clientinstallation tatsächlich wahrscheinlich ist).
                      • 8. Re: Fehler beim Ausführen von NiAgnt32.exe
                        oBi Apprentice
                        Hi,

                        ohne deine Client IP Konfiguration und ohne eine Einsicht der Sitekonfig kann man Dir wahrscheinlich nicht helfen...

                        cheers

                        oBi
                        • 9. Re: Fehler beim Ausführen von NiAgnt32.exe
                          Volker84 Rookie
                          Hallo Zusammen,

                          möchte meinen letzten Eintrag wiederrufen. Es lag an dem IP-Adr-Berreich.
                          Die Rechner haben sich jedes mal eine Adresse bezogen wo wir nicht festgellegt haben.
                          Haben nun den Bereich erweitert und siehe da es funktioniert.

                          Danke nochmal für eure Unterstützung.

                          Gruß Volker
                          • 10. Re: Fehler beim Ausführen von NiAgnt32.exe
                            thertkorn Expert

                            Da der Enteo Client noch nicht installiert ist, glaub ich nicht, dass er eine NiMoni drauf hat, die diese Einstellung beinflusst ;-)

                            Ich bin mir nicht ganz sicher, aber ich meine bei der ClientInstallation zieht das LogLevel das du für deine MasterSite eingeschalten hast.

                            Zur Not kontrolliere einfach mal deine Sites händisch. Je nachdem wie du deine Sites konfigurierst... ob per IP-Adresse, Name oder AD-Site... irgendwas muss unter "Computer Zuordnung" drin stehen was auf keinen Fall auf deinen Client zutrifft.

                            Alternativ würde ich noch empfehlen eine sog. Ausfallsite zu definieren. Diese legst du in deiner Infrastruktur direkt in der Root an am besten und nennst diese "ZZZ_Ausfallsite", damit sie ganz am Ende steht... mit Konfiguration auf dein Master Depot. Dem ganzen gibst du bei der Computerzuordnung "IP_NAME Von * bis *" mit. Quasi eine Einstellung, dass alle Clients dort rein fallen. Allerdings geht Enteo geht die Siteliste von oben nach unten alphabetisch durch, was bedeutet, dass ein Client sich in der Regel seiner Richtigen Site zuordnet da diese ja vor "ZZZ_[...]" kommt. Sollte aber mal irgendwas sein, dass ein Site-Server ausfällt oder der Computer mit einer IP kommt die du nicht in deiner Konfiguration berücksichtigt hast (z.B. bei VPN Benutzern), ordnen Sie sich trotzdem der Ausfallsite zu.



                            Hi,

                            das mit der Auffang Site ist in v6 nicht mehr zwingend notwendig da sich ein Client wenn er keiner Site zugeordnet werden kann sich immer der Site in welchem sich der Master Server /Depot befindet sich zuordnet.
                            • 11. Re: Fehler beim Ausführen von NiAgnt32.exe
                              NicoS1 Master

                              Hi,

                              das mit der Auffang Site ist in v6 nicht mehr zwingend notwendig da sich ein Client wenn er keiner Site zugeordnet werden kann sich immer der Site in welchem sich der Master Server /Depot befindet sich zuordnet.



                              Wenn das zuverlässig / bzw. in jeder Konfiguration funktioniern würde, würde es diesen Thread aber mit Sicherheit nicht geben ;-)
                              • 12. Re: Fehler beim Ausführen von NiAgnt32.exe
                                bretzeli Expert
                                Dein Enteo client hat z.B. die IP Adresse 192.168.1.244
                                Deine Enteo Site Definition z.B. 192.168.1.10-200 (DHCP RANGE z.B. nur bis 200)

                                Der clients hat einfach eine IP-Adresse ODER anderes Merkmal, mit welcher DU die Site Zugehörigkeit definierst und weiss so nicht zu welchem Enteo Server (Site) er gehört.

                                Hast Du dies geprüft?

                                Gruss aus der Schweiz