2 Replies Latest reply on Feb 22, 2012 1:26 AM by Markus.Zierer

    Frage zum Staging Verhalten

    Markus.Zierer Expert
      Ich bin hier bei nem Kunden, welcher als Installationsmethode den klassischen AutoAdminLogOn und AutoInstaller nutzt. Als ich jetzt hier gerade meine Entwickler VM neu installiert habe ist mir aufgefallen, dass das Staging Verhalten anders ist, als ich es sonst kenne.

      Ich nutze eigentlich immer die Installation über den Service und da läuft es so ab, dass zu Beginn der ersten Installier Session erst einmal die ganzen Massendaten in den Repo Cache heruntergeladen werden, bevor überhaupt eine Installation beginnt.

      Bei meinem Kunden ist es jetzt so, dass der Autoinstaller anfängt zu laufen und dann Paket für Paket abarbeitet. Wobei das Staging tatsächlich pro Paket gemacht wird und nicht am Anfang einmalig für alle zugewiesenen Pakete. Die Frage, welche sich mir hier jetzt stellt ist: Ist das tatsächlich das Verhalten bei der Benutzung des AutoInstallers oder liegt das möglicherweise daran, dass ich meine Entwickler VMs als Testworkstations habe eintragen lassen ?
        • 1. Re: Frage zum Staging Verhalten
          Michi Expert
          Hallo Markus,

          wenn es sich um Einzelzuweisungen handelt, ist das Verhalten meiner Meinung so korrekt.
          Bei Sets würde er erst das komplette Set stagen und dann installieren.

          Gruß,
          Michi
          • 2. Re: Frage zum Staging Verhalten
            Markus.Zierer Expert
            Ja, der Kunde verwendet (aufgrund SEHR schlechter Erfahrungen bei der v6.1) seither keine SWSets mehr. Alle SW Pakete sind einzeln zugewiesen und die Reihenfolge wird über die Installation Order ID gesteuert.

            Also das das bedeutet dann tatsächlich, dass nur bei der Verwendung des ServiceInstallers ein Staging der Pakete innerhalb einer Session gemacht wird. Beim AutoInstaller wird jedes Paket einzeln geprüft und ggf. gestaged.

            Hm, OK. Gut zu wissen.