1 2 Previous Next 18 Replies Latest reply on Feb 27, 2012 10:35 AM by Markus.Zierer

    Fehler bei OS-Installation / WinPE: OSD-Proxy request

    .dr.p. Rookie
      Hallo zusammen,

      ich habe einen unerklärbaren Fehler bei der Installation von Win7.
      Die Clients starten mit der Installation bzw. WinPE. Auch die Formatierung und Partitionierung funktionieren. Dann jedoch erscheint im Win PE Client Status Fenster folg. Meldung:

      OSD Proxy requested to re-send the request in 15 seconds...

      Danach erscheint die Meldung wie besagt alle 15 Sekunden, ansonsten tut sich nichts mehr.

      Woran könnte dies liegen? (Durchsuchen des Forums und Reboot des Servers ohne Erfolg)

      Vielen Dank
        • 1. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
          SBRUTSCH Expert
          Hi,

          kontrolliere bitte zwei Dinge:

          1. Was steht bei der Policie Instanz vom OS Set?
          2. Hast du weitere
          eue Treiber dem Device zugeordnet? Hier insbesondere schauen ob du für ein und dasselbe Gerät zwei Treiberpakete hast.

          Wenn dir hier nichts auffällt bitte die Logfiles unter PE kontrollieren.

          Gruß,
          Stefan
          • 2. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
            Ludwig Apprentice
            Hi,

            kann es sein das Du versuchst einen Computer zu installieren für dessen Netzwerkkarte dein WinPE noch keinen Treiber hat?

            Grüsse Ludwig
            • 3. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
              _Mel_ Master
              schau mal ob alle pakete (einschließlich treiber), die der rechner braucht verteilt sind - freigegebene, aber nicht verteilte pakete führen zu dem verhalten.
              ansonsten: logfile
              • 4. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
                Markus.Zierer Expert
                Ich hatte bei nem Kunden dieses Problem auch mal. Die Ursache dafür war die Option "Flow Control" im Netzwerkkarten Treiber. Diese Option kommt noch aus WinNT bzw. W9x Tagen und sollte in einem Modernen Netzwerk eigentlich gar nicht mehr zum tragen kommen. Wenn die Option sich tatsächlich aktiviert, gibt es irgendwo im Netzwerk einen Engpass welcher dieses Verhalten provoziert. Da das aber nicht auf der Anwendungsebene liegt, sondern tiefer, wirst Du als DSM Admin hier nicht allzuviel machen können.

                Technisch gesehen passiert folgendes: Wenn eine Gegenstelle mehr Daten empfängt, als Sie zu Verarbeiten in der Lage ist, kann die Flow Control ein sog. "Pause Frame" an den Sender schicken. Diese bewirkt dann, dass für eine definierte Zeitspanne (z.B. 15 Sek.) Der Sender keine Daten mehr schickt und erst danach es erneut versucht.

                Bei mir damals war genau das das Problem. Da die Option aktiv war, haben die Clients ewig in dieser Warteschleife gehangen bis die Installation endlich mal anlief. Nachdem ich auf dem Server in den Treibereigenschaften das FlowControl auf "Disabled" gestellt habe, war das Problem dann nicht mehr da.

                Wie gesagt, das ist nur ein Workaround, welcher das eigentliche Problem nicht löst.
                • 5. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
                  .dr.p. Rookie
                  zu SBR:
                  ******
                  1. zu der Software-Policy des OS Configuration Package stehen die PC's bei Compliance bevorstehend. Nur bei einem steht eine weitere Bemerkung ([ClientProxy] Could not resolve all variables.)
                  2. Hinsichtlich der Konfiguration des OS-Installation und Treiber hat es keinerlei Änderungen gegeben.

                  Wo finde ich die Logfiles auf dem Client?

                  zu Ludwig:
                  ********
                  Die Installation funktioniert auch bei PC's nicht, die schonmal installiert waren.

                  zu MEL:
                  ******
                  Der Distributions-Status ist jeweils aktuell - es wurde nichts verändert.
                  Welches Logfile könnte helfen?

                  zu Markus.Zierer:
                  *************
                  Auf dem DSM-Server gibt es bei der Netzwerkkarte keine erweiterte Einstellung Flow Control.

                  Zusammenfassend wäre denke ich, als nächstes die/das angesprochene Logfile hilfreich. Wo finde ich diese und wie lautet nochmal der Hotkey für die Debug-Level?
                  • 6. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
                    _Mel_ Master
                    logfiles:
                    den defaultwert unter
                    HKEY_LOCAL_MACHINE\SOFTWARE\NetSupport\ExtendedLogfileSettings\ClientProxyRpc
                    (bzw im 32 bit zweig auf 64 bit maschinen) auf "0" setzen
                    (oder nicht setzen, dann gelten die werte an den einzelnen funktionen.

                    unter nilogs\clientproxy liegen dann die logfiles (mit der id des clients im namen)
                    wenn ein client in der situation ist, dann sollte im letzten logfile für den client eine begründung stehen.
                    • 7. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
                      ChristophSteckelberg Expert
                      Ich kenne das Problem bisher nur wenn Treiber- bzw. OS Pakete nicht sauber distribuiert sind (CRC-Fehler beim Download) bzw. wenn auf der Platte des OSD-Proxy zu wenig freier Plattenplatz ist, so dass die relevanten Pakete nicht gestaged werden können.
                      Informationen, welche Package ID Probleme macht kannst Du aus den Logfiles im JobQueues Verzeichnis erkennen. Normalerweise hilft es auf dem vom OSD Proxy angesprochenen Depot das betroffene Package-ID-Verzeichnis aus dem Install zu löschen und den Distributionsdienst durchzustarten. Solche faulen Pakete werden übrigens beim Distributions-Monitor als "aktuell" markiert...
                      • 8. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
                        Markus.Zierer Expert
                        Hallo,

                        Also falls Du ne Virtuelle Maschine als Server hast, zumindest bei VMWare gibts die Option nicht im Treiber der NIC. Das ist Richtig. In diesem Fall müsstest Du aber an den Host ran. Denn wenn der Flaschenhals schon am Host sitzt, wird ziemlich sicher auf den Guests ebenfalls nicht viel mehr ankommen.

                        Ich nehme mal an, bei HyperV verhält es sich Ähnlich.
                        • 9. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
                          _Mel_ Master
                          wenn die meldung kommt, dann hat die kommunikation mit dem proxy geklappt.
                          und wenn es immer beim gleichen paket auftritt, dann ist es eher ein distributions/staging problem als ein netzwerkproblem.
                          • 10. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
                            .dr.p. Rookie
                            Hallo,

                            ich habe nun den Reg-Key auf dem Server gesetzt und dann die Installation neu angestoßen. Im Log fällt nun folgendes auf:


                            15:08.48.391  1 ClientProxy.dll  ---- finished 'get cached client item' ---- (time: 0.062501 seconds, Result: 3758686242 [0xE0090022] {info: There is already an storage operation in progress for this cache entry.})

                            15:08.48.391  1 ClientProxy.dll  FPS reported: 3758686242 [0xE0090022] {info: There is already an storage operation in progress for this cache entry.} - instruct client to wait.

                            Demnach scheint es mir ja so zu sein, dass irgendeine Installation "hängt" und somit alles andere blockiert.

                            Wie kann man diesem nun Abhilfe schaffen?
                            • 11. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
                              Markus.Zierer Expert
                              Das sieht mir eher danach aus, als ob beim Download in den RepoCache vom OSDProxy was schief gelaufen ist. Offenbar wird hier versucht die Datei noch zu schreiben und daher sagt der Server zum Client, er muss noch warten. Eigentlich ja auch nicht verwerflich.

                              Es gibt bei den PowerToyz ein Tool namens delpkg.exe. Damit kann man gezielt einzelne Pakete aus dem RepoCache löschen (lassen). Das war in der v6 Ab und an mal notwendig, wenn Dir der Cache vom OSDProxy vollgelaufen war und deshalb keine neuen BootEnvs oder OSSetup Files mehr verfügbar gemacht werden konnten.

                              Ich würde mir als erstes mal den Speicherplatz auf dem OSDProxy ansehen und checken ob da tatsächlich noch genug vorhanden ist. Im nächsten Schritt das fragliche Paket identifizieren und dieses Aus dem RepoCache löschen. Der NIService müsste das Paket dann neu in den Cache schreiben und spätestens dann sollte alles klappen.
                              • 12. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
                                _Mel_ Master
                                die insteressanten teile vom logfile fehlen leider...

                                1. clientproxyservice neu starten und schauen ob's dann geht
                                2. wenn nicht: im logfile nachsehen, welches filepackage er nicht bekommt und überprüfen, und in der dsmc überprüfen, ob die glaubt, daß es verteilt ist.
                                • 13. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
                                  .dr.p. Rookie
                                  Hallo,

                                  den DSM-Server habe ich (und damit ja auch den clientproxyservice) neugestartet. Bei dem im Log angegebenen Paket handelt es sich um das OS Configuration Package und der Policy-Eintrag für den PC (bzw. die PC's) bleibt bei Compliance bevorstehend.

                                  Wie prüfe ich den Speicherplatz auf dem OSDProxy? (Dateiverzeichnis auf HDD?) Wie lösche ich das Paket aus dem RepoCache? EInfach im Dateiverzeichnis unter ...\DSMCache\RepositoryCache\ das entsprechende PAket löschen? Wird das Paket automatisch neu in den Cache geschrieben?

                                  Oder hilft evtl. auch einfach das Paket neu zu distributionieren (Distribution vorbereiten)?
                                  • 14. Re: Fehler bei OS-Installation / WinPE: OSD-Proxy request
                                    _Mel_ Master
                                    bei einem speicherplatzproblem müßte die policyinstanz auf rot gehen. also wahrscheinlich ist ein paket nicht richtig verteilt. (ein freigegebenes, denn bei nicht freigegebenen würde die policyisntanz ebenfalls auf rot gehen)

                                    erstmal im logfile prüfen welches paket das problem macht.
                                    1 2 Previous Next