12 Replies Latest reply on Nov 12, 2012 9:28 AM by _Mel_

    Kein Depot verfügbar (NICFGPRV.00CC)

    SaschaI Apprentice
      Hallo zusammen,

      bin recht neu im Thema Enteo. Die ersten Standartscripts habe ich schon hinter mir jedoch sitze ich jetzt mit einem riesen Problem hier.

      Seit Freitag Nachmittag haben wir/ich folgendes Problem:
      -Rechner wird auf neu installieren gesetzt
      -OSD boot funzt einwandfrei
      -Windows fertig installiert
      -jetzt sollte eigentlich das POST OS Action anlaufen, tut es aber nicht weil der Client sich irgendwie unvollständig installiert

      Bekommen tue ich folgende Fehlermeldung: Fehler beim Starten einer Netinstall Komponente. Kein Depot verfügbar. (NICFGPRV.00.CC)

      Wenn ich den NIMoni starte braucht dieser eine ewigkeit um aufzugehen und ist dann nur sporadisch zu bedienen, die meisste Zeit ist er wie eingefroren. Aufgefallen ist mit jedoch das unter Server/Share (die dritte Zeile ist es glaube ich) ein lokaler Pfad nach C:\Progamme... angegeben ist und nicht wie auf allen anderen Maschinen \\Servername\enteo$....


      Niagnt32.exe schon mit niclean.exe /DIA entfernt und per \\Servername\enteo$
      iinst32.exe /install /bin /force erneut installiert jedoch ohne Lösung des Problems.

      Kennt jemand dieses Problem bzw. eine Lösung???? :-P
        • 1. Re: Kein Depot verfügbar (NICFGPRV.00CC)
          Klaus Salger Expert
          Hallo Sascha,

          hast Du wirklich noch eine V6.0? Dann wäre mein erster Tipp schon mal "Update der Infrastruktur".

          Zu Deinem Problem:
          Die Installation des enteo Agents geht z.B. per \\server\enteo$
          iagnt32.exe /install /bin /force.
          Der Aufruf von niinst32 ist da nicht das Richtige.
          Vor dem Aufruf am besten den Loglevel auf dem Client auf "detailliert" setzen.
          Der Agent schreibt ins NiLogs-Verzeichnis ein Log in dem dann wahrscheinlich etwas genauer steht, was das Problem ist.

          Wenn das Depot, so wie es die Fehlermeldung sagt, tatsächlich nicht erreichbar ist dann kann z.B. sein, dass die Site-Definition fehlerhaft ist, so dass sich der Client einer Site zuordnet, dessen enteo-Share nicht erreichbar ist.
          NiMoni sagt ja in den oberen beiden Zeilen welches die aktuelle Site und der aktuelle Server ist.
          Ist das beides korrekt?
          Ist das enteo-Share auf dem lt. NiMoni aktuellen Server erreichbar?

          Ciao
            Klaus
          • 2. Re: Kein Depot verfügbar (NICFGPRV.00CC)
            SaschaI Apprentice
            ähm ja wir haben noch eine 6.0 :-)
            ziehen asap eine DSM 7 parallel auf, steht in den startlöchern

            zu der problematik mit den sites:
            bis jetzt haben wir nur eine site und das depot steht zu verfügung.
            software verteilen funzt ja noch. bestehende systeme können wir mit neuen paketen füttern, revisionen anlegen, ditribuieren alles kein problem.
            nur neu installierte computer wollen nicht mehr. nach der windows installation ist schluss.

            die oberen beiden zeilen im nimoni sind korrekt nur eben der server/share nicht.
            wieso steht dieser auf lokal?
            .ncp datein habe ich auch überprüft, das sind die aktuellen.


            zwischendrin habe ich irgendwas gelesen von wegen ICDB-Database nicht vorhanden oder kein zugriff... kann das sein? wo muss ich da hin fassen?
            bin ratlos. ticket dazu ist bei frontrange auch schon aufgemacht. jedoch denke ich wird mir hier effizienter geholfen.
            • 3. Re: Kein Depot verfügbar (NICFGPRV.00CC)
              Klaus Salger Expert
              Poste doch mal das Installationslog eines betroffenen Clients.
              • 4. Re: Kein Depot verfügbar (NICFGPRV.00CC)
                SaschaI Apprentice
                im anhang die log datein
                ich hoffe es sind die richtigen
                • 5. Re: Kein Depot verfügbar (NICFGPRV.00CC)
                  _Mel_ Master
                  ok, es ist v6.2 - v6.0 hätte mich auch gewundert...

                  also mein verdacht ist, daß entweder die core-services nicht laufen oder der rechner sich keiner site zuordnet. das würde den lokalen pfad erklären und der ersupext wäre damit auch nicht glücklich.

                  was steht denn im csmext logfile ?
                  • 6. Re: Kein Depot verfügbar (NICFGPRV.00CC)
                    SaschaI Apprentice
                    sorry aber wo finde ich diese csmext.log?
                    • 7. Re: Kein Depot verfügbar (NICFGPRV.00CC)
                      _Mel_ Master
                      im nilogs und wenn man es genau nimmt heißt es cmsext
                      • 8. Re: Kein Depot verfügbar (NICFGPRV.00CC)
                        Klaus Salger Expert
                        Ich denke, dass lokal das
                        etinst\magntext-Verzeichnis bzw. dessen Inhalt fehlt.
                        Und ohne die DLLs können die Services nicht starten.

                        Die Dateien konnten offenbar nicht von \enteo$\magntext kopiert werden.
                        Ich würde mal prüfen, ob das Verzeichnis und die DLLs in enteo$ und im lokalen NetInst-Verzeichnis vorhanden sind bzw. ob der User netinst_srv darauf zugreifen kann.

                        Ciao
                          Klaus
                        • 9. Re: Kein Depot verfügbar (NICFGPRV.00CC)
                          SaschaI Apprentice
                          ich habe keine .log datei welche so heisst. tut mir leid.
                          folgende logs liegen bei mir vor:

                          c$\Program Files\Common Files\enteo\NiLogs\

                          NcpUpdate_1
                          NI32_1
                          NiAgnt32_1
                          NiAgnt32_Install_1
                          NiAgnt32_Install_2
                          NIMoni_1
                          NIMoni_2
                          NiVerChk_1
                          • 10. Re: Kein Depot verfügbar (NICFGPRV.00CC)
                            _Mel_ Master
                            richtig: erster start -> windows\temp

                            siCSM: Can't access source file \\DE-NETIKOHAG05.kmt-eu.kmtg.net\enteo$\magntext\cmsext.dll -> will be skipped
                            der scheint ein problem beim zugriff auf den share zu haben.
                            stimmt da was mit dem depot nicht ?
                            • 11. Re: Kein Depot verfügbar (NICFGPRV.00CC)
                              SaschaI Apprentice
                              das sieht gut aus! der magntext ordner sowie die anderen welche in der NiAgnt32_Install_2.log angemarkert werden sind leer.

                              haben sie vielleicht eine ahnung wie sowas passieren kann?
                              parallel werde ich mal versuchen jemanden bei frontrange zu erreichen.
                              • 12. Re: Kein Depot verfügbar (NICFGPRV.00CC)
                                _Mel_ Master
                                die dateien fehlen auf dem server oder nur auf dem client ?
                                denn wenn sie auf dem server fehlen, dann hat der client keine chance sich richtig zu installieren. wenn sie auf dem server vorhanden sind, dann frage ich mich was da schief geht, denn eigntlich macht der da nur ein FindFirstFile um die existenz zu prüfen und das datum abzufragen. auf die weise dürfte es nichtmal probleme geben, wenn die datei im zugriff ist.
                                wenn es reproduzierbar ist (und danach sieht es ja aus), dann wäre es interessant da mal den procmon aus der sysinternals suite mitlaufen zu lassen.

                                wenn der depotserver irgendwie spinnt könnte es helfen den mal durchzustarten, aber vorher ein procmon log für den support wäre nett.