12 Replies Latest reply on Feb 22, 2013 5:11 AM by NicoS1

    [SOLVED] Client Sync failed

    TimB Apprentice
      Hallo Zusammen,

      wir haben seit kurzem Probleme bei ein paar Clients, dass diese keine Pakete mehr ziehen. In ein paar Logs findet man einige Hinweise auf etwas, womit ich aber nicht ganz so viel anfangen kann.

      Wir haben DSM7.2 (Problem wurde auch bei 7.1 schon gesehen) im Einsatz und auf den Clients Win7/WinXP.

      Von diesem Problem scheinen nur einige WinXP-Client betroffen zu sein.

      Auszug aus dem nisvr32.log

      12:06:36.876 2  ICDBHlp.dll: Found MP: Management Point (DEXX01)
      12:06:36.892 2  ICDBHlp.dll: Random selected MgntPoint is: [66145]
      12:06:36.892 2  CMSClntLib.dll: Using [http://DEXX01.XXX.COM:8080/blsClientManagement/ClientManagementService.asmx] for communication with the BL
      12:06:36.892 2  CMSClntLib.dll: Or using [http://DEXX01.XXX.COM:8080/blsClientManagement/ClientService.svc/] for communication with the BL
      12:06:36.892 2  SWMSRT: Initializing SWMSRunTimeMgr
      12:06:38.789 2    SWMSRT: Could not get all needed ClientObjects!
      12:06:38.805 2   SWMSRT: Performing client sync for computer '35195' and user '1122' with QoS level 'Polling'
      12:10:06.263 E   Warning (Module:SWMSRT, Severity:0x03): Client sync (C:\Programme\Gemeinsame Dateien\DSM\NiLogs\SyncLogs\PerformSync_SYSTEM_0000000020.log) failed [-536541221]
      12:10:06.263 E   Warning (Module:SWMSRT, Severity:0x03): ClientSync failed with error code 3758426075
      Ein Web-Service Aufruf ist fehlgeschlagen.
      12:10:06.279 2   SWMSRT: Client sync for computer '35195' and user '1122' (QoS level 'Polling') failed with 'Ein Web-Service Aufruf ist fehlgeschlagen.' (3758426075)
      12:10:06.279 E   Warning (Module:SWMSRT, Severity:0x03): The initialize synchronization failed
      12:10:06.279 E   Warning (Module:Main, Severity:0x03): Initialization of TargetProvider SWMSTP failed!
      12:10:06.279 2  xniSPD.DLL: Registering algorithm provider 'SWMSSPDUPDATEAGENT;SWMSSPDSCANCAB;SWMSSPDPATCH'



      Im erwähnten Perfomsync.log steht folgendes

      12:06.38.931  2 ICDBHlp.dll  Random selected MgntPoint is: [66145]
      12:06.38.947  0 ICDBHlp.dll  Selected management point 66145, determining URL
      12:06.38.947  0 ICDBHlp.dll  Creating new URL cache entry for Management Point 66145
      12:06.38.947  0 ICDBHlp.dll  Caching and returning new 'blsClientManagement' URL 'http://DEXX01.XXX.COM:8080/blsClientManagement/' for Management Point 66145
      12:06.38.963  2 CMSClntLib.dll  Using [http://DEXX01.XXX.COM:8080/blsClientManagement/ClientManagementService.asmx] for communication with the BL
      12:06.38.963  2 CMSClntLib.dll  Or using [http://DEXX01.XXX.COM:8080/blsClientManagement/ClientService.svc/] for communication with the BL
      12:06.38.963  2 CMSClntLib.dll  Calling 'http://DEXX01.XXX.COM:8080/blsClientManagement/ClientService.svc/Sync?qos=0'
      12:07.41.476  E Warning (Module:mgmtagnt.exe, Severity:0x03): FpsClntHlp.dll  Failed to read data from HTTP request.
      The operation timed out
      12:07.41.476  E Warning (Module:mgmtagnt.exe, Severity:0x03): CMSClntLib.dll  Failed to send HTTP request
      The operation timed out
      12:07.41.476  2 CMSClntLib.dll  Waiting 0 seconds before retry 1/2...
      12:07.41.476  2 CMSClntLib.dll  Sleeping done..
      12:07.41.476  0 CMSClntLib.dll  Force BLS lookup is disabled
      12:07.41.476  0 CMSClntLib.dll  Resolve pareent is disabled
      12:07.41.476  0 ICDBHlp.dll  Selecting random management point for container 0x05797a38
      12:07.41.476  0 ICDBHlp.dll  ----------------------------------------
      12:07.41.476  0 ICDBHlp.dll   Start Gathering MgntPoints
      12:07.41.476  0 ICDBHlp.dll  Add container with ID [66145] to the list for selection
      12:07.41.476  0 ICDBHlp.dll  Add container with ID [66152] to the list for selection
      12:07.41.476  0 ICDBHlp.dll  ----------------------------------------



      Auf dem Client kann man alle ManagementPoint-URLs im Browser öffnen.

      Hat irgendjemand eine Idee wo ich noch nachschauen könnte um dem Problem auf die Spur zu kommen?

      Forcierte Client-Neu-Installationen haben leider keinen Erfolg gebracht!
      Das "Verschieben" der Clients in andere Sites unserer Struktur hat auch nichts gebracht.
      Die NCPs sind auf den betroffenen Clients auf dem neuesten Stand.

      Bin für jeden Hinweis dankbar.
      Tim
        • 1. Re: [SOLVED] Client Sync failed
          NicoS1 Master
          Hallo Tim,

          melde dich mal an einem betroffenen Client mit deinem Runtime / Service User an und Versuche die URL aufzurufen.

          Ich meine mich an ein ähnliches Problem erinnern zu können (noch aus Enteo V6 Zeiten) wo aus "irgendeinem Grund" der Internet Explorer im Profil des Serviceaccounts irgendwelche Proxyeinstellungen gesetzt hatte die vollkommen Banane waren.

          Ich glaube aber die Proxyeinstellungen sollten normal nicht mehr herangezogen werden (außer in den Site Einstellungen ist was konfiguriert, dann hätten es aber mehrere Clients). Prüfen kann man es trotzdem mal.

          Ansonsten wäre mein weiteres Vorgehen:
          - DSM Services auf dem Client deaktivierten => Neu Starten
          - Benutzerprofil des Runtime Benutzers vom Client löschen. DSM Dienste wieder auf Automatisch stellen
          - Computer neu starten.

          Wenn das auch nichts bringt:
          - In der Registry den HKLM\Software\NetSupport\NetInstall\Installed Apps Schlüssel SICHERN.
          - DSM Client komplett entfernen (ggf. gibts die PowerToys noch mit NiClean???)
          - Reg Key wieder importieren.
          - DSM Client neu installieren.
          • 2. Re: [SOLVED] Client Sync failed
            Bastix Rookie
            Hallo Tim,

            ich habe genau das gleiche Problem wie du. Bei mir tritt dieser Fehler anscheinend bei allen Clients auf.
            Hast du eventuell schon mehr dazu in Erfahrung bringen können?

            @NicoS: Deine Lösungsvorschläge haben leider auch nicht geholfen.

            MfG
            Basti
            • 3. Re: [SOLVED] Client Sync failed
              _Mel_ Master
              steht was im bslclientwebservice logfile auf dem bls ?
              entweder exceptions/fehler oder besonders lange zeiten für den sync ?
              der timeout auf dem client beträgt 60 sekunden - entspricht auch der zeit im logfile.
              • 4. Re: [SOLVED] Client Sync failed
                Bastix Rookie
                Hallo Mel,

                vielen Dank für deine Antwort. Ich bin schon einen Schritt weiter gekommen. Mir ist aufgefallen das auf dem ManagementPoint die Komponenten/Dienste "Client Proxy Web Service" und "OSD Proxy Web Service" nicht laufen. Kann die Komponenten/Dienste aber auch nicht mehr starten.
                Somit weiß ich zwar warum der Client-Sync nicht mehr funktioniert aber leider nicht warum sich die Dienste nicht mehr starten lassen.

                Hat hierzu vielleicht noch jemand eine Idee???
                • 5. Re: [SOLVED] Client Sync failed
                  TimB Apprentice
                  Hallo Zusammen,

                  danke schonmal für eure Antworten!

                  @Nico:
                  Hab einiges von deinen Ideen ausprobiert, bin aber leider noch nicht am ziel angekommen.
                  Unter dem runtime Dienst anzumelden hat leider keinen Unterschied gemacht. URL ließ sich problemlos auflösen/öffnen.
                  Proxy-Einstellungen sind für unsere Sites nicht gesetzt.
                  Runtime-User Profil löschen hat nichts gebracht.
                  Eine saubere Deinstallation (yep, niclean gibt's noch!) mit anschließender Neuinstallation hat leider auch nichts gebracht.

                  @Mel:
                  Das könnte ein sehr guter Hinweis gewesen sein!
                  Sehr merkwürdig: Die aktuellste blsclient_webservice.log hat die letzte Änderung/Eintrag im November 2012 gehabt.
                  Hat eventuell das LogLevel was damit zu tun, oder sollte da auf jeden Fall was aktuelles vorhanden sein. (nimoni auf dem BLS sagt auf jeden Fall "Full Loglevel (0))
                  Eventuell war das der Tag des Updates auf Version 7.1.

                  Kann damit jemand was anfangen?

                  BTW: Bei uns sind alle services gestartet.

                  Thx
                  Tim
                  • 6. Re: [SOLVED] Client Sync failed
                    info@offlimits-it.com Expert
                    Welchen Build von der DSM 7.2 setz du ein?
                    • 7. Re: [SOLVED] Client Sync failed
                      _Mel_ Master
                      @Bastix: Der ClientProxy wird nicht für den Clientsync notwendig; der steuert osd und linux clients.

                      die webservices werden als nichts funktionsfähig angezeigt, solange der clientproxy selber nicht gegen den bls syncen konnte.

                      @TimB:
                      das blsclientwebservicelog sollte auf jeden fall was enthalten, das ist unabhängig vom normalen logging und wird über die web.config configuriert...
                      in der 7.2 sind die BLS logfiles ins NiLogs\BLS verzeichnis gewandert
                      • 8. Re: [SOLVED] Client Sync failed
                        TimB Apprentice
                        Hallo Zusammen,

                        @Nordin Markow:
                        Hallo Herr Markow, wir setzen derzeit die Version DSM 7.02.000.1955 ein.
                        Gruß aus Ennepetal

                        @Mel:
                        Ok, gut zu wissen, dass die Logs nun woanders sind!
                        Die Meldung im ClientWebService-Log sieht eigentlich nicht schlecht aus, soweit ich das beurteilen kann.

                        Perfomsynclog vom Client: (Eintrag der entsprechenden Computer-ID)


                        11:01.38.197  2 ICDBHlp.dll  Random selected MgntPoint is: [66145]
                        11:01.38.197  0 ICDBHlp.dll  Selected management point 66145, determining URL
                        11:01.38.197  0 ICDBHlp.dll  Management Point entry 66145 found in the URL cache, looking for 'blsClientManagement' URL
                        11:01.38.197  0 ICDBHlp.dll  'blsClientManagement' is cached, returning URL 'http://DEXXX01.XXX.COM:8080/blsClientManagement/'
                        11:01.38.197  2 CMSClntLib.dll  Using [http://DEXXX01.XXX.COM:8080/blsClientManagement/ClientManagementService.asmx] for communication with the BL
                        11:01.38.197  2 CMSClntLib.dll  Or using [http://DEXXX01.XXX.COM:8080/blsClientManagement/ClientService.svc/] for communication with the BL
                        11:01.38.197  2 CMSClntLib.dll  Calling 'http://DEXXX01.XXX.COM:8080/blsClientManagement/ClientService.svc/Sync?qos=0'
                        11:02.39.603  E Warning (Module:mgmtagnt.exe, Severity:0x03): FpsClntHlp.dll  Failed to read data from HTTP request.
                        The operation timed out
                        11:02.39.603  E Warning (Module:mgmtagnt.exe, Severity:0x03): CMSClntLib.dll  Failed to send HTTP request
                        The operation timed out
                        11:02.39.603  2 CMSClntLib.dll  Waiting 0 seconds before retry 2/2...
                        11:02.39.603  2 CMSClntLib.dll  Sleeping done..
                        11:02.39.603  0 CMSClntLib.dll  Force BLS lookup is disabled
                        11:02.39.603  0 CMSClntLib.dll  Resolve pareent is disabled
                        11:02.39.603  0 ICDBHlp.dll  Selecting random management point for container 0x059f6f98



                        ClientWebServicelog:

                        2013-02-26 11:01:38,567 [875] INFO  Enteo.BlServer.Summary - 10.160.40.249 Anonymous en 411ms NI 7.2.0.1955 Sync [ServiceInstaller] (Computer 21253, User 1122, 1 Changes, 1358 Revs)



                        Diesen Vorgang macht er dann viermal, wahlweise auf den beiden Management-Points (BLS und Failover BLS), aber immer die obigen Resultate.

                        Die DSM-Dienste laufen alle auf dem Client und eine Firewall ist auch nicht aktiv.


                        Gruß
                        Tim
                        • 9. Re: [SOLVED] Client Sync failed
                          TimB Apprentice
                          Wow, das wird gerade immer mehr bei uns.

                          Ex sind defintiv nur XP-Clients, die das Problem haben, auch direkt während einer OS-Deployment-Phase (beim ersten starten des OS & niagnt).

                          Win7 PCs laufen ohne Probleme!

                          Any ideas???
                          • 10. Re: [SOLVED] Client Sync failed
                            TimB Apprentice

                            steht was im bslclientwebservice logfile auf dem bls ?
                            entweder exceptions/fehler oder besonders lange zeiten für den sync ?
                            der timeout auf dem client beträgt 60 sekunden - entspricht auch der zeit im logfile.



                            Wo könnte ich den TimeOut Wert verändern?
                            Bei uns am Standort mit 100Mbit zum RZ geht's nämlich auch noch mit XP!

                            Erschwerend kommt bei uns noch hinzu, dass viele Lokationen neuerdings mit WAN-Beschleunigung connectiert sind.
                            Könnte DSM damit ein Problem haben???
                            • 11. Re: [SOLVED] Client Sync failed
                              Bastix Rookie
                              Hallo Zusammen,

                              mein Problem ist jetzt sozusagen gelöst. Nach einem 2-Tages-Marathon mit dem FrontRange-Support der sich sogar auf den Server geschalten hat und den Fehler auch nicht finden konnte, haben wir den Management Point gelöscht und neu installiert. Danach sind wieder alle Dienste gelaufen, die Clients syncen wieder fleißig und das OS-Deployment funktioniert auch wieder.

                              @Tim: Sorry, hilft dir zwar auch nicht weiter aber ich wünsch dir noch viel Erfolg bei der Fehlersuche.

                              @Rest: Vielen Dank für die zahlreichen Tipps.

                              MfG
                              Basti
                              • 12. Re: [SOLVED] Client Sync failed
                                TimB Apprentice
                                Hallo Zusammen,

                                ich denke wir können das Thema abschließen.

                                Bastix ist zufrieden und ich weiß jetzt auch woran es bei uns liegt.
                                Es sind tatsächlich die Wan-Beschleuniger, schließen wir die BLS von der Beschleunigung aus geht's wieder, somit ist das Troubleshooting auf der DSM Seite abgeschlossen!

                                Danke für eure Ideen!

                                Gruß
                                Tim