2 Replies Latest reply on Jul 6, 2009 5:28 AM by phoffmann

    Pre-Requisite batch file result ignored

    Rookie

      I have been looking into finding a good reliable way of depoying software with Landesk. In another thread I was trying to find a way to replicate the way a GPO installs software on startup.

      From this it was suggested to run a pre-requisite batch file to detect if the software was running or not and either delay. I tootled off and found a nice vbscript to detect running processes etc and as per the documentation return a 1 code to fail if the process was running and a 0 if not. The VBScript seemed to do it's job in testing however I could not get this to work in a deployment package.

      I tried calling the VBS file from a batch file.

      Then writing out debugging info to the local PC.

      From which I had to conclude that this LANDESK feature just didn't seem to be working. I then put a specific exit code in my batch file with EXIT /B 1. This line from what I have read should make LANDESK report a failure every time however my package just kept on installing.

       

      Question

      Am I using the pre-requisite check correctly. I have added the extra file for my batch file and specified it to be called as "Run Additional File". The batch file is as follows.

       

      echo on
      echo "exiting with ErrorCode %ERRORLEVEL%" >> c:\errorcheck.txt
      exit /B 1

      The output tect file shows an errorcode of 0 as there are no actions but the exit /B 1 should return a 1 back to Landesk for a failure. I have done this with code that does not return a 0 and the result is the same. When run, my package still installs successfully and does not recognise the failure.

       

      I am running Landesk 8.7

        • 1. Re: Pre-Requisite batch file ignored
          Rookie

          A bit more testing shows if I run the batch file as a standalone package or a preliminary package it correctly fails.

           

          Alternate Question

          The documentation suggests I can use preliminary packages with push, policy and policy assisted push deployments. I am however only able to select a preliminary package using a push deployment. Please could someone clarify if I should be able to use a preliminary package with a policy assisted push deployment?

           

          Thanks

          Pete

          • 2. Re: Pre-Requisite batch file ignored
            phoffmann SupportEmployee

            Apologies for the belated response, I was on holidays when this originally was posted and only stumbled over it now.

             

            You CAN use "Preliminary Packages" and "Final Packages" quite happily with any of the methods - Push / Policy / Policy supported push.

             

            The thing you most likely stumble over (which gets me also pretty frequently until I remember it) is that you can ONLY use *PUBLIC* packages as preliminary/final packages.

             

            You can use personal (i.e. "My Distribution packages" ) as the main package, but in order to be preliminary or final, you need to have that be a PUBLIC package:).

             

            - Paul Hoffmann

            LANDesk EMEA Technical Lead