8 Replies Latest reply on May 13, 2013 8:07 AM by derniwi

    Falsche Revision bei Pre OS Packages

    NVUser Specialist
      Hallo mal wieder,

      ich habe folgendes Problem und erkenne nicht den Grund:
      Wir mußten wegen einem neuen Rechnermodel das Bootenviroment aktualisieren. Nach Einbinden der neuen LAN-Treiber habe ich distribuiert und freigegeben. Dann die entsprechenden Pakete aktualisiert, die das Bootenviroment nutzen (sollen). Das sind bei uns 2 verschieden Pre OS Packs, das OS Config Package und zum Schluß das OS Set. Nun bootet er normal ins Netz und das erste PreOSPack läuft (Kopieraktion vor Umstellung auf ein neues OS). Dann wurde bisher das zweite PreOSPack (Partitionieren und Formatieren) gleich danach gestartet. Jetzt bootet er dazwischen aber neu, lädt noch mal das PE und macht dann erst mit dem Formatieren weiter. Als Grund (und das stand so schon im Abschluß des ersten Packs) wegen einer anderen benötigten Bootumgebung. Tatsächlich steht dann als geladenes Bootenviroment im zweiten Pack eine ältere Revision drin, als beim ersten PreOSPack. Aber ich habe gewiss, und das kann man ja auch in den Packs nachsehen, das aktuelle Bootenviroment hinterlegt, distribuiert und freigegeben…

      Wo kann da das Problem liegen? Hatte im Wizard dann auch mal beim Aktualisieren des Bootenviroment „OSD Client aktualisieren“ angehakt, aber das hat auch nichts gebracht. Was macht dieser Schalter eigentlich genau und woher zieht er noch die alte Revision? Steht die sonst noch irgendwo/kann man sich das irgendwo anzeigen lassen?

      Danke für Eure Tipps, mir brummt der Schädel…

      Torsten
        • 1. Re: Falsche Revision bei Pre OS Packages
          _Mel_ Master
          wahrscheinlich ist das bootenvironment bei zuweisung änderbar.
          dann wird beim update der policy der bootenvironmentlink nicht vom paket übernommen.
          d.h. einfach an der policy nach dem hochziehen des paketes noch das bootenvironment setzen oder das bootenvironment nicht bei zuweisung änderbar machen
          • 2. Re: Falsche Revision bei Pre OS Packages
            info@offlimits-it.com Expert
            Das Problem haben wir auch bei vielen Kunden. Wann ist denn daran gedacht diesen Bug und ein solcher ist es jawohl zu beheben?
            • 3. Re: Falsche Revision bei Pre OS Packages
              _Mel_ Master
              genau genommen ist es kein bug, denn das system verhält sich eigentlich "richtig" (in dem sinne, daß das verhalten wie es ist tatsächlich beabsichtigt ist) - was leider nicht unbedingt dem entspricht, was man als benutzer erwarten würde.

              aber ich bin optimistisch, daß wir zur nächsten version ne deutlich spürbare verbesserung hinbekommen.
              • 4. Re: Falsche Revision bei Pre OS Packages
                NVUser Specialist
                Hi Mel,

                vielen Dank mal wieder für die sehr schnelle Antwort und … so geht es dann!
                Allerdings ist das schon ein wenig verwirrend, da ich ja die beiden PreOSPacks gleich behandelt habe. Das das erste dann ging war also nur ein Zufall? Denn bei beiden Packs ist der Haken für „Änderung bei Zuweisung“ gesetzt. Und bisher hatte ich an dieser Stelle noch nie was geändert. War es also bisher immer nur Zufall, daß es ging und er mal die richtige Revision genommen hat?
                Na egal, wenn man weiß wo man drehen muß, ist das ja schon mal was, aber für Neulinge (wie mich) im Bereich OSD alles andere transparent, da muß ich Euch beiden recht geben.

                Und was passiert, wenn man im Wizard beim Aktualisieren des Bootenviroment „OSD Client aktualisieren“ anhakt? Sollte man das immer setzen?
                • 5. Re: Falsche Revision bei Pre OS Packages
                  _Mel_ Master
                  hm evtl gibt's da auch noch ein thema mit sets...

                  OSD Client aktualisieren bringt die client dateien im bootenvironment auf den aktuellen stand.
                  kann man eignetlich immer anhaken, solange man da keine händischen änderungen vorgenommen hat (binaries ausgetauscht oder was an der ini geändert - das mit der ini sollte man vielleicht mal ändern)
                  • 6. Re: Falsche Revision bei Pre OS Packages
                    NVUser Specialist
                    Ah, ok dann danke nochmals für die schnelle Hilfe und die Infos!
                    • 7. Re: Falsche Revision bei Pre OS Packages
                      Raphael1 Rookie
                      Hallo Community,
                      dummerweise ist in unserem OS ConfigurationPack auch der Haken gesetzt.
                      Hab den Haken im Nachhinein entfernt,WinPe Image aktualisiert, neu distribuiert und Revision erhöht.
                      Das gleiche mit dem dazugehörigen OS Installation Set.
                      Jedoch wird immer noch die alte WinPe Revision gezogen.
                      Ich vermute, das die Änderung erst wirksam wird, wenn ich die OS Installation Set Zuweisung lösche und neu zuweise, was ich eigentlich verhindern will, da sonst alle Clients neu installiert werden.
                      Hab mir jetzt mit einenm unschönen Workaround weitergeholfen, aber stimmt meine Vermutung,oder sollte das so wie Mel beschrieben hat auch ohne löschen und neu Zuweisen des OS Sets funktionieren?

                      Danke und Grüsse Raffa
                      • 8. Re: Falsche Revision bei Pre OS Packages
                        derniwi Master
                        Hallo,

                        die Zuweisung wird auch bei der Freigabe des Paketes aktiv. Änderungen an einem Set sind leider immer etwas heikel, einmal eine Pilotinstallation zugeordnet kann man am Set vieles ändern, ohne das es sich direkt auswirkt. Hier hilft dann entweder die Policy zu löschen oder das Paket freizugeben. Bei letzterem darfst du in deinem Fall halt nicht die Policy-Instanzen auf die aktuelle Revision aktualisieren.

                        Gruß
                        Nils