12 Replies Latest reply on Mar 6, 2015 2:03 AM by Nice2010

    performance Problem oder doch normal?

    Nice2010 Expert
      Hallo,

      wir analysieren seit einigen Tagen unsere Umgebung wegen einiger performance Probleme. Wir haben einen Punkt im bls_ClientWebService.log gefunden. Die Zugriffszeiten liegen immer im hohen dreistelligen Bereich. Was eigentlich nach Aussagen von FrontRange zu hoch ist. Auch Werte um die 1400 ms sind keine Seltenheit. Die Zeiten der anderen Services liegen hingegen im unteren zweistelligen Bereich. Zum Vergleich habe ich nun unsere Testumgebung überprüft und festgestellt, dass die Zeiten dort fast identisch mit der Produktion sind. Nur sind in der Testumgbung kaum Clients, Policys und Verteilungen aktiv. Das die Werte gleich hoch sind, macht also keinen Sinn.
      Kann mal jemand von euch prüfen wie die Zugriffszeiten in eurer Umgebung ist?

      Wichtig wäre noch das der Patch Level indentisch ist. Wir haben 2642

      Vielen Dank
        • 1. Re: performance Problem oder doch normal?
          SBRUTSCH Expert
          Hi,

          könnte dir helfen wenn du mir sagst welche Zeilen du genau meinst. Ich habe nur bei manchen Zeilen Datum und Uhrzeit stehen.


          2015-02-25 11:12:21,845 [3] INFO  Enteo.BlServer.Config - Checking extension dependencies ...
          2015-02-25 11:12:21,845 [3] INFO  Enteo.BlServer.Config - ... check successful
          2015-02-25 11:12:21,845 [3] INFO  Enteo.BlServer.Config - DataAccess is of build 7.2.3.2627
          2015-02-25 11:12:21,845 [3] INFO  Enteo.BlServer.Config - CMDB is of version 7.2.3.15
          2015-02-25 11:12:23,078 [3] INFO  Enteo.BlServer.Config.ServiceWorker.AlertDownload - Using config file for reading AppSettings: c:\windows\system32\inetsrv\w3wp.exe.config
          2015-02-25 11:12:25,933 [3] INFO  Enteo.BlServer.Config - Registered Extensions:


          Viele Grüße
          Stefan
          • 2. Re: performance Problem oder doch normal?
            Nice2010 Expert
            Hallo,

            wir haben sehr viele von diesen Einträgen:
            ------------------------------------------------------------------------------------------
            2015-03-06 08:08:15,689 [30] INFO  Enteo.BlServer.Summary -  Anonymous en 1294ms NI 7.2.3.2582 Sync [ServiceInstaller] (Computer 107307, User 1457, 3 Changes, 720 Revs)
            2015-03-06 08:08:19,409 [30] INFO  Enteo.BlServer.Summary -  Anonymous en 822ms NI 7.2.3.2582 Sync [ServiceInstaller] (Computer 102821, User 1457, 3 Changes, 417 Revs)
            2015-03-06 08:08:20,244 [30] INFO  Enteo.BlServer.Summary -  Anonymous en 713ms OSD 7.2.3.2627 Sync [ClientProxy] (Computer 102821, User 0, 1 Changes, 180 Revs)
            2015-03-06 08:08:20,524 [573] INFO  Enteo.BlServer.Summary - Anonymous en 1329ms NI 7.2.3.2582 Sync [AutoInstaller] (Computer 106885, User 102166, 5 Changes, 817 Revs)
            2015-03-06 08:08:21,298 [30] INFO  Enteo.BlServer.Summary -  Anonymous en 853ms NI 7.2.3.2582 Sync [AutoInstaller] (Computer 98955, User 43058, 1 Changes, 989 Revs)
            2015-03-06 08:08:26,515 [30] INFO  Enteo.BlServer.Summary -  Anonymous en 1105ms NI 7.2.3.2582 Sync [ServiceInstaller] (Computer 100617, User 1457, 1 Changes, 998 Revs)
            2015-03-06 08:08:28,995 [30] INFO  Enteo.BlServer.Summary -  Anonymous en 845ms NI 7.2.3.2582 Sync [AutoInstaller] (Computer 106093, User 106918, 1 Changes, 965 Revs)
            2015-03-06 08:08:30,446 [30] INFO  Enteo.BlServer.Summary -  Anonymous en 530ms OSD 7.2.3.2627 Sync [ClientProxy] (Computer 102821, User 0, 1 Changes, 180 Revs)
            2015-03-06 08:08:34,938 [30] INFO  Enteo.BlServer.Summary -  Anonymous en 526ms OSD 7.2.3.2627 Sync [ClientProxy] (Computer 102821, User 0, 1 Changes, 180 Revs)
            2015-03-06 08:08:35,688 [573] INFO  Enteo.BlServer.Summary - Anonymous en 912ms NI 7.2.3.2582 Sync [AutoInstaller] (Computer 103727, User 80960, 6 Changes, 794 Revs)
            2015-03-06 08:08:36,659 [573] INFO  Enteo.BlServer.Summary - Anonymous en 945ms NI 7.2.3.2582 Sync [ServiceInstaller] (Computer 103826, User 1457, 6 Changes, 1016 Revs)
            2015-03-06 08:08:41,241 [573] INFO  Enteo.BlServer.Summary - Anonymous en 792ms OSD 7.2.3.2627 Sync [ClientProxy] (Computer 106849, User 0, 1 Changes, 170 Revs)
            2015-03-06 08:08:41,958 [30] INFO  Enteo.BlServer.Summary -  Anonymous en 1353ms NI 7.2.3.2582 Sync [AutoInstaller] (Computer 81760, User 94838, 1 Changes, 988 Revs)
            2015-03-06 08:08:42,052 [573] INFO  Enteo.BlServer.Summary - Anonymous en 598ms OSD 7.2.3.2627 Sync [ClientProxy] (Computer 106849, User 0, 1 Changes, 170 Revs)
            2015-03-06 08:08:43,503 [573] INFO  Enteo.BlServer.Summary - Anonymous en 814ms NI 7.2.3.2582 Sync [AutoInstaller] (Computer 105772, User 100510, 7 Changes, 728 Revs)
            2015-03-06 08:08:44,034 [573] INFO  Enteo.BlServer.Summary - Anonymous en 9ms NI 7.0.0 GetPackageInfo
            • 3. Re: performance Problem oder doch normal?
              derniwi Master
              Hallo,

              ich bin ein PL weiter, mit ca. 400 PCs und die komplette Installation von DSM auf einer VM liegen hier die Werte bei ca. 150ms. Mit Ausreißern, klar.

              Gruß
              Nils
              • 4. Re: performance Problem oder doch normal?
                MarkusMichalski Specialist
                Moin,

                ist die Netzwerkkarte auf dem BLS richtig konfiguriert? Also die Geschwindigkeit, Full-Duplex, TCP Offloading deaktiviert, etc; hierzu gibt es Infos beim Support. Ich habe so etwas schon bei einem Kunden nach der Aktualisierung von Netzwerkkartentreibern gesehen.

                Gruß, Markus
                • 5. Re: performance Problem oder doch normal?
                  _Mel_ Master
                  wie sind denn die pingzeiten zwischen BLS und datenbank (falls die auf unterschiedlichen rechnern laufen) ?
                  ich hab mal gesehen was passiert, wenn man mehrere zeitzonen (!) zwischen BLS und datenbank hat - das erhöht die synczeiten gleich mal um einen faktor 10.
                  • 6. Re: performance Problem oder doch normal?
                    Nice2010 Expert
                    Ich denke es liegt nicht an der Konfiguration. Imbls_AdministrationWebService.log liegen die Zugriffszeiten bei:

                    2015-03-06 09:58:59,302 [491] INFO  Enteo.BlServer.Summary - de-DE 43ms dsmc.exe

                    Mich interessieren wirklich mal vergleichszahlen, wer kann welche Liefern?
                    • 7. Re: performance Problem oder doch normal?
                      Nice2010 Expert

                      wie sind denn die pingzeiten zwischen BLS und datenbank (falls die auf unterschiedlichen rechnern laufen) ?
                      ich hab mal gesehen was passiert, wenn man mehrere zeitzonen (!) zwischen BLS und datenbank hat - das erhöht die synczeiten gleich mal um einen faktor 10.



                      Die Zeiten liegen bei <1ms - der BLS als auch der SQL Server haben kaum Last.
                      • 8. Re: performance Problem oder doch normal?
                        SBRUTSCH Expert
                        DSMC Zugriffszeiten haben wir hier auch zwischen 170 bis 240ms bei der Abfrage von GetInfrastructurTask.
                        Bei Zugriffen z.B. auf GetObjectList sind es um die 40ms.

                        Ist eine Umgebung mit getrennten Servern und ca. 15.000 Clients.
                        BLS virtualisiert auf einen zentralen SQL 2012 Server der ebenfalls unter VMware läuft.

                        Gruß
                        Stefan
                        • 9. Re: performance Problem oder doch normal?
                          NicoS1 Master
                          Hallo,

                          Patchlevel 2372 hier, etwas über 1000 Clients (Europaweit), 1 virtualisierter BLS + Datenbank auf SQL Cluster im gleichen Rechenzentrum, teilweise BLPs im Einsatz.

                          Ich hab über 4 Stunden einen einzigen Ausreiser, der über VPN rein kommt mit 480 ms.
                          ansonsten liegt alles im Schnitt bei ca. 150 ms.

                          Evtl. wären noch ein paar Eckdaten zu deiner Umgebung hilfreich. Virtuell? (Platform?), OS, wie "weit" ist die Datenbank weg?

                          P.S.: DSMC bei ~20-30ms (durch ein paar Firewalls und eine dicke WAN strecke)

                          Gruß
                          • 10. Re: performance Problem oder doch normal?
                            Nice2010 Expert
                            Wir haben ca. 4000 Clients. Der BLS und der SQL Server sind physik und die hängen mehr oder weniger an einem Switch.

                            Was ich nicht verstehe ist, die anderen Dienste bls_AuxiliaryService und bls_AdministrationWebService arbeiten normal schnell.

                            Daher fällt es mir schwer an Netzwerk oder Server Tuning zu denken. Die Verbindung zwischen den Servern ist sau schnell und die Auslastung der beiden Server ist im unteren drittel.

                            Und wenn ich sehe das er für drei Änderungen 1285ms braucht, dann frage ich mich warum.
                            • 11. Re: performance Problem oder doch normal?
                              _Mel_ Master
                              er muß im sync auch die policies durchrechnen. d.h. je nachdem wieviele policies insgesamt existieren und wieviele PIs durchschnittlich an einem rechner hängen kann das natürlich auch die synczeiten beeinflussen.
                              arbeitet ihr viel mit shop policies ?
                              • 12. Re: performance Problem oder doch normal?
                                Nice2010 Expert
                                Guten Morgen,
                                Shop Policys haben wir kaum. Ich glaube fünf oder so. Wir arbeiten mit mehreren dyn. Gruppen. Ich habe gerade mal so um die 20 dyn. Gruppen pro Client überschlagen. Wobei nicht jeder Gruppe eine Policy zugewiesen ist. Und einem Client sind so um die 80 Pakete zugewiesen (OS, Treiber und Software).