6 Replies Latest reply on Mar 29, 2016 7:08 AM by Klaus Salger

    DSM 2015.2: Auto-Installer und "Skipping user-cmd."

    derniwi Master
      Hallo,

      ich arbeite gerade an einem neuen Paket. Hier sehe ich immer wieder mal folgende Meldung im "NIAI32_xxx.log":
      12:47:37.653 1          Evaluating condition "not _WMI_Name_='iexplore.exe'"
      12:47:37.653 0           Comparing '' with 'iexplore.exe'
      12:47:37.653 2          Condition TRUE    -> entering IF part
      12:47:37.669 1           RegValue 'ProgramFilesDir' resolved as 'C:\Program Files (x86)'

      12:47:37.669 2          ->   RunAsEx('C:\Program Files (x86)\Internet Explorer\iexplore.exe','','',*****,'','',raUseCurrentUser+UndoneContinueParentScript)/TU
      12:47:37.669 1           Skipping user-cmd.

      12:47:37.669 2          ->   Sleep('30')


      Ich habe den Auto-Installer wie gewohnt mit
      "niinst32 /ai"
      gestartet... aber die gleiche Meldung erhalte ich auch, wenn ich die Änderungen am Rechner über die DSMC ausführen lasse.
      Und dieses Paket läuft auf einer anderen Maschine wie gewünscht (gleicher angemeldeter Benutzer). Der einzige Unterschied ist, dass auf edm "funktionierenden" System Win 7 x86 läuft, unter Win 7 x64 macht es Probleme...

      Hat das auch schon jemand gehabt?

      Gruß
      Nils
        • 1. Re: DSM 2015.2: Auto-Installer und "Skipping user-cmd."
          MarkusMichalski Specialist
          Moin Nils,

          aus dem Logfile sollte auch hervorgehen, ob der User-Part bereits installiert ist - dann wäre das Verhalten richtig.
          • 2. Re: DSM 2015.2: Auto-Installer und "Skipping user-cmd."
            derniwi Master
            Hallo Markus,

            auch bei einer Neu-Installation des Paketes? Und das Paket selbst darf nur im Kontext des Benutzers laufen.

            Ich installiere den Rechner (bzw. beide) gerade neu, dann prüfe ich das alles nochmal.

            Gruß
            Nils
            • 3. Re: DSM 2015.2: Auto-Installer und "Skipping user-cmd."
              Klaus Salger Expert
              Hallo Nils,

              auch bei einem frisch installierten Computer kann das so vorkommen - wenn der Benutzer ein roaming Profile hat.

              Dann erkennt der Installer, dass der Benutzerteil schon vorhanden ist und installiert nur den fehlenden Computerteil.
              Wie Markus schon sagte, das Log sollte darüber Aufschluss geben, ob der Benutzerteil als fehlend erkannt wurde bzw. welchen Teil der Installer meint installieren zu müssen.

              Wenn Du das Paket danach direkt nochmal installierst, dann würde ich erwarten, dass sowohl Computer- als auch Benutzerteil (re-) installiert werden.
              Alternativ kannst Du auch den Benutzerteil bei Deinem Testbenutzer (z.B. per NiMoni oder durch Löschen des Profils) entfernen und die Installation nochmal starten - dann sollte (nachdem der Computerteil schon drauf ist) nur der Benutzerteil installiert werden oder wenn beide fehlen eben beide Teile.

              Ciao
                Klaus
              • 4. Re: DSM 2015.2: Auto-Installer und "Skipping user-cmd."
                MarkusMichalski Specialist
                Hallo,

                auch bei einer Neu-Installation des Paketes? Und das Paket selbst darf nur im Kontext des Benutzers laufen.


                wie das Klaus schon beschrieben hat: beim Testen unbedingt darauf achten, das keine Reste von vorherigen Installationen/Tests vorhanden sind. Gerade Roaming Profiles sind anfällig für dieses Verhalten, sowie Clients bei denen nur das OS neu installiert wird ohne das Profil zu löschen (Recovery).
                • 5. Re: DSM 2015.2: Auto-Installer und "Skipping user-cmd."
                  derniwi Master
                  Hallo,

                  roaming profiles haben wir nicht im Einsatz.
                  Aber leider immer wieder merkwürdige Phänomene in Verbindung mit Paketen und Sets, die nur im Benutzerkontext laufen bzw. die nur Benutzern / Benutzergruppen zugeordnet sind.

                  Nach der Neuinstallation des Rechners war die Policy-Instanz für ein paar Pakete grün, die aber laut Protokoll (Log auf Debug Level) gar nicht gelaufen sind... und die Ausführungszeit des Paketes wäre im Zeitraum der Neuisntallation gelegen. Da muss ich jetzt nochmal schauen, aber ich habe gerade das komplette Set sowie die Pakete mal überarbeitet...

                  Gruß
                  Nils
                  • 6. Re: DSM 2015.2: Auto-Installer und "Skipping user-cmd."
                    _Mel_ Master
                    was steht für die pakete denn als lastcomment und als LastExecutionMode drin ?