9 Replies Latest reply on Jul 13, 2016 4:41 AM by SitzRieSe

    DSM 2016 - Fehler bei neuer Installation

    RWA Specialist
      Hallo zusammen,

      ich setze gerade eine kleine DSM 2016 Testumgebung auf. Also eine Neuinstallation mit DSM 2016 (kein Update! Bei Updates hatte ich dieses Problem nie).
      Leider kriege ich in der neuen Umgebung immer eine Fehlermeldung wenn ich ein neues Paket erstelle:


      Execution Failed.
      Error #-536607932: The Schema Tag 'eScriptPackage' of the object is unknown. This can be due to a missing license.

      (Fehler kommt bei allen Pakettypen, nicht nur eScript)
      Lizenzen könnens eigentlich nicht sein. habs sowohl mit den mitgelieferten Eval-Lizenzen als auch mit richtigen Lizenzen probiert.

      hier der Eintrag im dsmc log:
      15:22:27.386 1   esiConsoleExt: > Action 'eScript Package ...' started

      15:22:27.386 1    esiConsoleExt: > Action 'ActionInit' started
      15:22:27.386 1     esiConsoleExt: > Action 'ActionInit' completed without warnings (Action took 0 ms.)

      15:22:27.386 1    esiConsoleExt: > Action 'ActionPerform' started

      15:22:27.401 1     BlsAdminLib: > Action 'CreateObject( New eScript Package, eScriptPackage )' started
      15:22:27.448 2      BlsAdminLib.dll: SoapException:
      15:22:27.448 0      BlsAdminLib.dll:  detail:
      15:22:27.448 0      BlsAdminLib.dll: Error #-536607932: The schema tag 'eScriptPackage' of the object is unknown. This can be due to a missing license.
      15:22:27.448 2      BlsAdminLib.dll: Request failed adding MP with ID [66041] to the list of failed servers
      15:22:27.448 0      ICDB.dll: ----------------------------------------
      15:22:27.448 0      ICDB.dll: Init ICDB
      15:22:27.464 0      ICDB.dll: ----------------------------------------
      15:22:27.464 0      ICDB.dll: Init ICDB
      15:22:27.464 0      ICDBHlp.dll: Selecting random management point for container 0x07202c98
      15:22:27.464 0      ICDBHlp.dll: ----------------------------------------
      15:22:27.464 0      ICDBHlp.dll:  Start Gathering MgntPoints
      15:22:27.464 0      ICDBHlp.dll: Starting at container [65535] to iterate
      15:22:27.464 0      ICDBHlp.dll: Read container properties Type and ID
      15:22:27.464 0      ICDBHlp.dll: Check if the type of the container [66040] is MgntPoint
      15:22:27.464 0      ICDBHlp.dll: Container with ID:[66040] is ignored because of the wrong container type!
      15:22:27.464 0      ICDBHlp.dll: Read container properties Type and ID
      15:22:27.464 0      ICDBHlp.dll: Check if the type of the container [66041] is MgntPoint
      15:22:27.464 0      ICDBHlp.dll: The type is MgntPoint, Check if this MgntPoint has the requested components installed
      15:22:27.464 0      ICDBHlp.dll: Checking if Component [enteo Business Logic Server HA Node] is registerd on MgntPoint
      15:22:27.464 0      ICDBHlp.dll: Component is registerd
      15:22:27.464 0      ICDBHlp.dll: Add Container with ID [66041] from ICDB to the all MP list
      15:22:27.464 0      ICDBHlp.dll: Read container properties Type and ID
      15:22:27.464 0      ICDBHlp.dll: Check if the type of the container [66039] is MgntPoint
      15:22:27.464 0      ICDBHlp.dll: Container with ID:[66039] is ignored because of the wrong container type!
      15:22:27.464 0      ICDBHlp.dll: Read container properties Type and ID
      15:22:27.464 0      ICDBHlp.dll: Check if the type of the container [66036] is MgntPoint
      15:22:27.464 0      ICDBHlp.dll: Container with ID:[66036] is ignored because of the wrong container type!
      15:22:27.464 2      ICDBHlp.dll: The initialization of the selected list from the icdb failed, do fallback and gathering all BLS
      15:22:27.464 0      ICDBHlp.dll: Container with ID [66041] is not added to the list of select MPs, because he is explicit ignored
      15:22:27.464 0      ICDBHlp.dll: ----------------------------------------
      15:22:27.464 0      ICDB.dll: RefCounter befor closing: 5
      15:22:27.464 0      ICDB.dll: RefCounter befor closing: 4
      15:22:27.464 0      BlsAdminLib.dll: Last request failed, new url couldn't be calculated
      15:22:27.464 2      BlsAdminLib.dll: SoapError from Server: Error #-536607932: The schema tag 'eScriptPackage' of the object is unknown. This can be due to a missing license.
      15:22:27.464 1      BlsAdminLib: > Action 'CreateObject( New eScript Package, eScriptPackage )' failed (Action took 62 ms.)
      15:22:27.464 1     esiConsoleExt: > Action 'ActionPerform' completed without warnings (Action took 78 ms.)

      15:22:27.464 1    esiConsoleExt: > Action 'Action exception handler' started
      15:22:27.464 E     Warning (Module:esiConsoleExt, Severity:0x02): Error #-536607932:
      The schema tag 'eScriptPackage' of the object is unknown. This can be due to a missing license.
      15:22:27.464 1     esiConsoleExt: > Action 'Action exception handler' completed with 1 warnings (Action took 0 ms.)


      Jemand eine Idee woran es liegen könnte? (Und: hat schon jemand mal die 2016 neu installiert und dort nicht dieses Problem gehabt?).

      Dank + Grüße,
      René.
        • 1. Re: DSM 2016 - Fehler bei neuer Installation
          night Apprentice
          Hallo René,

          ich hatte lediglich Probleme beim Update, da ich die Windows Server Rollen bei meiner 2015.2 Installation mit dem Script von der ISO installiert hatte. Eine komplette Neuinstallation konnte ich bisher noch nicht probieren.

          Der Update Manager benötigt auf dem BLS den Rollendienst "URL-Autorisierung", dieser ist jedoch laut Dokumentation bisher nicht benötigt wurden und wird auch in den Systemvoraussetzungen für DSM 2016.1 nicht aufgelistet. Auch das PS Script auf der ISO der 2016.1 prüft diesen Dienst nicht. Ticket ist auch bereits bei der Entwicklung zur Prüfung

          Dein Fehler "Last request failed, new url couldn't be calculated" könnte darauf deuten das dieser Dienst wirklich benötigt aber nicht installiert wurde.

          Nicht das es da wirklich ein Problem beim Installer gibt.

          Gruß Frank
          • 2. Re: DSM 2016 - Fehler bei neuer Installation
            NicoS1 Master
            Hallo Rene,

            also eine Neuinstallation der 2016.1er habe ich auch noch nicht durchgeführt, aber meine Idee wäre spontan nachträglich nochmal irgend eine Kleinigkeit am Zentralen Management Point was zu drehen (irgend einen Service Installieren und wieder rausnehmen, dann wird der Management Point ja mehr oder weniger deinstalliert und wieder neu installiert. Vielleicht zieht er dann die fehlenden Schemata nach.

            Gruß
            • 3. Re: DSM 2016 - Fehler bei neuer Installation
              _Mel_ Master
              1. besteht das problem auch nach einem iisreset ?
              2. such mal im blsadminwebservice logfile nach escript; da sollte eigentlich einiges dazu auftauchen, wenn er die ganzen typen registriert; falls das nicht passiert, dann verrät das log vielleicht warum nicht
              • 4. Re: DSM 2016 - Fehler bei neuer Installation
                RWA Specialist
                Also IISReset und  Installation/Deinstallation einer Mgmt.Anwendung habe nicht geholfen. Ich habe sogar den Server komplett neu installiert.. immer noch der gleiche Effekt.

                Im webservice log ist mir aufgefallen, das wesentlich weniger Extensions geladen werden als auf einem funktionierenden 2016 Server (der wurde aktualisiert, nicht neu installiert).

                Hier der Testserver der nicht funktioniert:
                2016-07-07 20:21:03,424 [1] INFO  Enteo.BlServer.Config - Loading base extensions ...
                2016-07-07 20:21:03,424 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.DataAccess
                2016-07-07 20:21:03,564 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.DataAccess.Api
                2016-07-07 20:21:03,564 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Common
                2016-07-07 20:21:03,580 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Base
                2016-07-07 20:21:03,627 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Core
                2016-07-07 20:21:03,674 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Swms
                2016-07-07 20:21:03,721 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Jobs
                2016-07-07 20:21:03,736 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Replication
                2016-07-07 20:21:03,736 [1] INFO  Enteo.BlServer.Config - Loading additional extensions...
                2016-07-07 20:21:03,783 [1] INFO  Enteo.BlServer.Config - Loaded 12 extensions (incl. base & dependent extensions):
                  Enteo.BlServer.DataAccess, 7.3.1.3386
                  Enteo.BlServer.DataAccess.Api, 7.3.1.3386
                  Enteo.BlServer.Common, 7.3.1.3386
                  Enteo.BlServer.Base, 7.3.1.3386
                  Enteo.Mds.SchemaDefinitions, 7.3.1.3386
                  Enteo.BlServer.Core, 7.3.1.3386
                  Enteo.BlServer.Core.SchemaDefinitions, 7.3.1.3386
                  Enteo.BlServer.Swms, 7.3.1.3386
                  Enteo.BlServer.Swms.SchemaDefinitions, 7.3.1.3386
                  Enteo.BlServer.Jobs, 7.3.1.3386
                  Enteo.BlServer.Jobs.SchemaDefinitions, 7.3.1.3386
                  Enteo.BlServer.Replication, 7.3.1.3386


                gegenüber:

                2016-07-07 20:24:02,492 [1] INFO  Enteo.BlServer.Config - Loading base extensions ...
                2016-07-07 20:24:02,492 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.DataAccess
                2016-07-07 20:24:02,726 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.DataAccess.Api
                2016-07-07 20:24:02,757 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Common
                2016-07-07 20:24:02,788 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Base
                2016-07-07 20:24:02,882 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Core
                2016-07-07 20:24:02,992 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Swms
                2016-07-07 20:24:03,070 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Jobs
                2016-07-07 20:24:03,085 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Replication
                2016-07-07 20:24:03,117 [1] INFO  Enteo.BlServer.Config - Loading additional extensions...
                2016-07-07 20:24:03,117 [1] INFO  Enteo.BlServer.Config -   Enteo.EScript.Server.BusinessLogic
                2016-07-07 20:24:03,148 [1] INFO  Enteo.BlServer.Config -   Enteo.MSI.Server.BusinessLogic
                2016-07-07 20:24:03,148 [1] INFO  Enteo.BlServer.Config -   Enteo.PnP.Server.BusinessLogic
                2016-07-07 20:24:03,163 [1] INFO  Enteo.BlServer.Config -   Enteo.NetInstall.Server.BusinessLogic
                2016-07-07 20:24:03,179 [1] INFO  Enteo.BlServer.Config -   Enteo.Citrix.Server.BusinessLogic
                2016-07-07 20:24:03,210 [1] INFO  Enteo.BlServer.Config -   Enteo.FrontRangeIntegration.Server.BusinessLogic
                2016-07-07 20:24:03,273 [1] INFO  Enteo.BlServer.Config -   Enteo.SPD.Server.BusinessLogic
                2016-07-07 20:24:03,335 [1] INFO  Enteo.BlServer.Config -   Enteo.OSD.Server.BusinessLogic
                2016-07-07 20:24:03,367 [1] INFO  Enteo.BlServer.Config -   Enteo.Virtualization.Server.BusinessLogic
                2016-07-07 20:24:03,382 [1] INFO  Enteo.BlServer.Config -   Enteo.MDM.Server
                2016-07-07 20:24:03,445 [1] INFO  Enteo.BlServer.Config -   Enteo.RemoteControl.Server
                2016-07-07 20:24:03,460 [1] INFO  Enteo.BlServer.Config -   Enteo.BlServer.Web.Reporting.Server.Logic
                2016-07-07 20:24:03,523 [1] INFO  Enteo.BlServer.Config -   Enteo.Discovery.Server.BusinessLogic
                2016-07-07 20:24:03,554 [1] INFO  Enteo.BlServer.Config - Loaded 36 extensions (incl. base & dependent extensions):
                  Enteo.BlServer.DataAccess, 7.3.1.3386
                  Enteo.BlServer.DataAccess.Api, 7.3.1.3386
                  Enteo.BlServer.Common, 7.3.1.3386
                  Enteo.BlServer.Base, 7.3.1.3386
                  Enteo.Mds.SchemaDefinitions, 7.3.1.3386
                  Enteo.BlServer.Core, 7.3.1.3386
                  Enteo.BlServer.Core.SchemaDefinitions, 7.3.1.3386
                  Enteo.BlServer.Swms, 7.3.1.3386
                  Enteo.BlServer.Swms.SchemaDefinitions, 7.3.1.3386
                  Enteo.BlServer.Jobs, 7.3.1.3386
                  Enteo.BlServer.Jobs.SchemaDefinitions, 7.3.1.3386
                  Enteo.BlServer.Replication, 7.3.1.3386
                  Enteo.EScript.Server.BusinessLogic, 7.3.1.3386
                  Enteo.EScript.SchemaDefinitions, 7.3.1.3386
                  Enteo.MSI.Server.BusinessLogic, 7.3.1.3386
                  Enteo.MSI.SchemaDefinitions, 7.3.1.3386
                  Enteo.PnP.Server.BusinessLogic, 7.3.1.3386
                  Enteo.PnP.SchemaDefinitions, 7.3.1.3386
                  Enteo.NetInstall.Server.BusinessLogic, 7.3.1.3386
                  Enteo.NetInstall.SchemaDefinitions, 7.3.1.3386
                  Enteo.Citrix.Server.BusinessLogic, 7.3.1.3386
                  Enteo.Citrix.SchemaDefinitions, 7.3.1.3386
                  Enteo.FrontRangeIntegration.Server.BusinessLogic, 7.3.1.3386
                  Enteo.FrontRangeIntegration.SchemaDefinitions, 7.3.1.3386
                  Enteo.SPD.Server.BusinessLogic, 7.3.1.3386
                  Enteo.SPD.SchemaDefinitions, 7.3.1.3386
                  Enteo.OSD.Server.BusinessLogic, 7.3.1.3386
                  Enteo.OSD.SchemaDefinitions, 7.3.1.3386
                  Enteo.Virtualization.Server.BusinessLogic, 7.3.1.3386
                  Enteo.Virtualization.SchemaDefinitions, 7.3.1.3386
                  Enteo.MDM.Server, 7.3.1.3386
                  Enteo.MDM.SchemaDefinitions, 7.3.1.3386
                  Enteo.RemoteControl.Server, 7.3.1.3386
                  Enteo.RemoteControl.SchemaDefinitions, 7.3.1.3386
                  Enteo.BlServer.Web.Reporting.Server.Logic, 7.3.1.3386
                  Enteo.Discovery.Server.BusinessLogic, 7.3.1.3386


                Ich verstehe nur nicht warum das so ist.. ich werde nochmal eine Neuinstallation auf einem privaten Testserver versuchen...

                Grüße,
                René.
                • 5. Re: DSM 2016 - Fehler bei neuer Installation
                  _Mel_ Master
                  schau mal ob unter c:\windows\assembly die "enteo.escript.schemadefinitions" und "enteo.escript.server.buisinesslogic" vorhanden sind.
                  • 6. Re: DSM 2016 - Fehler bei neuer Installation
                    SitzRieSe Expert
                    Hi,

                    ich habe grade meine Demo Umgebung komplett neuinstalliert und habe genau den gleichen Fehler! Ich habe bisher mit den Testlizenzen gearbeitet. Hast du schon den Support kontaktiert?

                    Wir haben grade ein Ticket aufgemacht...
                    • 7. Re: DSM 2016 - Fehler bei neuer Installation
                      RWA Specialist
                      Hui.. da bin ich irgendwie beruhigt... ich hatte mal eine Installation von 2015.2 ausprobiert (um dann direkt auf 2016.1 zu aktualisieren) und auch da das gleiche Problem... kann ja eigentlich nicht sein, oder? Das hieße der Installer hat seit mindestens 2015.2 einen Bug der nicht bemerkt wurde?
                      • 8. Re: DSM 2016 - Fehler bei neuer Installation
                        RWA Specialist
                        Hi,

                        haben die Ursache gefunden: Distribution-User musste in die Gruppe mit Zugriff auf den Private Key... und voila.. man kann wieder Pakete erstellen. Narf. Ein Hinweis in den Installationsdialogen wäre nicht schlecht. Und die Fehlermeldung ist hier erstmal völlig irreführend..

                        Grüße,
                        René.
                        • 9. Re: DSM 2016 - Fehler bei neuer Installation
                          SitzRieSe Expert
                          Das wars auch bei uns... da hab ich wohl etwas gepennt, da das ja eigtl bekannt ist, der Fehler in dem Zusammenhang ist aber trotzdem neu