1 2 3 4 Previous Next 49 Replies Latest reply on Nov 12, 2016 1:52 AM by DSMForum Go to original post
      • 15. Re: 2016.1 Release?
        mlaercher Apprentice
        So - ohne HEAT PatchLink (Policies deaktiviert) - kommen keine Fehler und alle Pakete sind erfolgreich!!??
        Vorher hatte wir auch die Einstellung "Patches nach Application Packages installieren" aktiv - aber die funktioniert ja in der 2016.1 nicht mehr, siehe ReleaseNotes...

        Evtl. liegt es daran bzw. im Zusammenhang damit?

        Auszug:
        When the ICDB setting "Patch Management > Patch Installation Order" is set
        to the value "After packages", this setting is not correctly considered during
        the first run of the Installer after a computer has been installed via DSM OS
        Deployment.
        • 16. Re: 2016.1 Release?
          mlaercher Apprentice
          Noch einmal das HEAT PatchLink komplett neu konfiguriert und das servicepollintervall auf dem höheren Wert 90 gelassen.
          Die letzten 2 Installationen waren nun auch erfolgreich!?

          Edit: Die Patchpolicies und Pakete waren allerdings nach dem Update auch schon in der neuen Rev. vorhanden - es hat sich augenscheinlich nichts getan.

          Bin gespannt, ob den Fehler noch jemand hat bzw. hatte.

          Aber jetzt läuft alles.....

          Was mir persönlich nun noch fehlt in der 2016.1 ist, dass die Patches erst nach der OSD Phase UND den Packages installiert werden - das hat bei uns immer super geklappt und die Applikationen wurden gleich mitgepatcht.
          • 17. Re: 2016.1 Release?
            _Mel_ Master
            was funktionieren sollte ist: stell die ICDB einstellung auf "Installationsreihenfolge beibehalten" und dann setze die installation order für die policies des patch management execution packages auf einen hohen wert, damit es nach den anderen paketen ausgeführt wird..
            • 18. Re: 2016.1 Release?
              mlaercher Apprentice
              Fehler ist wieder da - kommt immer sporadisch.....

              Das mit der Installationsreihenfolge behalten teste ich gelich mal - Vielen Dank
              • 19. Re: 2016.1 Release?
                mlaercher Apprentice

                was funktionieren sollte ist: stell die ICDB einstellung auf "Installationsreihenfolge beibehalten" und dann setze die installation order für die policies des patch management execution packages auf einen hohen wert, damit es nach den anderen paketen ausgeführt wird..



                Das funktioniert auf jeden Fall perfekt.

                Der Fehler mit den Packages nach der OSD Phase tritt definitv nur auf, wenn die Patches nach OSD installiert werden.
                Werden die Patches nach den Application Packages installiert funktioniert alles reibungslos.
                ca. 10 mal Client neuinstalliert - jedes mal ohne Fehler
                • 20. Re: 2016.1 Release?
                  _Mel_ Master
                  der fehler trat ja bei der softwareinstallation nach dem reboot wegen der patch installation auf.

                  wenn die patch installation als letztes läuft, dann kommt danach keine softwareinstallation mehr und damit tritt auch der fehler nicht auf, was nicht bedeutet das alles in ordnung ist in dem sinn, daß es funktioniert, wenn man danach zusätzliche software installieren will.

                  falls das problem allerdings nur einen kurzen zeitraum nach dem reboot betrifft, kann es so in der praxis natürlich trotzdem gut funktionieren.
                  • 21. Re: 2016.1 Release?
                    mlaercher Apprentice
                    Installation nach den patches und dem reboot funktionieren ebenfalls einwandfrei - allerdings wurde die Software etwas später zugewiesen.
                    Ansonsten funktionieren Installationen nach reboots/startups auch einwandfrei (ohne vorherige Patchinstallation).
                    • 22. Re: 2016.1 Release?
                      FlorianZoller Apprentice
                      Also den Fehler

                      Error code = -2147023878 (Es wurde versucht, einen Registrierungsschlüssel einem unzulässigen Vorgang zu unterziehen, der zum Löschen markiert wurde. (0x800703fa)).

                      gab es auch schon mit 2015.2 direkt nach der OS Installation.

                      Ich hatte den in einer Umgebung auf Windows 10 Clients, das aber auch nur sporadisch und meistens im Zusammenahng mit FPS und dem laden eines XML Objekts.
                      Aber auch schon bei der Installation eines MSI Pakets und beim Zugriff auf den MSIInstaller.

                      Der Support konnte mir nicht weiterhelfen und ich bekam eigentlich auch nur nutzlose Vorschläge.

                      Bei mir läuft das ganze nun sehr stabil, wenn ich als letztes Paket in meinem OS Set einen Reboot mache.
                      D.h. nach der Installation des DSM Clients und der eigentlichen Installation des ersten Pakets habe ich noch einen Reboot.

                      Das ganze scheint ein Timing Problem zu sein, ich hab das nicht auf jeder Hardware und auch nicht mit jedem OS. Wenn ich einen Procmon-Trace Parallel laufen lasse, tritt es auch nicht auf...

                      Der Reboot ist nicht schön, aber im Moment scheint es damit besser zu laufen
                      • 23. Re: 2016.1 Release?
                        derniwi Master
                        Hallo zusammen,

                        hier hat das Update auf 2016.1 auch problemlos funktioniert.

                        Gruß
                        Nils
                        • 24. Re: 2016.1 Release?
                          SitzRieSe Expert
                          Ich habe grade meine Demo Umgebung updaten wollen. Dort ist mein BLS nach dem Update outdated obwohl der Update Manager komplett durchgelaufen ist und auch behauptet hat alles wäre super!

                          Starte ich jetzt das Update manuell über die DSMC bekomme ich die Meldung "all Management Points are up to date". Ich such mal was da los ist :P
                          • 25. Re: 2016.1 Release?
                            SitzRieSe Expert

                            Ich habe grade meine Demo Umgebung updaten wollen. Dort ist mein BLS nach dem Update outdated obwohl der Update Manager komplett durchgelaufen ist und auch behauptet hat alles wäre super!

                            Starte ich jetzt das Update manuell über die DSMC bekomme ich die Meldung "all Management Points are up to date". Ich such mal was da los ist :P



                            Also ich habe jetzt versucht den BLS neuzuinstallieren, in dem ich im RAW Mode die installedServices auf 0 gesetzt habe und anschließend den MP erneut aktualisiert habe.

                            Er installiert wieder alles und sagt, jop! alles gut, aber der BLS bleibt veraltet, alle anderen Komponenten sind Up-to-date


                            Hier mal der Installer Log:

                            http://cryptb.in/FeNB#a94f8bff2e45de7ed95eb8aa60c09b5b

                            Ich versuch jetzt nochmal alles drüber zu installieren.

                            Updateversuch war von 2015.2.4 auf 2016.1.
                            • 26. Re: 2016.1 Release?
                              SitzRieSe Expert

                              Also ich habe jetzt versucht den BLS neuzuinstallieren, in dem ich im RAW Mode die installedServices auf 0 gesetzt habe und anschließend den MP erneut aktualisiert habe.

                              Er installiert wieder alles und sagt, jop! alles gut, aber der BLS bleibt veraltet, alle anderen Komponenten sind Up-to-date


                              Hier mal der Installer Log:

                              http://cryptb.in/FeNB#a94f8bff2e45de7ed95eb8aa60c09b5b

                              Ich versuch jetzt nochmal alles drüber zu installieren.

                              Updateversuch war von 2015.2.4 auf 2016.1.



                              Hat Jemand das gleiche Problem? Also ich hab auch nach erneuter Installation eine PBLS Komponente die out-of-date ist. Der Update Manager hat keinen Fehler geworfen!

                              Ich habe bei allen Versuchen vor dem Update ein Neustart gemacht, nach der Distribution einen Neustart gemacht und vor dem Update des PBLS ein Neustart gemacht. So lief es in den letzten Versionen immer ohne Probleme... Aktuell wüsste ich grade nicht wie ich die Demo Umgebung retten kann... Ich werde mal ein Ticket aufmachen.
                              • 27. Re: 2016.1 Release?
                                _Mel_ Master
                                welche komponente soll denn out-of-date sein ? und welche version hat die ?

                                und verscuh mal den updatesources\ssi\autoimport ordner (falls er existiert) umzubenennen - und falls es das war, dann schau mal was da noch drin ist.
                                • 28. Re: 2016.1 Release?
                                  SitzRieSe Expert

                                  welche komponente soll denn out-of-date sein ? und welche version hat die ?

                                  und verscuh mal den updatesources\ssi\autoimport ordner (falls er existiert) umzubenennen - und falls es das war, dann schau mal was da noch drin ist.



                                  Hi Mel,

                                  laut dem Komponenten Reiter soll es "System Object Import" sein, aber die Version ist 7.3.1.3386:

                                  https://img4.picload.org/image/rgplclii/mp.png
                                  • 29. Re: 2016.1 Release?
                                    SitzRieSe Expert
                                    Im Log hab ich grad vermehrt sowas gefunden:

                                    13:52:03.814 2       ->  MSIInstallProduct('\\dsm-depot1.dsmdemo.intra\dsm$\SSI\{5E8A4751-2325-4189-B91E-04EB7A91EA2A}\Extern$\Msidata\SQLSysClrTypes_x64.msi','DEBUG',MsiInstMach) ... /TW
                                    13:52:03.814 E        Warning (Module:xniMSI, Severity:0x03): MSI installations are not supported in a Terminal Server session.
                                    13:52:03.814 E        Warning (Module:SWMSRT, Severity:0x03): failed to get SWMSRunTimeMgr

                                    13:52:03.814 2       ->  MSIInstallProduct('\\dsm-depot1.dsmdemo.intra\dsm$\SSI\{5E8A4751-2325-4189-B91E-04EB7A91EA2A}\Extern$\Msidata\SMO_x64.msi','DEBUG',MsiInstMach) ... /TW
                                    13:52:03.814 E        Warning (Module:xniMSI, Severity:0x03): MSI installations are not supported in a Terminal Server session.
                                    13:52:03.814 E        Warning (Module:SWMSRT, Severity:0x03): failed to get SWMSRunTimeMgr
                                    13:52:03.814 2       else - Skipping ELSE part
                                    13:52:03.814 2       Skipping command : MSIInstallProduct
                                    13:52:03.814 2       Skipping command : MSIInstallProduct
                                    13:52:03.814 2       SI: Message........: [Logging installation status ...]
                                    13:52:03.814 2       SI: Text Index: [1], Text: [Logging installation status ...]
                                    13:52:03.814 2       SI: Message........: [Logging installation status ...]
                                    13:52:03.814 2       SI: Text Index: [1], Text: [Logging installation status ...]
                                    13:52:03.814 2       SI: Text Index: [1], Text: []

                                    13:52:03.814 2       ---->Installation of SSI:Installing MS SQL Server Management Objects ... complete.