1 2 3 Previous Next 32 Replies Latest reply on Nov 19, 2013 7:35 AM by e.wolff

    Problem mit Intel I217-LM

    e.wolff Apprentice
      Hallo zusammen,

      ich habe hier ein Problem mit einem Treiber. Hier kurzt die Eckdaten:

      Hardware => Lenovo ThincCenter M83
      OS: Windows 7 x64
      WinPE im Boot Environment: WinPe 3.x

      Jetzt zu meinem Problem. Die Netzwerkkarte des M83 wurde im WinPe nicht erkannt. Soweit so gut. Vorinstallierten Rechner genommen und über die Funktion "Auswahl von Plug & Play-Geräten, die auf diesem Computer installiert sind" den Treiber abgezogen. Treiber in das Boot Environment eingebunden und siehe das Netzwerk ist da und die Intsallation beginnt. Den gleichen Treiber (wurde ja von einem M83 mit W7 x64 abgezogen) möchte ich jetzt dem Rechner zuweisen, damit die Netzwerkfunktionalität gewährleistet ist. Sobald ich jetzt die Funktion "Passt Treiber zu Computer" ausführe, kommt die Konsole zum Ergebnis, dass kein passendes Gerät am Computer gefunden wurde. Ich habe den Treiber auch schon aus den Original Sourcen von Intel abgezogen, aber das Ergebnis bleibt das Gleiche.

      Folgendes steht im Gerätemanager und in der prjconf:

      http://forum.enteo.com/attachment.php?attachmentid=789&stc=1&d=1384769177

      http://forum.enteo.com/attachment.php?attachmentid=790&stc=1&d=1384769177

      http://forum.enteo.com/attachment.php?attachmentid=791&stc=1&d=1384769177
        • 1. Re: Problem mit Intel I217-LM
          Markus.Zierer Expert
          Hallo,

          auf das Problem bin ich auch schon gestossen. Das Problem hier ist, dass die HW ID auf Subsystem Ebene unterschiedlich ist. Wenn ich mich recht erinnere, wird beim extrahieren des Treibers von der Maschine, aber nicht so tief hinunter evaluiert und deswegen führt das dann zu der Situation, dass der Treiber für WinPE funktioniert (weil das an der Stelle "toleranter" ist), für DSM dann aber nicht mehr tut, weil hier eben im Treiber kein Eintrag mit entsprechender Subsystem ID vorhanden ist.

          Wenn ich mich recht erinnere, hab ich das dadurch gelöst, dass ich den Hersteller Treiber entpackt habe, die entsprechende INF Datei gesucht und diese dann beim Treiber wizard angegeben habe.
          • 2. Re: Problem mit Intel I217-LM
            e.wolff Apprentice
            [QUOTE=Markus.Zierer;41917]Hallo,

            auf das Problem bin ich auch schon gestossen. Das Problem hier ist, dass die HW ID auf Subsystem Ebene unterschiedlich ist. Wenn ich mich recht erinnere, wird beim extrahieren des Treibers von der Maschine, aber nicht so tief hinunter evaluiert und deswegen führt das dann zu der Situation, dass der Treiber für WinPE funktioniert (weil das an der Stelle "toleranter" ist), für DSM dann aber nicht mehr tut, weil hier eben im Treiber kein Eintrag mit entsprechender Subsystem ID vorhanden ist.

            Wenn ich mich recht erinnere, hab ich das dadurch gelöst, dass ich den Hersteller Treiber entpackt habe, die entsprechende INF Datei gesucht und diese dann beim Treiber wizard angegeben habe.

            Hallo,

            vielen Dank für die Antwort.

            Ich habe die Vorgehensweise getestet. Leider ohne Erfolg. Gibtr es vielleicht noch eine andere Vorgehensweise?
            • 3. Re: Problem mit Intel I217-LM
              Markus.Zierer Expert
              Ich fürchte leider Nein. Ich hab grade nochmal nachgesehen. Ich habe die Netzwerktreiber vom Hersteller (in meinem Fall Dell) runter geladen und entpackt, dann hab ich die INF Dateien nach der passenende HW ID durchsucht. Bei mir war es die e1d62x64.inf. Beim Treiber Wizard dann explizit diese Datei angeben, nicht das ganze Verzeichnis !!! Und schon sollten die entsprechenden Treiber importiert werden. Damit sollte auch Sichergestellt sein, dass die Treiber für die HW ID passen.
              • 4. Re: Problem mit Intel I217-LM
                e.wolff Apprentice
                Hallo zusammen,

                ich habe das Problem gelöst. Habe ein weiteres Gerät angeschlossen und habe es installieren lassen. Plug & Play Treiber passt hier und der Rechner installiert sich wie er soll. Ich habe dann den ersten PC komplett aus dem DSM entfernt und habe ihn nochmals komplett aufgenommen (PXE Boot, Name vergeben und Betankung angestossen). Jetzt passt auch hier der Treiber und der Rechner installiert sich wie er soll. Ich gehe davon aus, dass es bei der ersten Inventarisierung ein Problem gab.

                Grüße
                • 5. Re: Problem mit Intel I217-LM
                  Polymer Apprentice
                  Na toll, bin jetzt an der gleichen Stelle. Laut ID müsste es der Windows Server 2008 R2 Treiber sein. Den habe ich nun auch in den Netzwerkkartentreibern hinzugefügt. Wenn ich dann das Boot Environment mit dem Treiber aktualisiere, dann schließt der Wizzard mit einem Fehler ab (siehe Screenshot).

                  An der Stelle hilft dann auch nicht das rauslöschen des PC´s.


                  Schönen Gruß
                  Matthias
                  • 6. Re: Problem mit Intel I217-LM
                    e.wolff Apprentice

                    Na toll, bin jetzt an der gleichen Stelle. Laut ID müsste es der Windows Server 2008 R2 Treiber sein. Den habe ich nun auch in den Netzwerkkartentreibern hinzugefügt. Wenn ich dann das Boot Environment mit dem Treiber aktualisiere, dann schließt der Wizzard mit einem Fehler ab (siehe Screenshot).

                    An der Stelle hilft dann auch nicht das rauslöschen des PC´s.


                    Schönen Gruß
                    Matthias



                    Hallo Matthias,

                    ich hatte einen anderen Fehler. Bei mir war im WinPe Umfeld alles in Ordnung. Ich hatte Probleme während der Windows 7 Installation.

                    Was möchstest du den aufsetzen? Windows Server 2008? und was für eine WinPE Version verwendest du?

                    Gruß
                    • 7. Re: Problem mit Intel I217-LM
                      _Mel_ Master
                      schau mal ins log dsmc logfile was genau beim treiber integrieren schief geht.
                      • 8. Re: Problem mit Intel I217-LM
                        Markus.Zierer Expert
                        Also wenn der Client irgendwie einen PXE Boot hinbekommt, werden die MAC und die PCI ID der NIC ins Basic Inventory geschrieben. Ab diesen Zeitpunkt kann man mit der Funktion "Passt Treiber zu Computer" prüfen, ob das gewählte Treiberpaket die entsprechenden HW IDs als Referenzen hat. Ist das nicht der Fall, dann unterscheidet sich die HW und man sollte anschliessend den Treiber über den Wizard importieren.

                        @Polymer
                        Hm, welche ID meinst Du jetzt genau? Die PCIID sagt dir nämlich nur welche HW genau verbaut ist, aber nicht für welches OS der Treiber ist.

                        Ach ja, die Paketierung des Treibers MUSS immer unter dem OS erfolgen, unter dem der Treiber später auch genutzt werden soll. Wenn Du also einen Windows 7 Treiber unter Windows 8.1 Paketieren würdest, würde der Assistent zwar vermutlich durchlaufen, aber der Treiber anschliessend nicht funktionieren.
                        • 9. Re: Problem mit Intel I217-LM
                          Polymer Apprentice
                          Moin zusammen,

                          wenn ich ehrlich bin, dann kann ich in dem DSMC Logfile nichts erkennen

                          Ich möchte ein Win8.1 installieren (was auch mit einem anderen PC klappt) und habe einen neuen PC mit der Intel I217. Nun hbae ich den PC mit einer Win8.1 CD aufgesetzt und die Treiber nachinstalliert. Dann starte ich die DSMC Konsole und habe (wie immer) den Treiber (per Plug&Play Wizzard) hinzugefügt. Als Plattform wird dann Win8(x64) erkannt. Nun möchte ich das WinPe x64 aktualisieren und wähle den Treiber aus. Dabei bekomme ich die Meldung, dass die Plattformvoraussetzungen nicht passen. Also setze ich als Plattform noch Win8 x86 und dann läuft die Aktualisierung des Boot Envrionments durch.....aber am Ende kommt wieder die Meldung, dass der Netzwerkkartentreiber nicht initialisiert werden konnte.


                          In den eigenschaften des Treibers passt die PNP-ID zu der Hardware ID des Treibers.
                          Ich habe mittlerweile 5 verschiedene Versionen des Treibers für die I217 Karte...

                          Schönen Gruß
                          Matthias
                          • 10. Re: Problem mit Intel I217-LM
                            Markus.Zierer Expert
                            Aha, da haben wir den Fehler ja...

                            Das Problem hierbei ist, dass Du mit ziemlicher Sicherheit das ADK 8 installiert hast. Das ADK 8.1 für Windows 8.1 wird von der DSM 7 derzeit noch nicht erkannt, daher kannst Du damit kein WinPE erstellen. Das Problem ist jetzt aber, dass das WinPE 4.0 ja auf Windows 8 basiert, also intern die Kernel Version 6.2 ist. Windows 8.1 ist jedoch Kernel Version 6.3. Das hat bei der normalen SW Installation praktisch keine Auswirkungen, ist bei Treibern aber enorm wichtig.

                            Wenn Du dir die INF Datei deines Treibers genauer ansiehst, wird es höchstwahrscheinlich so sein, dass dort nur die Sections für Windows 8.1 (Kernel 6.3) mit werten Gefüllt sind und sonst nichts. Da das WinPE 4.0 aber Werte in der Section 6.2 sucht, dort aber keine Einträge vorhanden sind, ist es logisch, dass der Treiber dann nicht funktionieren kann.

                            Dieses Problem kannst Du nur dadurch umgehen, dass Du die Treiber eben NICHT  per PnP Wizard von einem laufenden System abziehst, sondern direkt über die INF Datei importierst. Im Gegensatz zur PnP Methode, sollten hier tatsächlich alle Decorated Sections der INF Datei mit eingelesen werden und nicht nur die für das Aktuelle OS. Aber meine Hand würde ich dafür jetzt trotzdem nicht ins Feuer legen. Von FrontRange wirst Du hier auch keinen Support kriegen, da Windows 8.1 noch gar nicht offiziell unterstützt wird.
                            • 11. Re: Problem mit Intel I217-LM
                              Polymer Apprentice
                              Guten Morgen,

                              danke Markus für die ausführliche Antwort!

                              Ich installiere diesen Rechner gerade per CD mit Win8, werde dann das Waik für Win8 installieren und die Treiber so einbinden. Mal schauen ob das so klappt.

                              Ich werde berichten!

                              Schönen Gruß
                              Matthias
                              • 12. Re: Problem mit Intel I217-LM
                                JSHAY Apprentice
                                Hallo Matthias,

                                wir hatten (haben) auch immer wieder Probleme mit der Paketierung von Intel Treibern, eben wegen der schier unendlichen Kombination aus den Treiber Dateien und den dazu passenden PNP Infs. Nach meiner Erfahrung sollte man Intel Treiber nicht über die "installierten hochladen"  paketieren sondern immer vom Hersteller Download. Hast du schon das PE 4.0 Treiberpack vom Hersteller (z.B: HP) probiert?

                                Beispiel HP 8300 usdt:

                                http://ftp.hp.com/pub/softpaq/sp60501-61000/sp60861.exe

                                viele Grüße

                                Jochen  (um die Ecke ;-)
                                • 13. Re: Problem mit Intel I217-LM
                                  Polymer Apprentice
                                  Hallo,

                                  also es hat jetzt geklappt.
                                  Welcher Treiber am Ende gepasst hat (HP, Intel, WinPE), das weiß ich gar nicht mehr...aber ich habe alles inkl. der Aktualisierung des Bootinvrironments auf dem Win8 Rechner gemacht und dann war´s ok.


                                  Schönen Gruß
                                  Matthias

                                  PS: Danke Jochen, Gruß zurück!
                                  • 14. Re: Problem mit Intel I217-LM
                                    JSHAY Apprentice
                                    Hallo Matthias,

                                    ich hab das gleiche Spiel geade mit Windows 7 durchgespielt (HP z230). Die einzig funktionierende Variante zur Treiber Paketierung für PE war den Treiber von HP ausgepackt (der enthält praktische alle Intel Pro Treiber) und einzeln aus den Source Verzeichnissen paketiert :

                                    C:\swsetup\SP63503\PRO1000\Winx64\E1D\WIN7-x64 (das ist deine NIC)
                                    C:\swsetup\SP63503\PRO1000\Winx64\E1C\WIN7-x64
                                    usw... 

                                    Die Treiber habe ich exakt auf der Zielplattform paketiert.

                                    Dann auf einem PC mit gleicher Plattform ein neues WINPE erstellt (damit da keine alten Treiber mit gleichen Namen drin sind) und die Treiber eingebunden.

                                    Wichtig ist seit DSM 7.2 noch das setzen der Variable für das Standard Boot Environment in der DSM Gruppe die dein OS-Installation Set enthält, da damit der Link Eintrag im OS Configuration Package überschrieben wird.

                                    Da WIN 8.1 von DSM noch nicht unterstützt wird würde ich das aktuell noch auf einem Windows 8 PC mit gleicher Architektur und dem genau richtigen installierten ADK f. WIN 8 (nicht das ADK für 8.1) machen.

                                    Gruss

                                    Jochen
                                    1 2 3 Previous Next