1 2 3 4 Previous Next 52 Replies Latest reply on Jun 18, 2010 6:12 AM by jelmerj

    Adobe CS3 & 4

    Apprentice

      Hi all,

       

      im in surch of the best way to deploy Adobe CS3 & CS4 on mac? I dont find anything about it here.

       

      Can somebody help me please? How can i insert the serial in the dmg?

        • 1. Re: Adobe CS3 & 4
          SupportEmployee

          It sounds like what you are looking for is the Adobe® Creative Suite® Enterprise Manual Deployment.

           

          The Adobe® Creative Suite® 4 enterprise manual deployment options let you configure and silently install or uninstall

          Creative Suite 4 editions and point products at an enterprise level. Only volume licenses are accepted to configure

          and silently install Creative Suite 4.

           

          Here is a link to CS4 version:

           

          http://www.adobe.com/aboutadobe/openoptions/pdfs/manualenterprisedeployment_cs4_help.pdf

           

           

          And here is CS3:

           

          http://www.adobe.com/support/deployment/cs3_deployment.pdf

           

           

           

          Once you have taken the steps and created a silent unattended installation you can push it out with Management Suite.

          • 2. Re: Adobe CS3 & 4
            Apprentice

            Adobe also offers the "Creative Suite 4 Deployment Toolkit" free of charge for members of the CLP licensing program.

             

            http://www.adobe.com/aboutadobe/openoptions/cs/deployment_toolkit.html

            • 3. Re: Adobe CS3 & 4
              Apprentice

              Thanks for your posts.

               

              now i create a pckage, which is allready runnig local on mac. I open the terminal execute this: sudo ./Setup --mode=silent --deploymentFile=install.xml

               

              all works fine.

               

              Only the deployment with LDMS isn't working.

               

              After i created the the silent folder i created the dmg file and copy this to the ldms share.

               

              Created the deploy packet in ldms with this options:

              File: http://landeskserver/ldmssoftware/Mac/CS3/CS3Silent.dmg

              and on the tab "install/unstall" i type in the follow: sudo ./Setup --mode=silent --deploymentFile="\\landeskserver\Software\Mac\CS3\CS3Silent\Setup.app\Contents\MacOS\install.xml

               

              The client LANDesk.log recieve my the follow massage: sdclient : EC: execute: 'sudo ./Setup --mode=silent --deploymentFile=' rval=1

               

              Any idea what im making wrong?

              • 4. Re: Adobe CS3 & 4
                Apprentice

                You are not going to be able to do it like that. I guessing that if you push out the DMG LANDesk is simply going to copy the Setup.app to the /Applications directory.

                 

                Everything needs to be local paths on the machine including the deployment file.

                • 5. Re: Adobe CS3 & 4
                  Apprentice

                  I tried to deploy CS3 in the past, but the version of the agent at the time was choking on the size. They have since fixed that apparently, but I haven't not revisited CS3 deployment in a while (or CS4 for that matter). But here's some details I remember:

                   

                  When landesk mounts a disk image (or unzips a .zip), it looks at the files in that volume or folder. If it finds a .app, it copies it to Applications, if it finds a .sh, .pkg, etc, it will execute it from the command line.

                   

                  So the CS3 installer dmg has a Setup.app on the disc image, and as Gil mentioned, we don't want that copied to Applications.

                   

                  What I did was move the contents of the dmg into a hidden folder ".Adobe Creative Suite 3 Web Premium" (or whatever edition) and created a shell script on the root of the disk image so that will get executed.

                   

                  The script contained:

                   

                  #!/bin/sh
                  
                  # Adobe Web Premium CS3 installer script
                  #
                  
                  cs3="Adobe CS3 Web Premium"
                  cs3Setup="/Volumes/$cs3/.Adobe Creative Suite 3 Web Premium/Setup.app/Contents/MacOS/Setup"
                  deployFile="/Volumes/$cs3/.Adobe Creative Suite 3 Web Premium/install.xml"
                  
                  
                  
                  
                  # Install command
                  "$cs3Setup" --mode=silent --deploymentFile="$deployFile" --skipProcessCheck=1
                  
                  
                  exit 0
                  

                   

                  If I get time this week, I'll try to revisit this and document what works. I also need CS4 deployment working.

                  • 6. Re: Adobe CS3 & 4
                    SupportEmployee

                    You need you use the -exec switch to have LANDesk run the .app file rather then just copy it out of the .dmg to the Applications folder. You also don't need to use the sudo command as LANDesk will elevate privileges. If you use sudo I think the deployment will fail because it will be waiting for someone to type in the password but because the UI for the task is being hidden the user won't see anything to type a password into and it will just sit until a timeout occurs.

                    • 7. Re: Adobe CS3 & 4
                      Apprentice

                      That exactly my prblem at the time.

                       

                      without a sudo this script dont want to run and with sudo it want the password. :-(

                       

                      What do you mean with -exec switch? Do i have to insert it in to the script or do i have to use it in LDMS, in the properties of the package?

                       

                      Can you give me an example please?

                      • 8. Re: Adobe CS3 & 4
                        Apprentice

                        homermg wrote:

                         

                        That exactly my prblem at the time.

                         

                        without a sudo this script dont want to run and with sudo it want the password. :-(

                         

                        What do you mean with -exec switch? Do i have to insert it in to the script or do i have to use it in LDMS, in the properties of the package?

                         

                        Can you give me an example please?

                         

                        When you push a task from LANDesk, it is already running as root (or local system in Windows). It's only when you run it yourself locally that it needs sudo.

                         

                        I assume he means put -exec in the install options within the distribution package. This should be documented somewhere as I think this was only recently added to the Mac agents if I'm not mistaken. I reported the "setup.app gets copied to applications" bug a few months ago and this is probably what fixes.

                         

                        Snowman, if this is the case, can you post a doc describing this?

                        • 9. Re: Adobe CS3 & 4
                          Apprentice

                          Snowman wrote:

                           

                           

                          You need you use the -exec switch to have LANDesk run the .app file rather then just copy it out of the .dmg to the Applications folder. You also don't need to use the sudo command as LANDesk will elevate privileges. If you use sudo I think the deployment will fail because it will be waiting for someone to type in the password but because the UI for the task is being hidden the user won't see anything to type a password into and it will just sit until a timeout occurs.

                           

                          Yes, documentation is certainly one area that I see as a failing of LANDesk. Where is this -exec documented? There needs to be a white paper on all the command line options for the rest of the Mac LANDesk tools as well.

                          • 10. Re: Adobe CS3 & 4
                            Apprentice

                            unfortunatly it isn't runs with this script

                             

                            "/Volumes/CS3Silent/cs3/Setup.app/Contents/MacOS/Setup" --mode=silent --deploymentFile="/Volumes/CS3Silent/cs3/Setup.app/Contents/MacOS/install.xml" --skipProcessCheck=1

                             

                            exit 0

                             

                            i saved this script as install.sh

                             

                            copy all stuff in cs3 folder and the install.sh parallel to cs3 folder in CS3Silent and made a dmg which called CS3.dmg:

                             

                            CS3.dmg

                                  cs3

                                  install.sh

                             

                             

                            That is what i have (Whta im doing wrong?)

                            on local mashine with: sudo "/Volumes/CS3Silent/cs3/Setup.app/Contents/MacOS/Setup" --mode=silent --deploymentFile="/Volumes/CS3Silent/cs3/Setup.app/Contents/MacOS/install.xml" --skipProcessCheck=1


                            it runs but only with password (so i think the sysntax is ok) but you said without sudo it should runs too, over ldsm push.

                             

                             

                            -----------------------------------------------------

                             

                            -exec

                             

                            with: -exec "/Volumes/CS3Silent/cs3/Setup.app/Contents/MacOS/Setup" --mode=silent --deploymentFile="/Volumes/CS3Silent/cs3/Setup.app/Contents/MacOS/install.xml" on local mishine via terminal it dont runnig

                            I mounted the CSSilent.dmg before and i typed the line in terminal.


                            Any idea why?

                             

                             

                            ____________________________________

                             

                            what is the meaning of the following line in the logfile:

                            sdclient : EC: execute: 'exec ' rval=0 (i recive this one it deploying without a script only with this in package properties:exec "/Volumes/SC3/Setup.app/Contents/MacOS/Setup" --mode=silent --deploymentFile="/Volumes/SC3/Setup.app/Contents/MacOS/install.xml")

                            and

                            sdclient : EC: execute: '<null> ' rval=1 (i recieve this one if i deploying with the script in the dmg file)

                            • 11. Re: Adobe CS3 & 4
                              SupportEmployee

                              homermg wrote:

                               

                               

                              with: -exec "/Volumes/CS3Silent/cs3/Setup.app/Contents/MacOS/Setup" --mode=silent --deploymentFile="/Volumes/CS3Silent/cs3/Setup.app/Contents/MacOS/install.xml" on local mishine via terminal it dont runnig

                              I mounted the CSSilent.dmg before and i typed the line in terminal.


                              Any idea why?

                               

                               

                               

                               

                              -exec is a LANDesk switch not a native Mac OS so if you just run it in terminal you will get an error. The -exec switch causes LANDesk to go down a different code path after mounting the .dmg.  So instead of copying the .app file out it will run the command listed after the -exec switch. The switch was added in the January rollup and should have been in the patch notes. I'm OOO this week but when I get back I can put in a post about the -exec switch.

                              • 12. Re: Adobe CS3 & 4
                                Apprentice

                                but unfortunately it doesnt works :-(

                                 

                                This is what i type in the "Install/Deinstall Options" -exec "/Volumes/SC3/Setup.app/Contents/MacOS/Setup" --mode=silent --deploymentFile="/Volumes/SC3/Setup.app/Contents/MacOS/install.xml"

                                 

                                can somebody help me?

                                • 13. Re: Adobe CS3 & 4
                                  Apprentice

                                  homermg wrote:

                                   

                                  but unfortunately it doesnt works :-(

                                   

                                  This is what i type in the "Install/Deinstall Options" -exec "/Volumes/SC3/Setup.app/Contents/MacOS/Setup" --mode=silent --deploymentFile="/Volumes/SC3/Setup.app/Contents/MacOS/install.xml"

                                   

                                  can somebody help me?

                                  Is the volume name really SC3 or is that a typo?

                                  • 14. Re: Adobe CS3 & 4
                                    Apprentice

                                    its really CS3

                                    1 2 3 4 Previous Next