7 Replies Latest reply on May 7, 2009 3:08 AM by jan.buelens

    WinPE SATA Driver for Dell OptiPlex 760

    Rookie

      Has anyone attempted to capture/deploy a Dell OptiPlex 760 workstation? I cannot get WinPE to recognize the disk. I used the SATA driver from Dell's website.

       

      Thanks.

        • 1. Re: WinPE SATA Driver for Dell OptiPlex 760
          Employee

          The reason why it didn't work for you is probably this: Added storage drivers are not working in WinPE. As the document explains, if you just click the buttons in the console and go through the motions, chances are it's not going to work. You need to customise the driver's txtsetup.oem file.

           

          Or do you? See Lenovo S10 / M58 and WINPE. I attached a document to that thread that walks you through the process. It also suggests an alternative approach that gives you a generic WinPE image that probably works on any intel-SATA based machines. No need to mess about with any files.

          • 2. Re: WinPE SATA Driver for Dell OptiPlex 760
            Rookie

            The "Generic" SATA option worked great. Thanks.

             

            Mike

            • 3. Re: WinPE SATA Driver for Dell OptiPlex 760
              Rookie

              I had the Same Problem,  But now i can't Deploy any Image with the OptiPlex 760, It Fails during the injection of the sysprep file. Any Ideas?

              • 4. Re: WinPE SATA Driver for Dell OptiPlex 760
                Apprentice

                You may need to go into the bios and set the sata mode to legacy (or something like that, maybe compatability, it really depends on the PC)

                • 5. Re: WinPE SATA Driver for Dell OptiPlex 760
                  Employee

                  If you get as far as injecting sysprep.inf, that presumably means you've successfully restored an image. If so, whatever is causing the problem, it won't be anything to do with the SATA driver.

                   

                  Can you clarify how things fail? We're in the OSD section of the forum here, but something tells me you might be using provisioning. If you are using OSD, which command fails? Does the same OSD script / provisioning template / sysprep.inf work for other machine types?

                  • 6. Re: WinPE SATA Driver for Dell OptiPlex 760
                    Rookie

                    Yes I am using WinPe provisioning. Now i Use the same steps with other models as i use with this one and dont get this error.  The error Occurs during the post-os install with the injection of the sysprep file, which i use the same one across the board, and fails with an error of  " 80001501H".  The only thing that is different is that these PCs are not in the database because they are new PC's from Dell.  Attached is a txt version of the  sysprep.inf file

                     

                    *PRE OS

                    template process:

                    remove all partition

                    creat

                    mount

                    make bootable

                    format

                     

                    *OS

                    map image file

                    map image engine

                    deploy image

                    mount c:

                     

                    * POST OS

                    INJECT SYSPREP  - FAIL

                     

                    *SYSTEM CONFIG

                    install agent

                    • 7. Re: WinPE SATA Driver for Dell OptiPlex 760
                      Employee

                      For the benefit of anybody browsing this forum in search of SATA or Optiplex 760 related topics, stop reading here. I don't know what is causing this problem but I think we can say it's nothing to do with SATA or with Optiplex 760.

                       

                      I tried the sysprep.inf attached to the previous posting. I can't get it to go wrong on me, no matter whether the target machine exists in the database or not. One difference might be that I'm using 8.8 SP2 and you might be using an older version. What version are you using?

                       

                      Here's one suggestion: I notice "ComputerName = *" in your sysprep.inf (which tells mini-setup to generate a random name). I don't dispute your right to use this setting but I wonder if that's what causing trouble here. When I enabled parameter substitution (remember, when you import a sysprep.inf in the database, there is a checkbox labeled "insert variables into script" to enable or disable parameter substitution), the inject action deleted the asterisk - not sure why. This may be a long shot but try ComputerName = %macAddress% (caution - case sensitive!) and see if that makes a difference. Or disable parameter substitution.