7 Replies Latest reply on Jun 17, 2007 5:24 PM by jparekh

    OSD v6

    jparekh Apprentice
      After the drive is formatted, the system reboots and then a error in German appears:

      “Ungueltiges System” line 2 “Dataentraeger wechseln und Taste druecken

      enteo OSDeployment Menu
      Booting from local disk

      xiting Broadcom PXE Rom

      Ungueltiges System
      Dataentraeger wechseln und Taste druecken

      I have noticed this in the osdtftpmxSvc_0000000005.log file.

      13:36.49.660  E Warning (Module:mgmtagnt.exe, Severity:0x03): osdTftpMx.dll  NWCM login failed.
      The parameter is incorrect.
      13:36.49.660  1 osdTftpMx.dll  Last data block received.
        • 1. Re: OSD v6
          jparekh Apprentice
          I had to create a new dos environment, the one it creates during OSD install didn't work.

          With OSD 6, if you are using an unattended mode, how do you get the drivers in there to where "%OSD.OEMDriversPath%" is point to?
          • 2. Re: OSD v6
            Apprentice
            hi,
            create your drivers... go through your lifecycle then assign them to your objects. a policy with instances will then be created. there is no need to copy drivers anywhere...

            cheers

            oBi
            • 3. Re: OSD v6
              jparekh Apprentice
              Thanks.  That is true for the DOS unattend as well?  I will try that.

              Also, I am getting now getting this message again after formatting is done and reboots -> “Ungueltiges System” line 2 “Dataentraeger wechseln und Taste druecken.

              Any ideas?
              • 4. Re: OSD v6
                jparekh Apprentice
                This is what I get in the log file when I get the error.  The two pre DOS Enviornments do kick in and do their work but on the reboot after formatting it fails with the error in german (above).  I did notice a log file at the same time on the server with this error:

                15:11.32.401  : --------------------------------------------------------------------------------
                15:11.32.401  : --------------------------------------------------------------------------------
                15:11.32.401  : --------------------------------------------------------------------------------
                15:11.32.401  : LogFile C:\Program Files\NetInst\NiLogs\osdpxemxPool_0000000002.log, started 14.06.2007 15:11.32
                15:11.32.401  : Application : C:\Program Files\NetInst\mgmtagnt.exe(PID: 2628 [1432])
                15:11.32.401  : Version : 6.0.0.1867
                15:11.32.401  :
                15:11.32.401  : Params: "C:\Program Files\NetInst\mgmtagnt.exe" /run=osdPxeMx.dll/osdTftpMx.dll
                15:11.32.401  :

                15:11.32.401  : Windows NT 5.2 (Build 3790) Service Pack 2

                15:11.32.401  : Product Type: ServerNT, Terminal Server

                15:11.32.401  : Registered for Horwood Marcus Berk

                15:11.32.401  : User lang: English, System lang: English
                15:11.32.401  :
                15:11.32.401  : Reportlevel: 0
                15:11.32.401  : Username: NETWORK SERVICE (is local admin), Workstation: HMBCOMM
                15:11.32.401  :
                15:11.32.401  : --------------------------------------------------------------------------------
                15:11.32.401  :

                15:11.32.401  :
                15:11.32.401  :

                15:11.32.401  0 osdPxeMx.dll  CPxeService::GetBootFileNameByLayer entered
                15:11.32.401  0 osdPxeMx.dll  CPxeService::GetBootFileNameByLayer leave (true); boot file name: osddelayload.0.
                15:11.32.401  0 osdPxeMx.dll  Sending reply to 10.0.15.249:4011
                15:11.32.401  E Warning (Module:mgmtagnt.exe, Severity:0x03): osdPxeMx.dll  Failed to report DHCP client info.
                Element not found.
                15:11.32.401  : End Of Logfile
                • 5. Re: OSD v6
                  jparekh Apprentice
                  Seems to work sometimes and sometimes I get this error (above).  Can't figure out why it's on consistently working even on the same machines. The first two pre phases work 100% but then the next reboot it errors out.  Using DOS Boot Environment and unattend XP install.

                  Also, when it works the unattend doesn't put the NIC drivers which I packaged and assigned to the computer as well.  So when devices are detected during the unattend, no NIC is installed therefore it fails to join the domain.

                  Should I just stop using DOS and go try WinPE?  We are a enteo partner in the US and this is the first v6 install.  Hoping someone in US or Germany can help me resolve this.
                  • 6. Re: OSD v6
                    FrankScholer Master
                    Hi,

                    the dynamic driver injection into the unattend setup only works with WinPE as your Boot-Environment. Using DOS you are out of luck... not driver injection at all with the one exception if you are using old-school $OEM$ directory-structure on your source-share (though it should be possible to adopt the mechanism used in OSD 3.x into v6, but you'll have to do that manually).

                    Fortunately you can use WinPE 2005 (aka v1.6) if you have Windows XP SA agreement or WinPE 2.0 from Vista (or the Windows AIK). I read through the WAIK EULA and to my understanding (though I'm not a lawyer and cannot guarantee) you are entitled to use WinPE 2.0 from WAIK to install a Windows operating system without the appropriate Vista licenses...

                    So download WAIK ([URL="http://www.microsoft.com/downloads/details.aspx?familyid=C7D4BC6D-15F3-4284-9123-679830D629F2&displaylang=en"]http://www.microsoft.com/downloads/details.aspx?familyid=C7D4BC6D-15F3-4284-9123-679830D629F2&displaylang=en), install it and then follow the instructions from "Readme.txt" in \OSD\Bootenvironment\Tools\WinPE20.

                    That'll create you a WinPE 2.0 WIM-file with the necessary enteo-binaries included, which you can then import as a new Boot-Environment package into v6.

                    I did that during a v6 workshop at a customer two days ago and it worked flawlessly (including the dynamic injection of third party driver PnP-Packages).

                    Don't forget, that you can partition, format and install under PE without any reboots between those actions. To achive this, you'll have to create copies of the respective PreOS-Actions and link the copies to your new WinPE Boot-Enivronment...

                    HTH,
                    Frank
                    • 7. Re: OSD v6
                      jparekh Apprentice
                      Thanks Frank!  This does help a lot.  One problem I am having is regardless of if I use DOS or WinPE, after phase 3 or 4 it fails.  In DOS enviornment, it always partitions and format and then the next reboot it downloads the DOS boot image with NDIS drivers, gets IP address and then there is a error and reboots.  After the reboot, it comes to a msg "“Ungueltiges System”  “Dataentraeger wechseln und Taste druecken.".  In PE, after format, it reboots and NTLDR not found message.  There were couple of times the DOS boot worked but most of the time it doesn't.  Right after it failed in DOS, I do see a P: drive mapped properly but quickley reboots and can't see the error.  I have did create a OS Source package for XP.