6 Replies Latest reply on Nov 5, 2007 7:05 AM by SBRUTSCH

    WINPEOEM.SIF nich gefunden bei erstellen von PE ISO

    Andreas1983 Apprentice
      Hallo,

      ich versuche gerade eine PE ISO mit SATA Treibern fuer einen Lenovo T60 zu erstellen aber bekomme immer folgenden Fehler:


      10:49:07.480 1      OSDAdminLib: C:\WINDOWS\TEMP\__WinPeBootTemplate\i386\System32\WINPEOEM.SIF does not exist. Creating link to the new Mass storage driver not possible
      10:49:07.480 1      OSDAdminLib: > Action 'Add Mass storage Driver' failed
      10:49:07.480 E     Warning (Module:OSDAdminLib, Severity:0x03): Creating WinPe Iso Image failed. Inserting Mass storage drivers into WinPe boot environment shell failed for package 'WinPE32 based on WS03 R2 SP2 (1)'
      10:49:07.480 1     OSDAdminLib: Inserting Mass storage drivers into WinPe boot environment shell failed for package 'WinPE32 based on WS03 R2 SP2 (1)'
      10:49:07.480 1     OSDAdminLib: Delete: No Files matching C:\WINDOWS\TEMP\__WinPeBootTemplate\I386\System32\wbem\Autorecover\*.*
      10:49:07.480 1     OSDAdminLib: Delete: No Files matching C:\WINDOWS\TEMP\__WinPeBootTemplate\I386\System32\wbem\Logs\*.*
      10:49:07.496 1     OSDAdminLib: Delete: No Files matching C:\WINDOWS\TEMP\__WinPeBootTemplate\I386\System32\wbem\Mof\*.*
      10:49:07.496 1     OSDAdminLib: Delete: No Files matching C:\WINDOWS\TEMP\__WinPeBootTemplate\I386\System32\wbem\*.*
      10:49:07.496 1     OSDAdminLib: Delete: No Files matching C:\WINDOWS\TEMP\__WinPeBootTemplate\I386\*.*
      10:49:07.496 1     OSDAdminLib: Delete: No Files matching C:\WINDOWS\TEMP\__WinPeBootTemplate\*.*
      10:49:07.496 1     OSDAdminLib: > Action 'Create Iso Image task' failed
      10:49:07.496 2    OsdConsoleExt: Creating Iso Image task FAILED for 'WinPE32 based on WS03 R2 SP2 (1)'
      10:49:07.496 2    OsdConsoleExt: WinPe Template is ready but creating Iso Image failed. Template will be deleted.
      10:49:07.496 1    esiConsoleExt: > Action 'ActionPerform' failed


      hat jemand eine Idee wonach ich da suchen muss?

      THX
      Andreas
        • 1. Re: WINPEOEM.SIF nich gefunden bei erstellen von PE ISO
          hermixx Apprentice
          Hast Du in der eMMC das SATA Treiber Paket mittels einer CD erstellt ?
          Bei Mass Storage Treibern wird immer ein TXTSETUP.OEM fiel benötigt. ISt dies in Dem Treiberverzeichnis vorhanden ?
          • 2. Re: WINPEOEM.SIF nich gefunden bei erstellen von PE ISO
            Andreas1983 Apprentice
            Ja ich habe es von CD bzw. aus einem Ordner erstallt.
            Ja die Datei txtsetup.oem ist im Treiberverzeichnis.

            Die Datei WINPEOEM.SIF existiert auch auf dem Server unter ...\enteo$\OSD\Bootenvironment\BootTemplate\WinPESource\.
            • 3. Re: WINPEOEM.SIF nich gefunden bei erstellen von PE ISO
              Andreas1983 Apprentice
              Habe das Problehm gefunden!!

              Die Windows Server 2003 R2 SP2 funktioniert nicht ich verwende jetzt Windows Server 2003 SP1 und damit kommt der Fehler nicht.

              THX
              Andreas
              • 4. Re: WINPEOEM.SIF nich gefunden bei erstellen von PE ISO
                Frank.Scholer Master
                Hallo Andreas,

                das ist ein bekanntes Problem, für das ich leider auch noch keine Lösung gefunden habe: die WinPE 2005 Build-Tools funzen nicht, wenn Sourcen mit geslipstreamten SP2 (egal ob x86 oder x64 und egal welche Version, also Standard, Enterprise oder was auch immer).

                Dasselbe Verhalten kriegst du auch, wenn du versuchst auf dieser Basis anhand des Whitepapers ein PE-Image für OSD 3.2 zu machen, nur dass da das Script MKIMG.CMD schon meckert, dass es keine gültigen Sourcen findet...

                Daher das machen, was du auch rausgefunden hast: W2K3 mit geslipstreamtem SP1 nehmen und alles ist gut

                HTH, Gruß Frank

                P.S.: wenn jemand weiß, ob (und wenn ja: wo) es aktualisierte PE 2005 Build-Tools gibt, die mit geslipstreamtem SP2 klarkommen, wäre ich für ne kurze Info sehr dankbar.
                • 5. Re: WINPEOEM.SIF nich gefunden bei erstellen von PE ISO
                  Micha1 Apprentice
                  Gibt es für dieses Problem mitlerweile eine Lösung? Weil so allmählich sterben bei uns die Versionen von 2k3 vor R2 aus, und wenn sie wirklich versehntlich alle entfernt wurden, hätte ich ein ernsthaftes Problem.

                  mfg Micha
                  • 6. Re: WINPEOEM.SIF nich gefunden bei erstellen von PE ISO
                    SBRUTSCH Expert

                    Gibt es für dieses Problem mitlerweile eine Lösung? Weil so allmählich sterben bei uns die Versionen von 2k3 vor R2 aus, und wenn sie wirklich versehntlich alle entfernt wurden, hätte ich ein ernsthaftes Problem.

                    mfg Micha



                    Hat ja nur was mit Windows PE zu tun. Du kannst ja mit diesem Image trotzdem Server 2003 SP2 aufsetzen. Lösen wird sich das nicht mehr, weil Microsoft auf Windows PE 2.0 verweist.

                    Zu dem Problem siehe folgenden KB Artikel:
                    http://support.microsoft.com/kb/933510/en-us

                    Unbedingt beachten:
                    You cannot start the Windows Server 2003 SP2 version of Windows PE by using a bootable RAM disk

                    You can start Windows PE by using a bootable RAM disk. This RAM disk can be a hard disk or a CD. However, you cannot start the Windows Server 2003 SP2 version of Windows PE by using a bootable RAM disk.


                    Also startrom etc. weiterhin von SP1 verwenden oder umsteigen auf die neue PE Version.

                    Gruß
                    Stefan