14 Replies Latest reply on May 7, 2009 5:58 AM by Stoj



      Where is the LDVPE1.IMG stored?


      Is it in a directory on your core? I'm having trouble understanding that.

        • 1. Re: LDVPE1.IMG
          Joshni SupportEmployee

          It is stored on the core server in program files\LANDesk\Managementsuite\landesk\vboot directory

          • 2. Re: LDVPE1.IMG

            Paul --


            To be more specific, the LDVPE1.img is stored where Josh stated (\Program Files\LANDesk\ManagementSuite\landesk\vboot by default), however the file is called renamed peboot.img when it is deployed to your PXE reps, and is located on \Program Files\LANDesk\PXE\System\images by default.  If you are looking to modify the windows PE boot image, I would recommend making the changes on a PXE rep (i.e. the peboot.img on a PXE rep), testing it on that subnet, and if all goes well, copy the peboot.img up to the core (renaming it to ldvpe1.img and backing up the old one) and redeploy all of the remaining PXE reps.

            • 3. Re: LDVPE1.IMG

              This will be helpful. I need to update the version of HAL that WinPE is using so I will be able to test it first to make sure everything is okay.

              • 4. Re: LDVPE1.IMG

                the HAL?  What do you need to do?  Are you trying to run the Windows PE image on 64 bit systems rather than the typical 32 bit?  I don't recall if there are any forum posts floating around to that end, but there are a ton of potential issues to this end -- at the moment LANDesk isn't supporting a 64 bit for imaging through windows PE.

                • 5. Re: LDVPE1.IMG



                  Since I'm not at work today I cannot provide the exact HAL versions but ultimately what my issue is, is that I'm setting up provisioning. My base image was on a GX520. I've deployed this provisioning task to several other model machines desktops and laptops. However when I send it to a D600 or a D400 Dell Laptop I'm getting a HAL error. I then took my base image and set the HAL back to whatever the so called "Universal" HAL is called and ran it again with no luck. Then I was reading that the "Universal" HAL needs to be in the WinPE image. That's why I need to edit it. Feel free to offer advice here. I know it's a bit off topic. If you want I can start a thread in OSD.

                  • 6. Re: LDVPE1.IMG
                    Joshni SupportEmployee



                    I just tried escalating this case to the PSE and received a out of office response.  It looks like Jeremy is going to be out of the office until Wed.


                    I will ask around to see if anyone else has had a chance to play with HWII lately.  But this may have to wait until Wed so I can talk with Jeremy.



                    • 7. Re: LDVPE1.IMG

                      Thanks for the update Josh. Shoot me an email if you hear anything. pstojanovski@fhi.org

                      • 8. Re: LDVPE1.IMG

                        Paul --


                        I may get my knuckles rapped for suggesting this, but you can inject the hal files as part of the provisioning script.  Before provisioning was part of LANDesk, Jan Beulens co authored a document with Mike Ybarra on Hardware Independent imaging.  In that document, it spoke specifically of the files that HAL comprises of with respect to CPU.  One of my customers found that copying the files from a functional machine resolved their HAL issues.  I'ts a little more than what I'm explaining here at the moment, and it may not speak to your specific issue, however if your HAL problem is with processor architecture specifically this may do the trick.  See if you can track down that document  (I think it's rev2, but the information may be in the latest and greatest document).

                        • 9. Re: LDVPE1.IMG
                          ahe Expert



                          here you can find the latest document (Rev 9): Hardware Independent Imaging using LANDesk OSD - rev 9.1




                          • 10. Re: LDVPE1.IMG

                            I've been using this document extensively. It's been my Bible over the past month. Before your post i've done pretty much everything the document has suggested for HAL except the manual copy of hal.dll, ntkrnlpa.exe, and ntoskrnl.exe. Today however, I decided to try and copy the files over and leave the HalConfig.Exe action in there. It didn't work when I tried that. Nonetheless, when I removed the HalConfig.Exe action it finally worked. Except for one driver issue haha. Can't win them all. I suppose I'll just make a template for Desktops, Laptops, and D600/D400.

                            • 11. Re: LDVPE1.IMG

                              I'm confident your issue can be overcome - keep posting your challenges and we'll see if we can help you get everything into one template.

                              • 12. Re: LDVPE1.IMG
                                ahe Expert

                                Hello Paul,


                                do you know the new hints about HAL of Jan Buelens from yesterday? :-)






                                • 13. Re: LDVPE1.IMG

                                  Or rather, the one that I published today. It turns out I had forgotten to put in a bug fix that a few people suggested to me. HalConfig V2.1, published today, corrects that oversight.


                                  The problem was that the ACPI HAL (likely to be found on machines that are a few years old) was not recognised, resulting in a HalConfig failing with error message "unknown HAL type: acpipic_up". You may not have seen the message because it goes away after 10 seconds. But you would have noticed HalConfig exiting with a bad return code.


                                  The new version removes the requirement to downgrade your master machine to a "lowest common denominator" HAL. That was necessary because it turns out that, if you add some of the latest machines into the mix, there is no longer a lowest common denominator. It should no longer matter which HAL you have in your image.

                                  1 of 1 people found this helpful
                                  • 14. Re: LDVPE1.IMG

                                    Oh I'm very confident I will get through this process. No one said it would be easy. It's better if it's not. That way I'm forced to learn more . I was able to get the Hal and Drivers on the D600 and D400 to work just fine. However, Jan, this updated post of yours is exactly the trouble I was having with the HAL. I was getting that "unknown HAL type: acpipic_up". error. Currently I have a template for Desktop machines and one for Laptop machines. Because of this issue I was forced to create a seperate template for D600 and D400 that addressed their HAL issue, giving me three total templates. With this updated post of yours, I should be able to revert back to just using a Desktop and Laptop template.


                                    Again I appreciate all your guys help. You've contributed to much of my learning of this process. I think I have the drivers section down, now the only thing I have to work on is MSD which I've already created a post. http://community.landesk.com/support/message/24831#24831 that covers the trouble I'm having.


                                    I've realized one thing I did wrong and I'm going back to test now to see if that's the cure. I'll keep you guys posted on my progress through that discussion.


                                    I think we should retire this one. Thank you again!


                                    - Paul