1 2 3 Previous Next 40 Replies Latest reply on Jun 13, 2008 2:34 AM by Ratzratz

    Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt

    PaddyM Specialist
      Hallo zusammen,
      ich habe einen Grafiktreiber der wunderbar installiert wird, funktioniert auch soweit (hab natürlich noch nicht jede einzelne Funktion getestet) aber er wird mir in der eMMC als fehlgeschlagen zurück gemeldet.
      Warum?
      Ich find irgendwie auf der Maschine kein LOG das mir einen Fehler anzeigt.
      Weiß jemand wo ich da fündig werden könnte?

      c ya
      Paddy

      Edit:
      so ich hab das LOG gefunden:


      12:34:54.730 2        ---->Starting installation of "Intel_G31_G33_Q33_Q35_Graphics_Controller_Driver_Optiplex755 Ver. 6.14.10.4837 vom 28.06.2007"

      12:34:54.730 2        -> InstallPnpDevices
      12:34:56.139 2         xniTools: Now copying complete driver package from C:\Programme\Gemeinsame Dateien\enteo\RepositoryCache\5706\rev\1\Extern$\drv\{EC4ABDD7-C358-4C8F-9148-CABDCD2D4F4A} to C:\Dokumente und Einstellungen\enteoservice\Lokale Einstellungen\Temp\PNPBD.tmp
      12:34:56.139 1         xniTools: Trying Pnp Installation from inf file C:\Dokumente und Einstellungen\enteoservice\Lokale Einstellungen\Temp\PNPBD.tmp\igxp32.inf
      12:34:56.139 1         xniTools: Updating matching hwID PCI\VEN_8086&DEV_29B2&SUBSYS_02111028 from file C:\DOKUME~1\ENTEOS~1\LOKALE~1\Temp\PNPBD.tmp\igxp32.inf with its 1st hwID PCI\VEN_8086&DEV_29B2&SUBSYS_02111028&REV_02

      12:35:00.116 1         Logging up ExR event 3501 (0x00000dad)

      12:35:00.116 1         SI: Starting ExRSend.exe ...
      12:35:00.116 2         SI: Rewriting SI client state data...
      12:35:00.116 1          SI: Reading client state...
      12:35:00.131 1          SI: Writing possible changes of client state...
      12:35:00.131 E         Error (Module:xniTools, Severity:0x0b): Treiberinstallation/Aktualisierung für DeviceInstance/Treiberpfad PCI\VEN_8086&DEV_29B2&SUBSYS_02111028&REV_02 C:\DOKUME~1\ENTEOS~1\LOKALE~1\Temp\PNPBD.tmp\igxp32.inf
      Falscher Parameter.
      fehlgeschlagen.
      Das System kann das angegebene Gerät oder die angegebene Datei nicht öffnen.

      12:35:00.131 1         Checking if policies should run for the trigger 'Time based trigger'.
      12:35:00.131 1         SWMSClntLib: Verify if the policyinstance are possible to install
      12:35:00.742 2       Execution terminated on error
      12:35:00.742 1       Logging up ExR event 3002 (0x00000bba)

      12:35:00.742 1       SI: Starting ExRSend.exe ...
      12:35:00.742 1       SI: ExRSend is allready running no need to start ...
      12:35:00.742 2       xniFPS: '{3DF9A9EE-B6D4-4724-A5C1-8EAB1107033C}' is installed
      12:35:00.742 1       xniFPS: Switching package folder for package 'Intel_G31_G33_Q33_Q35_Graphics_Controller_Driver_Optiplex755 Ver. 6.14.10.4837 vom 28.06.2007' to 'C:\Programme\Gemeinsame Dateien\enteo\RepositoryCache\5706\rev\1\'.
      12:35:00.742 1       FPS.dll: --------------- FpsCloseFilePackage interface called ---------------
      12:35:00.742 2       FPS.dll: Closing the file package '\\?\C:\Programme\Gemeinsame Dateien\enteo\RepositoryCache\5706\rev\1\'.
      12:35:00.742 1       FPS.dll: --------------- FpsCloseFilePackage finished ---------------

      12:35:00.742 2       ---->Installation of Intel_G31_G33_Q33_Q35_Graphics_Controller_Driver_Optiplex755 Ver. 6.14.10.4837 vom 28.06.2007 has not completed on exit.

      er meckert mir darin die Datei igxp32.inf an. Die Datei liegt aber definitv im Repository.
      Was tun?
        • 1. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
          PaddyM Specialist
          So jetzt hab ich den Treiber mal neu installieren lassen und siehe da kein Fehler mehr. Jetzt krieg ich compliant zurück gemeldet.
          Ist das jetzt ein Bug meines Release (2095) bezüglich der Compliant Rückmeldung? Kann ja nicht sein weil der Fehler ja auch im Log drin steht.
          Oder ist es ein Fehler im Treiberpaket?

          Ich bin etwas ratlos. Ich installier die Kiste jetzt mal neu und dann sehen wir was passiert.

          c ya
          Paddy
          • 2. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
            PaddyM Specialist
            So, ich nochmal.
            Also hab die Maschine neu installiert --> Treiber war erfolgreich drauf, wurde aber als fehlgeschlagen zurück gemeldet.
            Den Treiber nochmals installieren lassen --> Treiber wurde als Compliant zurück gemeldet.

            Irgendjemand ne Idee?

            c ya
            Paddy
            • 3. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
              NicoS1 Master
              Ich hätte da eine ganz ganz blöde Vermutung...

              C:\DOKUME~1\ENTEOS~1\LOKALE~1\Temp\PNPBD.tmp\igxp3 2.inf

              Enteo könnte ein eventuell ein Problem mit der Leertaste im Dateinamen haben. Seit mir enteo nach einem update keine Dateien mehr ohne Dateiendung kopiert traue ich dem Ding alles zu ;-) müsste nur ein Programmierer vergessen haben den Befehl (wie auch immer) mit Anführungszeichen zu übergeben.
              • 4. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
                MTheis Specialist
                Ich klinke mich hier mal ein, da ich mit dem gleichen Chipsatz (Intel Q35) dsa Problem habe. Der Treiber ist installiert (sehe ich ja an der Auflösung) aber enteo zeigt einen Fehler an. Wenn ich mich an der Maschine als lokaler Admin anmelde erscheint von Windows der Hinweis, dass der Gerätetreiber installiert werden muss. Bestätige ich dies, ist alles in ordnung. Mit Benutzerrechten taucht der Hinweis nicht auf.

                Hier mal die Logdatei, den spannenden teil markiere ich rot.

                12:39:52.022 2        -> InstallPnpDevices
                12:39:52.037 0         xniTools: NIL_InstallPnpDevices: Created Event named Global\PnPEventIntel(R)  G35 Express Chipset Family{04EEB915-A6AB-4B80-BF22-F3EB96EAE7D6}
                12:39:52.037 0         xniTools: NIL_InstallPnpDevices: Project is already installed: No
                12:39:52.037 0         xniTools: NIL_InstallPnpDevices: Event Global\PnPEventIntel(R)  G35 Express Chipset Family{04EEB915-A6AB-4B80-BF22-F3EB96EAE7D6} is non-signalled
                12:39:52.084 0         xniTools: Using C:\Program Files\Common Files\enteo\RepositoryCache\9103\rev\1\extern$\prjconf.inf as the PNP project configuration file
                12:39:52.115 0         xniTools: Determination of full path to inf file:
                12:39:52.131 0         xniTools: ST5210: Skipping path query for C:\Program Files\Common Files\enteo\RepositoryCache\9103\rev\1\extern$\prjconf.inf to avoid Windows SetupQueryInfFileInformation Bug
                12:39:52.131 0         xniTools: Determination of original name of inf file:
                12:39:52.131 0         xniTools: Skipping determination of original file name C:\Program Files\Common Files\enteo\RepositoryCache\9103\rev\1\extern$\prjconf.inf since it is already known...
                12:39:57.170 2         xniTools: Now copying complete driver package from C:\Program Files\Common Files\enteo\RepositoryCache\9103\rev\1\Extern$\drv\{6D372748-B16C-4791-BDA3-401BF6F46433} to C:\Users\eRuntime\AppData\Local\Temp\PNP866E.tmp
                12:39:57.186 0         xniTools: Driver package was copied successfully from the server directory to a local temporary directory, we will use the client's driver files.
                12:39:57.186 1         xniTools: Trying Pnp Installation from inf file C:\Users\eRuntime\AppData\Local\Temp\PNP866E.tmp\kit13732.inf
                12:39:57.186 1         xniTools: Updating matching hwID PCI\VEN_8086&DEV_29B2 from file C:\Users\eRuntime\AppData\Local\Temp\PNP866E.tmp\kit13732.inf with its 1st hwID PCI\VEN_8086&DEV_29B2&SUBSYS_2819103C&REV_02

                12:40:07.139 0         xniTools: Deleting Subdirs of C:\Users\eRuntime\AppData\Local\Temp\PNP866E.tmp
                12:40:07.139 0         xniTools: Deleting Dir: C:\Users\eRuntime\AppData\Local\Temp\PNP866E.tmp
                12:40:07.357 1         Logging up ExR event 3501 (0x00000dad)
                12:40:07.357 E         Error (Module:xniTools, Severity:0x0b): Treiberinstallation/Aktualisierung für DeviceInstance/Treiberpfad PCI\VEN_8086&DEV_29B2&SUBSYS_2819103C&REV_02 C:\Users\eRuntime\AppData\Local\Temp\PNP866E.tmp\kit13732.inf
                fehlgeschlagen.
                Das System kann das angegebene Gerät oder die angegebene Datei nicht öffnen.

                12:40:07.373 0         Messagebox suppressed  (No output allowed)
                12:40:07.373 0         Searching for triggered jobs (13)
                12:40:07.373 1         Checking if policies should run for the trigger 'Time based trigger'.
                12:40:07.373 1         SWMSClntLib: Verify if the policyinstance are possible to install
                12:40:07.482 0         No triggered jobs found
                12:40:07.513 2       Execution terminated on error
                12:40:07.513 0       Checking install state of {04EEB915-A6AB-4B80-BF22-F3EB96EAE7D6}...
                12:40:07.529 0        Not installed
                12:40:07.529 1       Logging up ExR event 3002 (0x00000bba)
                12:40:07.529 2       xniFPS: '{04EEB915-A6AB-4B80-BF22-F3EB96EAE7D6}' is installed
                12:40:07.529 1       xniFPS: Switching package folder for package 'Intel(R)  G35 Express Chipset Family' to 'C:\Program Files\Common Files\enteo\RepositoryCache\9103\rev\1\'.
                12:40:07.529 1       FPS.dll: --------------- FpsCloseFilePackage interface called ---------------
                12:40:07.545 0       FPS.dll: Parameters:
                12:40:07.545 0       FPS.dll: Package handle: 5060140
                12:40:07.545 2       FPS.dll: Closing the file package '\\?\C:\Program Files\Common Files\enteo\RepositoryCache\9103\rev\1\'.
                12:40:07.545 1       FPS.dll: --------------- FpsCloseFilePackage finished ---------------

                12:40:07.545 2       ---->Installation of Intel(R)  G35 Express Chipset Family has not completed on exit.

                12:40:07.545 1      > Action 'Executing project db:master\Intel(R)  G35 Express Chipset Family [ExecFlags: 0x002010 (install, ws, )]' failed (Action took 15912 ms.)
                12:40:07.560 1     SwmsTpExtenderScript: Installation or Uninstallation of eScriptPackage PNPPACKAGE.9103 ({04EEB915-A6AB-4B80-BF22-F3EB96EAE7D6}) failed
                12:40:07.560 0     SwmsTpExtenderScript: Termination flags are: 0
                12:40:07.560 E    Warning (Module:Main, Severity:0x03): Installation or Uninstallation of Package PNPPACKAGE.9103 (Intel(R)  G35 Express Chipset Family) via PolicyInstance POLICYINSTANCE.9509 failed!
                12:40:07.576 0    SWMSClntLib: Setting ClientRolloutState of PolicyInstance POLICYINSTANCE.9509 to IMPLEMENTATION_NOT_POSSIBLE
                12:40:07.732 2   Cleanup Run of Job JOB:POLICYINSTANCE.9509...
                12:40:07.747 0    Searching for triggered jobs (8)
                12:40:07.747 1    Checking if policies should run for the trigger 'Terminated script'.
                12:40:07.763 1    SWMSClntLib: Verify if the policyinstance are possible to install
                12:40:07.857 0    No triggered jobs found
                12:40:07.872 0     SWMSClntLib: CEsiSWMSPackageController: Setting package state to 'uninstalled'
                12:40:07.872 0     SWMSClntLib: File package properties: ID is '9103', Repository is 'master' (65916) and Revision 'R1'.
                12:40:07.872 1     FPSClnt.dll: --------------- FpsClientAnnounceFilePackageState interface called ---------------
                12:40:07.872 0     FPSClnt.dll: Parameter:
                12:40:07.888 0     FPSClnt.dll: File package Id : 9103
                12:40:07.888 0     FPSClnt.dll: Package revision: R1
                12:40:07.888 0     FPSClnt.dll: Package in use  : no
                12:40:07.966 1     FPSClnt.dll: --------------- FpsClientAnnounceFilePackageState finished ---------------
                12:40:07.966 2   Handling Reboot of Job JOB:POLICYINSTANCE.9509...
                12:40:07.966 0    Handling Reboot for Job JOB:POLICYINSTANCE.9509
                12:40:07.966 2     Reboot not allowed: Job failed
                12:40:07.981 1     System reboot flag cleared
                12:40:07.981 1     System reboot flag cleared

                Ich verstehe das so, dass er das Verzeichnis löscht und dann danach sucht Im Ordner Drivers sind alle Dateien vorhanden.

                Gruß, MTheis
                • 5. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
                  PaddyM Specialist
                  Na da bin ich aber froh das das Problem noch bei anderen Auftritt.
                  Nun ja wir haben den Sachverhalt immer noch und auch einen ähnlichen Fehler wie von meinem "Vor-Poster" beschrieben.

                  Falls jemand Lösungsvorschläge hat nur her damit

                  c ya
                  Paddy
                  • 6. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
                    CarolaB Apprentice
                    Auch hier leider exakt das selbe Fehlerverhalten
                    Hardware:
                    Optiplex 755
                    Latitude D830

                    Der Fehler tritt sowohl im Dell Treiber auf, als auch wenn ich mir den Treiber von Intel runterziehe. Die angemeckerte inf. ist allerdings dann verschieden.

                    Die Frage ist sowowieso, warum der Treiber ins Temp.-Verzeichnis kopiert wird, wenn doch der Treiber an anderer Stelle im Repository-Cache liegt.

                    grüße
                    CarolaB
                    • 7. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
                      PaddyM Specialist
                      Hallo Carola,
                      das jedesmal ne andere Inf-Datei angemeckert wird ist mir übrigens auch schon aufgefallen
                      Da der Thread allerdings ein bischen tot war die letzte Zeit hab ichs nicht gepostet.

                      So nun haben wir 3 Problemfälle aber keine lösung

                      c ya
                      Paddy
                      • 8. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
                        Ratzratz Expert
                        Hallo Paddy,

                        so ein Problem hatte ich auch schonmal (siehe "http://forum.enteo.com/showthread.php?t=5472&highlight=treiber").
                        Es war bei mir auch eine Intel Q35 Express-Grafikkarte (OnBoard auf dem FSC ESPRIMO P5925).

                        Die Lösung bei uns war, daß der Treiber-Paket-Assistent nicht alle Dateien im Treiber-Paket, das ich von Intel heruntergeladen habe, auch in das Paketverzeichnis kopiert hat.
                        Ich habe dann einfach den Treiber per Assistent ganz normal in der eMMC importiert, aber danach noch alle fehlenden Dateien aus dem Treiber-Paket von Intel in das Paketverzeichnis reinkopiert.
                        Vorher waren das nur 54 Dateien, danach sind das dann 64 Dateien.
                        Es fehlten also 10.
                        Das kommt daher, daß in der INF-Datei des Treiber-Pakets nicht alle Dateien, die der Treiber braucht, eingetragen sind. Das ist also eine Nachlässigkeit vom Treiber-Hersteller.

                        Danach habe ich das Treiber-Paket freigegeben und nochmal neu zugewiesen und hatte dann in der eMMC grün.

                        Gruß
                        M. Metzger
                        • 9. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
                          sku Apprentice
                          Hallo,

                          Na da bin ich aber froh das das Problem noch bei anderen Auftritt.
                          Nun ja wir haben den Sachverhalt immer noch und auch einen ähnlichen Fehler wie von meinem "Vor-Poster" beschrieben.

                          Falls jemand Lösungsvorschläge hat nur her damit

                          c ya
                          Paddy



                          Wurde denn ein logfile fuer den niudfppd.exe angelegt? Dessen Inhalt waere an dieser Stelle interessant. Und noch ne Frage: Ist auf der entsprechenden Maschine eventuell im filesystem die Erzeugung kurzer Dateinamen disabled (kann man fuer NTFS volumes ausschalten)?

                          --
                          Stefan Kuhr, enteo development
                          • 10. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
                            Ratzratz Expert
                            Hallo Stefan,

                            das mit der Logdatei weiß ich jetzt nicht mehr. Ist zu lange her.
                            Wenn ich jedoch per enteo ein Projekt ausrolle habe ich immer diese Pfade mit "~" drin.
                            Ich gehe also davon aus, daß die Erzeugung kurzer Dateinamen standardmäig aktiviert ist und ich habe da nie irgendwas geändert.

                            Gruß
                            M. Metzger
                            • 11. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
                              MTheis Specialist
                              So, vielen Dank erstmal.

                              Ich habe noch einmal die Varaiante probiert mit

                              1. Treiber (Original Intel)  manuell installieren
                              2. Treiber über die eMMC von dem PC einlesen lassen (Q35)
                              3. die fehlenden Dateien aus dem Original Downloadpaket ins paketverzeichnis kopieren
                              4. Distributieren
                              5. Maschine neu installieren

                              Was passiert?

                              - Maschine installiert sich neu (Vista Business 32)
                              - Treiber wird als compliant angezeigt
                              - Unter der Useranmeldung sehe ich den Treiber im Gerätemanager
                              - Beim Einstellen der Anzeige wird jedoch noch Standard-VGA angezeigt
                              - Maschine manuell neu starten
                              - Immer noch eine 800x600 Auflösung
                              - Benutzer erneut anmelden -> er springt automatisch auf die gewünschte (1680x1050)

                              Das Ergebnis gefällt mir ganz gut. Jetzt müsste nur noch der Neustart automatisch erfolgen, oder gar nicht erst nötig sein, wie bei der anderen Variante. Da zeigt er ja an, dass der Treiber nicht drauf sei, startet aber gleich beim ersten Hochfahren mit der 1680er Auflösung. Nachteil bei der Lösung ist halt, dass der Treiber nicht sauber drauf ist und sobald sich der erste Admin einloggt, Windows um Installation des Treiber bittet.

                              Wir sind doch schon nah dran, oder?

                              Los, Endspurt!
                              • 12. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
                                FrankScholer Master
                                Hi M.

                                wie wäre es, wenn du die Auflösung einfach per Script setzt. Z.B. über das Tool ResSwitch (http://www.naughter.com/qres.html). Funzt unter XP und auch Vista.

                                HTH, Gruß Frank
                                • 13. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
                                  MTheis Specialist
                                  Er nimmt ja die Auflösung, nach einem manuell ausgeführtem Neustart und einem weiteren Login automatisch an.

                                  Wenn ich das per Script verteile bringt es nichts, da der Treiber vor dem Neustart nicht richtig initialisiert wird. Und das er nach dem darauffolgenden Login die richtige Auflösung nimmt, liegt vermutlich daran, dass ich die beim Setup-Package schon entsprechend mit übergebe.

                                  Gruß, Michael
                                  • 14. Re: Treiber erfolgreich installiert - wird aber als Fehlgeschlagen angezeigt
                                    sku Apprentice
                                    Hallo beisammen,

                                    Hallo Stefan,

                                    das mit der Logdatei weiß ich jetzt nicht mehr. Ist zu lange her.
                                    Wenn ich jedoch per enteo ein Projekt ausrolle habe ich immer diese Pfade mit "~" drin.
                                    Ich gehe also davon aus, daß die Erzeugung kurzer Dateinamen standardmäig aktiviert ist und ich habe da nie irgendwas geändert.

                                    Gruß
                                    M. Metzger



                                    Vielleicht haben PaddyM oder MTheis noch ein niudfppd-Logfile, das zum Zeitpunkt der fehlgeschlagenenen Pnp-Installation erzeugt wurde? Die Vermutung mit dem fehlenden Quote duerfte richtig sein, mit einem niudfppd-Logfile koennte man's beweisen.

                                    Danke fuer jeden Hinweis,

                                    --
                                    Stefan Kuhr, enteo development
                                    1 2 3 Previous Next