1 2 Previous Next 26 Replies Latest reply on Jul 29, 2008 6:54 AM by dkoenig

    Software Shop Fehler SWMS (v6.1)

    benim Apprentice
      Hallo Leute,

      da mit der Support immer noch nicht weiter geholfen hat wollte ich mal euch fragen ob Ihr auch das Problem mit dem Software Shop habt wie ich. Wenn ich den Shop starte bekomme ich direkt eine Fehlermeldung: Failed to initialize SWMS to get SwShop-Entries.
      Auf diesem Client war früher ein 5.85 Client, diesen habe ich mit NiClean geläuscht und danach das alte Verzeichnis gelöscht. Ich habe mal zum testen einen "sauberen" Rechner genommen und den v6.1 Client auf diesem Installiert und siehe da es funktioniert. Woran kann das liegen das das nicht auf dem anderen Rechner nicht läuft?

      Gruß,
      Benim
        • 1. Re: Software Shop Fehler SWMS (v6.1)
          dei Specialist
          Hi,

          poste doch einfach mal das entsprechende Logfile hier und eventuell ein File-Version-Nummern-Dump deines NetInst-Client-Directories. Vielleicht kann ich schnell und einfach den Grund finden.

          Grüße
          • 2. Re: Software Shop Fehler SWMS (v6.1)
            benim Apprentice
            Hallo Dirk,

            hier ist der Auszug aus der Log Datei:
            08:18:01.581 1  -------- enteo v6 Software Shop -----------------------------------------------

            08:18:01.581 2  Initialisiere SWMS
            08:18:01.612 1  CMSClntLib: Using http://SRVNETINSTALL:8080//blsClientManagement/ClientManagementService.asmx to communicate with the business logic server or a proxy

            08:18:01.612 1  -------- Initializing target provider -----------------------------------------


            08:18:01.675 1  -------- Identify logged on user and local computer ---------------------------

            08:18:01.675 1   CMSClntLib: Performin local computer indentification
            08:18:01.675 1   CMSClntLib: Enumerating network devices...
            08:18:01.675 1   CMSClntLib: Ignoring VMWare adapter
            08:18:01.675 1   CMSClntLib: Ignoring VMWare adapter
            08:18:01.675 1   CMSClntLib: Indentification properties:
            08:18:01.690 1   CMSClntLib: A server exception occured
            08:18:01.690 1   CMSClntLib: Error-Msg: Error #-1:

            08:18:01.690 1  -------- Final MiCache Synchronization ----------------------------------------

            08:18:01.690 2  Failed to get all assigned policy instances.
            08:18:01.690 1  During the last run no policyinstances are handled
            08:18:01.690 1  Skipping final sync.
            08:18:01.690 1  Trigger a background job to clean removed CMDBCache entries...
            08:18:02.035 E  Warning (Module:SWMSClntLib, Severity:0x03): Couldn't find the need job object

            08:18:02.035 1   -------- Unregistering all TargetProviderExtender -----------------------------

            08:18:02.035 E  Warning (Module:Main, Severity:0x03): Failed to initialize SWMS to get SwShop-Entries!
            08:18:06.071 2  Uninitializing NIRT (Quality Assurance and Support)
            08:18:06.071 2  Uninitializing NIRT (ExR)
            08:18:06.071 2  Uninitializing NIRT (RunTime)

            Die Version die bei mir Installiert ist, ist die 6.01.0.2193


            Mir ist aber auch gerade etwas anderes aufgefallen:

            08:18:01.581 E   Warning (Module:xniTools, Severity:0x03):
            Couldn´t open registry key 'Software\NetSupport\NetInstall\PnPDeviceList in HKEY_LOCAL_MACHINE'
            Das System kann die angegebene Datei nicht finden.

            Hat das etwas zu bedeuten?


            Gruß,
            Benim
            • 3. Re: Software Shop Fehler SWMS (v6.1)
              dei Specialist
              Hi,

              1 CMSClntLib: Ignoring VMWare adapter
              08:18:01.675 1 CMSClntLib: Indentification properties:
              08:18:01.690 1 CMSClntLib: A server exception occured
              08:18:01.690 1 CMSClntLib: Error-Msg: Error #-1:


              Diese Zeilen zeigen das die Kommunikation mit dem Server nicht funktioniert. Entweder die Anfrage kommt garnicht beim Server an oder es gibt einen Fehler im BLS. Jetzt brauchen wir auch noch den zeitgleichen Auszug aus dem Serverlog (blsAdminWebServicexxxx.log). Falls du das Log nicht mehr hast, muss der Prozess wohl nochmal wiederholt werden.

              Dirk
              • 4. Re: Software Shop Fehler SWMS (v6.1)
                benim Apprentice
                Hi,

                so habe heraus bekommen das die Daten an den Server gesendet werden (Inventory Dateien). Habe mir auch mal die blsAdminWEbService....mal angesehen. Laut Log baue ich eine Verbindung zu Server auf, eine Fehlermeldung kann ich aber nicht genau sehen.

                Gruß,
                Benim
                • 5. Re: Software Shop Fehler SWMS (v6.1)
                  Badmin Apprentice
                  Hi Benim.

                  Ich hatte dieses Problem auch auf einem Client nach dem Update von 6.0 auf 6.1
                  Eine Neuinstallation des Clients auf dem Rechner hat das Problem bei mir behoben.

                  Gruß
                  Harry
                  • 6. Re: Software Shop Fehler SWMS (v6.1)
                    benim Apprentice
                    Hallo Harry,

                    den Client habe ich schon 3mal neu installiert und immer noch keine Lösung.
                    Wie hast du den Client deinstalliert? Ich habe es mit NIClean deinstalliert.

                    Gruß,
                    Benim
                    • 7. Re: Software Shop Fehler SWMS (v6.1)
                      Badmin Apprentice
                      Ich habe die Dienste gestoppt, alles aus C:\Programme\Gemeinsame Dateien\Enteo\ gelöscht und dann niagnt32 /install /force /bin laufen lassen.
                      • 8. Re: Software Shop Fehler SWMS (v6.1)
                        dei Specialist
                        Hi,

                        bitte probier doch mal zwei Sachen aus:

                        1. Reproduzier den Fehler und poste mit das blsClientWebService-LogFile vom Server und das zugehörig AutoInstaller-Log

                        2. Probier mal über den InterExplorer auf die bslClientWebService-URL zu gehen die du im Logfile des AutoInstallers sehen kannst. Erscheint dort die WebService-Informations-Seite ist nicht von einem Proxy-Fehler auszugehen.

                        Grüße
                        • 9. Re: Software Shop Fehler SWMS (v6.1)
                          benim Apprentice
                          Hi,

                          Client Log
                          ------------
                          12:09:50.271 2  Initialisiere SWMS
                          12:09:50.286 1  CMSClntLib: Using http://SRVNETINSTALL:8080//blsClientManagement/ClientManagementService.asmx to communicate with the business logic server or a proxy
                          12:09:50.349 1   CMSClntLib: Performin local computer indentification
                          12:09:50.349 1   CMSClntLib: Enumerating network devices...
                          12:09:50.349 1   CMSClntLib: Indentification properties:
                          12:09:50.364 1   CMSClntLib: A server exception occured
                          12:09:50.364 1   CMSClntLib: Error-Msg: Error #-1:
                          12:09:50.364 2  Failed to get all assigned policy instances.
                          12:09:50.364 1  During the last run no policyinstances are handled
                          12:09:50.364 1  Skipping final sync.
                          12:09:50.364 1  Trigger a background job to clean removed CMDBCache entries...
                          12:09:50.708 E  Warning (Module:SWMSClntLib, Severity:0x03): Couldn't find the need job object
                          12:09:50.708 E  Warning (Module:Main, Severity:0x03): Failed to initialize SWMS to get SwShop-Entries!
                          12:09:56.315 2  Uninitializing NIRT (Quality Assurance and Support)
                          12:09:56.315 2  Uninitializing NIRT (ExR)
                          12:09:56.315 2  Uninitializing NIRT (RunTime)



                          Gruß,
                          Benim
                          • 10. Re: Software Shop Fehler SWMS (v6.1)
                            benim Apprentice
                            Server Log
                            ------------
                            2008-04-23 12:09:54,903 [1] INFO  Enteo.BlServer.Config - Loaded Business Logic 'Enteo.BlServer.DataAccess'.
                            2008-04-23 12:09:54,919 [1] INFO  Enteo.BlServer.Config - Trying to register assembly 'Enteo.BlServer.DataAccess, Version=6.1.0.2174, Culture=neutral, PublicKeyToken=2aa8ae3ddce4beba'.
                            2008-04-23 12:09:54,919 [1] INFO  Enteo.BlServer.Config - Loaded Business Logic 'Enteo.BlServer.Base'.
                            2008-04-23 12:09:54,919 [1] INFO  Enteo.BlServer.Config - Trying to register assembly 'Enteo.BlServer.Base, Version=6.1.0.2175, Culture=neutral, PublicKeyToken=2aa8ae3ddce4beba'.
                            2008-04-23 12:09:54,919 [1] INFO  Enteo.BlServer.Config - Loaded Business Logic 'Enteo.BlServer.Core'.
                            2008-04-23 12:09:54,934 [1] INFO  Enteo.BlServer.Config - Trying to register assembly 'Enteo.BlServer.Core, Version=6.1.0.2175, Culture=neutral, PublicKeyToken=2aa8ae3ddce4beba'.
                            2008-04-23 12:09:54,966 [1] INFO  Enteo.BlServer.Config - Loaded Business Logic 'Enteo.BlServer.Jobs'.
                            2008-04-23 12:09:54,966 [1] INFO  Enteo.BlServer.Config - Trying to register assembly 'Enteo.BlServer.Jobs, Version=6.1.0.2171, Culture=neutral, PublicKeyToken=2aa8ae3ddce4beba'.
                            2008-04-23 12:09:54,966 [1] INFO  Enteo.BlServer.Config - Loaded Business Logic 'Enteo.BlServer.Swms'.
                            2008-04-23 12:09:54,981 [1] INFO  Enteo.BlServer.Config - Trying to register assembly 'Enteo.BlServer.Swms, Version=6.1.0.2190, Culture=neutral, Public
                            • 11. Re: Software Shop Fehler SWMS (v6.1)
                              dei Specialist
                              Hi,

                              aber was ist mit dem Server-Log-File "blsClientWebServiceXXX.log".

                              Grüße
                              • 12. Re: Software Shop Fehler SWMS (v6.1)
                                dei Specialist
                                Hi,

                                sorry war zu schnell. Kannst du das ganze Logfile an einen Post hängen?

                                Grüße
                                • 13. Re: Software Shop Fehler SWMS (v6.1)
                                  benim Apprentice
                                  Hi,

                                  die Log Datein ist einfach zu groß. Kann ich dir die Datei mal schicken?

                                  Gruß,
                                  Benim
                                  • 14. Re: Software Shop Fehler SWMS (v6.1)
                                    benim Apprentice
                                    Hi,

                                    so hier ist die Log.

                                    Gruß,
                                    Benim
                                    1 2 Previous Next