2 Replies Latest reply on Nov 25, 2008 1:40 AM by SKietzke

    Outbox läuft voll

    SKietzke Apprentice
      Hallo,

      wir haben in unserer Umgebung (NI 5.85) für jeden Standort einen Managepoint inkl. Inventory. Auf einem dieser MPs werden seit einiger Zeit die Inventorydaten nicht mehr weitergereicht.
      Der Server versucht anscheinend die Daten zu verarbeiten und stösst dabei meines Erachtens auf einen Fehler.

      Hier der Abschnitt aus der Datei ExrMPEServObAgent_SYSTEM_1452.log:

      08:49:06 0 OutboxAgent: SendExrXmlData
      08:49:06 0 OutboxAgent: Read Xml datafile C:\Program Files\NetInst\Outbox\Exr.{6207A140-0D54-4392-9F00-37D8F255842D}_00000231227.xml and save to buffer without Xml Info Lines.
      08:49:06 0 OutboxAgent: Sending XML data...
      08:49:06 1 OutboxAgent: Sending file to MgntPoint URL: http:/
      isrv101:8080/NIISAPI.dll

      08:49:06 0 OutboxAgent: Http XML Handlertag: ExRep, Authentication: ANONYMOUS
      08:49:06 0 OutboxAgent:  please wait - connection timeout: max. 30 seconds ...
      08:49:06 1 niHttp: Using WinHTTP.dll to send data
      08:49:06 0 niHttp: WinHTTP: Send request
      08:49:06 0 niHttp: Parsing Webserver reply
      08:49:06 2 niHttp: Internal server error in XML ReplyXML ParseError0x-1072896681Invalid xml declaration.
      1<?xml version="1.0" encoding="UTF-16"?><niisapi><ExRep Version="">ÿþ<?xml version="1.0" encoding="UTF-16"?>
      08:49:06 2 niHttp: Internal server error in XML ReplyXML ParseError0x-1072896681Invalid xml declaration.
      1<?xml version="1.0" encoding="UTF-16"?><niisapi><ExRep Version="">ÿþ<?xml version="1.0" encoding="UTF-16"?>
      08:49:06 1 OutboxAgent: Receiving response...
      08:49:06 2 OutboxAgent: Failed to send XML file:  Internal server error in XML ReplyXML ParseError0x-1072896681Invalid xml declaration.
      1<?xml version="1.0" encoding="UTF-16"?><niisapi><ExRep Version="">ÿþ<?xml version="1.0" encoding="UTF-16"?>
      08:49:06 2 MPE_Service: Failed to send client data: C:\Program Files\NetInst\Outbox\Exr.{6207A140-0D54-4392-9F00-37D8F255842D}_00000231227.xml
      08:49:06 E Warning (Module:MPE_Service, Severity:0x03): Failed to send client data of outbox cache directory
      08:49:16 1 MPE_Service: Waiting 40 seconds ...
      08:49:56 0 OutboxAgent: SendExrXmlData
      08:49:56 0 OutboxAgent: Read Xml datafile C:\Program Files\NetInst\Outbox\Exr.{6DBE50B9-CA60-4CEB-B110-DF7847E027D6}_00000366972.xml and save to buffer without Xml Info Lines.
      08:49:57 0 OutboxAgent: Sending XML data...
      08:49:57 1 OutboxAgent: Sending file to MgntPoint URL: http:/
      isrv101:8080/NIISAPI.dll

      08:49:57 0 OutboxAgent: Http XML Handlertag: ExRep, Authentication: ANONYMOUS
      08:49:57 0 OutboxAgent:  please wait - connection timeout: max. 30 seconds ...
      08:49:57 1 niHttp: Using WinHTTP.dll to send data
      08:49:57 0 niHttp: WinHTTP: Send request
      08:49:57 0 niHttp: Parsing Webserver reply
      08:49:57 2 niHttp: Internal server error in XML ReplyXML ParseError0x-1072896681Invalid xml declaration.
      1<?xml version="1.0" encoding="UTF-16"?><niisapi><ExRep Version="">ÿþ<?xml version="1.0" encoding="UTF-16"?>
      08:49:57 2 niHttp: Internal server error in XML ReplyXML ParseError0x-1072896681Invalid xml declaration.
      1<?xml version="1.0" encoding="UTF-16"?><niisapi><ExRep Version="">ÿþ<?xml version="1.0" encoding="UTF-16"?>
      08:49:57 1 OutboxAgent: Receiving response...
      08:49:57 2 OutboxAgent: Failed to send XML file:  Internal server error in XML ReplyXML ParseError0x-1072896681Invalid xml declaration.
      1<?xml version="1.0" encoding="UTF-16"?><niisapi><ExRep Version="">ÿþ<?xml version="1.0" encoding="UTF-16"?>
      08:49:57 2 MPE_Service: Failed to send client data: C:\Program Files\NetInst\Outbox\Exr.{6DBE50B9-CA60-4CEB-B110-DF7847E027D6}_00000366972.xml
      08:49:57 E Warning (Module:MPE_Service, Severity:0x03): Failed to send client data of outbox cache directory
      08:50:07 1 MPE_Service: Waiting 40 seconds ...
      08:50:47 0 OutboxAgent: SendExrXmlData
      08:50:47 0 OutboxAgent: Read Xml datafile C:\Program Files\NetInst\Outbox\Exr.{6DBE50B9-CA60-4CEB-B110-DF7847E027D6}_00000367784.xml and save to buffer without Xml Info Lines.
      08:50:47 0 OutboxAgent: Sending XML data...
      08:50:47 1 OutboxAgent: Sending file to MgntPoint URL: http:/
      isrv101:8080/NIISAPI.dll

      08:50:47 0 OutboxAgent: Http XML Handlertag: ExRep, Authentication: ANONYMOUS
      08:50:47 0 OutboxAgent:  please wait - connection timeout: max. 30 seconds ...
      08:50:47 1 niHttp: Using WinHTTP.dll to send data
      08:50:47 0 niHttp: WinHTTP: Send request
      08:50:47 0 niHttp: Parsing Webserver reply
      08:50:47 2 niHttp: Internal server error in XML ReplyXML ParseError0x-1072896681Invalid xml declaration.
      1<?xml version="1.0" encoding="UTF-16"?><niisapi><ExRep Version="">ÿþ<?xml version="1.0" encoding="UTF-16"?>
      08:50:47 2 niHttp: Internal server error in XML ReplyXML ParseError0x-1072896681Invalid xml declaration.
      1<?xml version="1.0" encoding="UTF-16"?><niisapi><ExRep Version="">ÿþ<?xml version="1.0" encoding="UTF-16"?>
      08:50:47 1 OutboxAgent: Receiving response...
      08:50:47 2 OutboxAgent: Failed to send XML file:  Internal server error in XML ReplyXML ParseError0x-1072896681Invalid xml declaration.
      1<?xml version="1.0" encoding="UTF-16"?><niisapi><ExRep Version="">ÿþ<?xml version="1.0" encoding="UTF-16"?>
      08:50:47 2 MPE_Service: Failed to send client data: C:\Program Files\NetInst\Outbox\Exr.{6DBE50B9-CA60-4CEB-B110-DF7847E027D6}_00000367784.xml
      08:50:47 E Warning (Module:MPE_Service, Severity:0x03): Failed to send client data of outbox cache directory
      08:50:57 1 MPE_Service: Waiting 40 seconds ...


      Es sieht für mich so aus als hätte der Server ein Problem mit XML.

      Leider weiss ich momentan keinen Rat. Hatte schon jemand dieses oder ein ähnliches Problem und noch wichtiger hat jemand einen Lösungsansatz?

      Dank und Gruß

      Silvio
        • 1. Re: Outbox läuft voll
          thertkorn Expert
          kontrolliere mal den IIS auf dem Sevrer wo die XML DAteien hingesendet werden sollen. Irgendwie kann keine Verbindung mehr gemacht werden.
          Was passiert wenn du die Dateien manuell kopierst? d.h. die Dateien aus der Outbox in die Inbox des Servers wo die DAteien hingesendet werden sollen manuell kopieren.
          Werden diese importiert.
          Ebenso Plattenplatz kontrollieren und schauen ob auf dem Central die DAteien in der inbox abgearbeitet werden.
          • 2. Re: Outbox läuft voll
            SKietzke Apprentice
            Hallo,

            danke erstmal für Antwort. Am zentralen Server kann es nicht liegen, da die Abarbeitung von den anderen Standorten aus funktioniert.

            Ich habe trotzdem die Dateien mal händisch auf den zentralen Server kopiert. Sie werden dort klaglos verarbeitet. Es muss also am dezentralen Server liegen.

            Herzliche Grüsse
            Silvio