5 Replies Latest reply on May 7, 2009 2:43 PM by Jared Barneck

    Limit Remote Downloads To One At A Time Failing

    jmanijak Rookie

      I was trying to distribute a simple batch file that runs a .reg key to about 1600 devices.  I setup the delivery method enabling the "limit remote downloads (per subnet) to one device at a time".  When I ran the task, an unusual percentage failed, more than 60% failed with "failed to download all additional files for a package".  When I used a different delivery method that does not limit one per subnet, the task ran normally with a high success percentage.  Narrowing this down further, I ran the task again on the failed machines with the original delivery method but disabled the limit remote downloads, I didn't get those failures.  Is this the way this setting works?  I thought it would just cause one machine to grab the package and cause the others to wait, not fail.  Any thoughts?

        • 1. Re: Limit Remote Downloads To One At A Time Failing
          Jared Barneck SupportEmployee

          I have seen sometimes where that setting has caused this.

           

          What version is your Core?
          What version are your agents?

          Specifically what version of sdclient.exe and lddwnld.dll are on your agents?

          • 2. Re: Limit Remote Downloads To One At A Time Failing
            jmanijak Rookie

            We are supposed to be on SP2a on both our core and clients.  I looked at one machine I'm testing with.  The version of sdclient.exe is 8.80.1.12 and the version of lddwnld.dll is 8.80.2.13

            • 3. Re: Limit Remote Downloads To One At A Time Failing
              Jared Barneck SupportEmployee

              The SDClient.exe is the correct SP2 version

              The LDDwnld.dll file is newer, must have come from a Post SP2 patch.

               

              Sounds like a bug in lddwnld.dll or maybe in the TMC service where the client is trying to get a file from a peer but for some reason it is crashing.

               

              Do you have a support ticket on this?  This might have to come to support.

              • 4. Re: Limit Remote Downloads To One At A Time Failing
                jmanijak Rookie

                I do have a ticket opened.  They let me know today that SP3 has been released a couple days ago and applying this to our core and clients would be the first step into troubleshooting this issue.  I think that is a lot of work to just find out after the fact it didn't solve the issue.  Our server admin is out until 5/18 and I was hoping there would be another solution to try.

                • 5. Re: Limit Remote Downloads To One At A Time Failing
                  Jared Barneck SupportEmployee

                  That is not normally the default procedure.  We don't just blatantly say that for all issues.

                   

                  I think that in this instance there is some significant development work in SP3 around improving behinds the scenes peer download technology.  So they are not giving you a quick answer to close your case or anything, in your case with your issue, it really is something that has a high probability of resolving the situation.

                   

                  But again, despite the work, you are correct in that there is a chance the issue may still exist after installing SP3.

                   

                  Buy the way, I did a pilot on SP3 with a customer in Chicago and it went really smooth for us.  Took 30 minutes from when we clicked Setup.exe until it was done.

                   

                  So lets look at your options:

                   

                  1. Troubleshoot at the current version and root cause the issue in 8.8 SP2.  You could turn on xtrace of sdclient, lddwnld, and tmcclient and tmcservice and try to get more debugging. Issues like this can be time consuming and some of the more difficult to find the issue as so many pieces are involved: Core, Client and their processes such sdclient, lddwnld, tmc, peers and their processes and many steps happen on the network and on different machines.

                  - If you find it is a configuraton issue, you make whatever change and go on.

                   

                  - However, you may find that it is a bug you are encountering that most environments don't see, and in order to submit a CR, it would need to duplicate in SP3.  So you have to install SP3 to move on.  If SP3 fixes the issue, then the troubleshooting would feel like a wast of time.

                   

                  2. You could go ahead and install SP3.

                  - However, if you install SP3 and it doesn't fix it, you may feel like the time to install SP3 was a waste (though at least you got your box patched out of it) and then you will have to start troubleshooting with xtrace until you figure it out.

                  - If it is not a configuration issue, you submit a bug and wait for a patch, that will require SP3 be installed.

                   

                  3. Or you can live with the issue for now.

                  - So Limit remote downloads to one device at a time is a key feature but not exactly required. You can simulate this using two tasks by deploying a task to a single machine per subnet and once finished, deploy a task with a peer download only delivery method afterwards.

                   

                  You should discuss these options with your support engineer.