1 2 Previous Next 25 Replies Latest reply on Mar 28, 2011 2:51 AM by alps

    PE 3.0 - Option 60 is missing

    tsauter Apprentice
      Hallo,

      ich versuche gerade Windows 7 zu deployen und hab zu diesem Zweck ein frische Win PE 3.0 erzeugt. Das ganze bootet auch über das Netzwerk im enteo Client (6.02.002.3035) erhalte ich aber die Fehlermeldung:

      receive BOOTP answer
      Option 60 is missing - Ignoring this Server
      receivcd Option 54: Server Address is x.x.x.x


      Das alte Windows PE 2.0 (für XP) funktioniert aber tadelos.

      Jemand eine Idee woran das liegt? Ich vermute mal am PE.
      Im PE selber (mit Debug-Option) habe ich Netzwerk und IP-Adresse.

      Ich habe schon mal die Option 60 in unseren DHCP-Server eingetragen. Aber das bringt auch nichts.

      Umgebung: DHCP-Server Linux (ISC 4.1), enteo Server Windows 2003

      Vielen Dank für die Hilfe.

      Thorsten
        • 1. Re: PE 3.0 - Option 60 is missing
          Markus.Zierer Expert
          Wenn mich nicht alles täuscht, ist das ein DHCP Problem und kein Enteo Problem. Es wird schlichtweg nicht der korrekte Boot Server an den PXE Client zurückgemeldet. Und daher kann das PE Image dann auch nicht geladen werden.
          • 2. Re: PE 3.0 - Option 60 is missing
            tsauter Apprentice
            So sieht es aus. Aber wird nicht der DHCP-Server mit den Optionen des PXE-Proxies überschrieben? (z.B. Boot-Server, Downloadfile, ...). Mit dem alten PE funktioniert es zumdinest einwandfrei.

            Der DHCP-Server liefert nur IP, Subnet und Gatway.
            • 3. Re: PE 3.0 - Option 60 is missing
              _Mel_ Master
              wie sieht denn die umgebung aus ? läuft der osdproxy auf dem dhcpserver ? bekommt der client noch andere antworten als die oben genannte ? ist das eine "normale" konfiguration oder eine, bei der der bootserver auf dem dhcpserver hart eingetragen ist ?

              die enteo osd clients in pe 2.0 und pe 3.0 sind übrigens dieselben, wenn die also zu unterschiedlichen ergebnissen kommen, dann würde ich vermuten, daß sich da das netzwerk von windows PE unterschiedlich verhält... mein verdacht ist, daß in der dhcp/pxe konfiguration was nicht stimmt und das bei PE 2.0 zufällig nichts ausgemacht hat.
              • 4. Re: PE 3.0 - Option 60 is missing
                Markus.Zierer Expert
                Hallo,

                langsam. Reden wir hier von einem PXE Bootproblem, oder von einem Problem mit dem PE Image.

                Sollte es der Fall sein, dass das PXE schon gar nicht booten kann, ist es ein Infrastrukturproblem. Soweit ich weis, sollte der DHCP Server BootP Anfragen automatisch an den OSDProxy weiterleiten. Normalerweise tut er das auch, sofern das Netzwerktechnisch alles stimmt. Da ich von Netzwerken relativ wenig Ahnung hab, kann ich nur sagen Du solltest die Netzwerksettings mal prüfen.

                Und falls das PE Image zwar geladen wird, bei der Abarbeitung dann aber nicht weitermacht, versteh ich die Fehlermeldung nicht. Das müsste eigentlich ne PXE Meldung sein. Und zu dem Zeitpunkt, wo die Auftritt, ist PE noch gar nicht geladen.
                • 5. Re: PE 3.0 - Option 60 is missing
                  _Mel_ Master
                  die meldung kommt vom enteo client innerhalb des bootenvironments, der versucht seinen osdproxy zu finden.

                  d.h. netzwerkboot war erfolgreich und das PE hat gestartet.

                  ok, ganz übersehen - wenn der dhcp-server ein linuxrechner ist, dann erübrigt sich die frage, ob der osdproxy auf dem dhcpserver läuft.

                  am besten erstmal das osdpxe logfile checken, ob der pxedienst die url vom osdproxy webservice an den client rausschickt. (und falls das logfile zufällig riesig sein sollte und ständig truncated wird, einfach mal löschen, das kann ne menge performance kosten und zu timeouts führen)
                  • 6. Re: PE 3.0 - Option 60 is missing
                    tsauter Apprentice
                    Hallo,

                    vielen Dank für die Antworten.

                    Die Proxy läuft nicht auf dem gleichen Server. Da es ein Linux DHCP-Server ist.

                    Der Client bootet über das Netzwerk und erhält vom DHCP-Server ein IP/Subnet/GW und vom enteo Proxy die Optionen für den TFTP-Boot. Danach bootet er das Boot Environment für das benötigte Pre-OS-Action-Pack. Dies funtkioniert sowohl mit dem Boot Environment PE 2.0 als auch mit dem neuen PE 3.0 (64bit).
                    Danach startet der enteo Windows PE Client und kontaktiert den OSD Proxy.

                    Bei dem alten PE-2.0 Boot Environment findert er den Proxy, läd die Treiber und installiert Windows.
                    Beim neuen kommt oben genannte Fehlermeldung. Er versucht es 5 mal und gibt dann auf.

                    Ich denke eher nicht, dass es sich um ein Netzwerk-Problem handelt, da es immer die selbe Client-Machine ist. Und ich soeben 4 neue Laptops (mit altem PE) erfolgreich installiert habe. Da gibt es absolut keine Problem. Wechsel ich auf PE 3.0 passiert es.
                    • 7. Re: PE 3.0 - Option 60 is missing
                      Frank.Scholer Master
                      Hallo Thorsten,

                      macht er denn im alten (PE2.0) Bootenvironment überhaupt ein Discovery auf den OSD Proxy oder habt ihr womöglich in der OSDCLNT.INI eine URL eingetragen, unter der er den OSD Proxy findet (weil dann sucht der WinPE Binary Client garnicht danach)... vielleicht hat das auch mal ein Consultant für euch gemacht in der Einführungsphase und es wurde vergessen zu dokumentieren o.ä.

                      Du findest die Datei im Paketverzeichnis des Bootenvironments (wird dann aber natürlich ins WIM reinkompiliert...)

                      HTH, Gruß Frank
                      • 8. Re: PE 3.0 - Option 60 is missing
                        SBRUTSCH Expert


                        Ich habe schon mal die Option 60 in unseren DHCP-Server eingetragen. Aber das bringt auch nichts.

                        Umgebung: DHCP-Server Linux (ISC 4.1), enteo Server Windows 2003

                        Vielen Dank für die Hilfe.

                        Thorsten



                        Hi,

                        wir reden doch hier vom OSD V6. Hier sollten eigentlich gar keine Boot Optionen im DHCP Server eingerichtet sein. Also wenn ihr auch noch die Boot Optionen vom alten OSD drin habt bitte komplett raus nehmen.

                        Das wären die Optionen 43, 60, 128 und 129.

                        Dann sollte es gehen. Die Optionen gibt jetzt der OSD PXE Proxie mit ins Netz und werden somit nicht mehr vom DHCP Server benötigt.

                        Gruß
                        Stefan
                        • 9. Re: PE 3.0 - Option 60 is missing
                          tsauter Apprentice
                          Hallo,


                          macht er denn im alten (PE2.0) Bootenvironment überhaupt ein Discovery auf den OSD Proxy oder habt ihr womöglich in der OSDCLNT.INI eine URL eingetragen, unter der er den OSD Proxy findet (weil dann sucht der WinPE Binary Client garnicht danach)... vielleicht hat das auch mal ein Consultant für euch gemacht in der Einführungsphase und es wurde vergessen zu dokumentieren o.ä.



                          vielen Dank für den Tip. Bei uns war nie ein Consultant und ich habe dort auch nichts eingetragen.

                          Der Eintrag WebURL ist auskommentiert. Ich denke dieser ist gemeint.

                          Aber vielleicht kann ich dort den Pfad mal hart setzten?


                          Thorsten
                          • 10. Re: PE 3.0 - Option 60 is missing
                            tsauter Apprentice
                            Hi,


                            wir reden doch hier vom OSD V6. Hier sollten eigentlich gar keine Boot Optionen im DHCP Server eingerichtet sein. Also wenn ihr auch noch die Boot Optionen vom alten OSD drin habt bitte komplett raus nehmen.

                            Das wären die Optionen 43, 60, 128 und 129.



                            ja, die Version ist v6.2.
                            Im DHCP-Server sind keine Boot-Optionen mehr gesetzt, und waren eigentlich auch nie. Es war nur ein Test.


                            Bye
                            Thorsten
                            • 11. Re: PE 3.0 - Option 60 is missing
                              SBRUTSCH Expert

                              Hi,

                              ja, die Version ist v6.2.
                              Im DHCP-Server sind keine Boot-Optionen mehr gesetzt, und waren eigentlich auch nie. Es war nur ein Test.


                              Bye
                              Thorsten



                              Und sonst auch von keinem anderen Tool? RIS braucht z.B. auch den Eintrag 66. Der könnte hier dann auch stören.

                              Ansonsten wie schon die Vorredner geschrieben haben müssen wir hier die Logs durchsuchen. Du findest die auf dem Server wo der OSD bzw. PXE Proxy installiert ist.

                              Gruß
                              Stefan
                              • 12. Re: PE 3.0 - Option 60 is missing
                                tsauter Apprentice
                                wo finde ich das Logfile? Bzw. in welchem Logfile müsste ich nachschauen?
                                • 13. Re: PE 3.0 - Option 60 is missing
                                  SBRUTSCH Expert

                                  wo finde ich das Logfile? Bzw. in welchem Logfile müsste ich nachschauen?




                                  Wie immer so auch auf den Server:
                                  %CommonFiles%\Enteo\Nilogs

                                  Also z.B. beim 32-Bit deutschem System
                                  C:\Programme\Gemeinsame Dateien\Enteo\Nilogs

                                  Logfiles für OSD fangen mit OSD an. Hier kannst du mal schauen ob der Client überhaupt ankommt. Momentan habe ich den Verdacht das bei eurem Netz irgend ein Routing vielleicht nicht funktioniert. Bei PE 3.0 hat sich ja der Netzwerkstack verändert.

                                  Gruß
                                  Stefan
                                  • 14. Re: PE 3.0 - Option 60 is missing
                                    _Mel_ Master
                                    in einem osdpxe* logfile müßte eine zeile auftauchen die so aussieht:
                                    URL for client of the SOAP WebInterface is

                                    wenn die nicht auftaucht, dann kommt die anfrage garnicht erst beim PXEdienst an, wenn sie da ist, dann geht vermutlich die antwort verloren.
                                    1 2 Previous Next