11 Replies Latest reply on Jan 26, 2012 2:51 AM by simon.wagner@ortenaukreis

    [SOLVED] Lotus Notes 8.5.3

    simon.wagner@ortenaukreis Rookie
      Hi zusammen,

      ich wollte mal fragen schon jemand die Notes Version 8.5.3 für Windows 7 paketiert hat.
      Ich habe da ein etwas ärgerliches Problem.

      Nachdem ich hier alle Forenthemen zu 8.5.x und zu Notes gelesen hatte, habe ich folgende Varianten ausprobiert.

      Installation über:

      1. Setup.exe /S /V"TRANSFORMS=Transform.mst" /V/qb+
      2. MSIInstallProduct mit Transform
      3. MSI-Paket mit Transform
      4. MSI-Aufruf mit Parametern über execute

      Die Installation scheint auch zuerst sauber zu funktionieren.
      Leider bleibt die MSI aber kurz vor Ende stecken und ich bekomme folgende
      Meldung auf den Bildschirm:

      [ATTACH]641[/ATTACH]

      Falls ich die Meldung anzeigen lasse wird nur ein schwarzer Bildschirm angezeigt.

      Weiterhin löst die nsd.exe folgenden Fehler im Anwendungsprotokoll aus:

      "
      Name der fehlerhaften Anwendung: nsd.exe, Version: 8.5.30.11258, Zeitstempel: 0x4e72f724
      Name des fehlerhaften Moduls: nsd.exe, Version: 8.5.30.11258, Zeitstempel: 0x4e72f724
      Ausnahmecode: 0xc0000005
      Fehleroffset: 0x0005e6f4
      ID des fehlerhaften Prozesses: 0xd90
      Startzeit der fehlerhaften Anwendung: 0x01ccdb38c257855e
      Pfad der fehlerhaften Anwendung: C:\Programme\Lotus\Notes
      sd.exe
      Pfad des fehlerhaften Moduls: C:\Programme\Lotus\Notes
      sd.exe
      Berichtskennung: 0008d2fe-472c-11e1-b55d-180373e10dae
      "

      Weiterhin fordert die Visual C++ Runtime Libary mein Eingreifen (laut Anwendungsprotokoll)

      Wenn die Execute-Befehler am Rechner direkt über "Ausführen" eingegeben werden, funktioniert die Installation fehlerfrei, silent und ohne jede Rückmeldung des Installers.


      Hat irgendjemand ähnliche Probleme oder noch besser Lösungen ;-)

      Vielen Dank schonmal
        • 1. Re: [SOLVED] Lotus Notes 8.5.3
          Markus.Zierer Expert
          Hm, mit Notes an Sich hatte ich schon ewig nichts mehr zu tun, daher kann ich keine Spezielle Lösung hierfür anbieten.

          Der Screenshot sieht für mich aber eher danach aus, als ob es hier ein Problem mit einem sog. MergeModule gibt. So werden die Prerequesites bei MSI bezeichnet. Ich vermute mal, das Notes versucht, irgend eine VC++ Runtime zu installieren, die sich nicht sauber mit dem System verträgt. Das sollte zwar eigentlich nicht vorkommen, ich hab aber schon zuviel Merkwürdiges gesehen, um das von Vorneherein ausschließen zu können.

          Mach mal Folgendes:

          Mach einfach mal einen Spy der Notes Installation. Bei der Aufzeichnung müsste er Dich dann darauf hinweisen, dass er 1 bzw. mehrere MSI Installationen gefunden hat und Dich fragen, ob Du wirklich weitermachen willst. Schreib Dir hier die MSIs ab, die Notes zusätzlich installieren will und erstelle für diese eigene Pakete. Wenn Du diese Pakete dann Vor der Notes Installation auf das System installierst, sollte Notes das erkennen und seine eigenen MergeModules nicht installieren.

          Das könnte eine Lösung für dein Problem sein. Probier das mal aus.

          Wenn Du ein W7 x64 benutzt, könnte es aber auch der Fall sein, dass Du für Notes einen sog. Shim benötigst. Die Shims sind eine Methode von MS, um die Kompatibilität von x86 SW auf x64 Systemen zu verbessern. Einfach mal danach Googeln.
          • 2. Re: [SOLVED] Lotus Notes 8.5.3
            NicoS1 Master
            Hallo Simon,

            wir damals auch Probleme mit der 8.5er Notes Installation, wenn man sie als "per Service" ausführen wollte.

            Versuch mal bitte folgendes:
            "RunAs" Befehl, mit der setupexe und entsprechenden Parametern.(Achtung, hier die Parameter in das 2. Textfeld eintragen, nicht wie mein Execute einfach hinten dran).
            Dann noch angeben, dass der den Account des Runtime Services nehmen soll, Anmelden MIT Profil, warten auf ausführen und bei der maximalen Wartezeit circa 60-90 Minuten. Wir hatten erst 60 drin, aber bei manchen Rechnern irgendwie war das zu wenig.

            Wenn du den Befehl fertig hast, dann nur Maschinenbezogen flaggen, NICHT Maschinenbezogen als Service.

            Und dann noch in den Ausführungseigeneschaften mit "Nur wenn Benutzer angemeldet ist" einstellen, damit das Paket nicht vom Serviceinstaller installiert werden kann, sondern nur vom Autoinstaller.

            Gruß
            • 3. Re: [SOLVED] Lotus Notes 8.5.3
              simon.wagner@ortenaukreis Rookie
              Hi,

              danke schonmal für die schnellen Antworten.
              Ich habe auch schon die Tipps von Markus probiert,
              leider hilft der Spy aber nicht wirklich weiter.
              Er registriert nur die Installation der Notes8.5.3.msi sonst nichts.


              Ich werde mich jetzt auch gleich daran machen mal zu testen
              wie es mit der Lösung von Nico steht.

              Melde mich dann später nochmal

              Vielen Dank auf jeden fall
              • 4. Re: [SOLVED] Lotus Notes 8.5.3
                simon.wagner@ortenaukreis Rookie
                Also ich habe das mal so getestet, leider ist das Problem immernoch das gleiche.
                • 5. Re: [SOLVED] Lotus Notes 8.5.3
                  Markus.Zierer Expert
                  Also das Problem wird ja durch eine VC++ Runtime verursacht. Das grenzt den Kreis der Verdächtigen schonmal deutlich ein. Ich würde mir mal Pakete für die Runtimes 2005SP1, 2008SP1 und 2010 erstellen und die mal vor der notes installation auf das System nageln. Das sind eigentlich die aktuellsten im Moment. Wenn's dann immer noch Stress gibt, weis ich jetzt erstmal auch nicht weiter.
                  • 6. Re: [SOLVED] Lotus Notes 8.5.3
                    simon.wagner@ortenaukreis Rookie
                    Habe ich gerade versucht.
                    Problem bleibt bestehen.
                    • 7. Re: [SOLVED] Lotus Notes 8.5.3
                      Markus.Zierer Expert
                      Ach, jetzt hab ich erst gesehen was genau das für ne Fehlermeldung ist. Das ist ja der Hinweis, dass ein Meldungsfenster in einem anderen Userkontext angezeigt werden soll. Hast Du da mal auf "Meldung anzeigen" geklickt ? Was passiert denn dann ?

                      Also so wie ich das sehe, wäre das ein Fall für den IBM Support. Die müssten eigentlich wissen wodurch das Problem verursacht ist. Und wenn Du die Ursache kennst, dann können wir uns nochmal Gedanken zur Beseitigung dieser machen. Tut mir leid, aber mehr fällt mir jetzt gerade auch nicht dazu ein.
                      • 8. Re: [SOLVED] Lotus Notes 8.5.3
                        simon.wagner@ortenaukreis Rookie
                        Also wie oben schon geschrieben kommt bei Meldung anzeigen nur ein schwarzes Fenster ohne zusätzliche Info.
                        Ich kann dann lediglich wieder zum Desktop zurück.

                        Vielen Dank auf jeden fall schonmal für die Ideen.
                        • 9. Re: [SOLVED] Lotus Notes 8.5.3
                          asch68 Expert
                          Hallo,

                          ich habe hier Notes als MSI Paket angelegt, kann es auch ohne weitere Probleme installieren.
                          Ist aber noch die Version 8.5.2 Basic....

                          Ich passe auch nur die Option gleichzeitige Anmeldung an, mehr eigentlich nicht.

                          Es läuft bei mir unter XP und 7, egal ob 32 oder 64 bit...

                          Gruß
                          Andreas
                          • 10. Re: [SOLVED] Lotus Notes 8.5.3
                            NicoS1 Master
                            Wenn du das Paket so gebaut hast, wie ich geschrieben habe, dann dürfte die Meldung, dass ein Dienst eine Meldung anzeigen will gar nicht kommtn.

                            Bitte Kontrollieren:
                            1. RunAs verwendet, nicht Execute
                            2. RunAas als Computerbezogen geflaggt, nicht als Computerbezogen als Service!
                            3. Paket mit Autoinstaller ausgeführt, nicht mit ServiceInstaller.

                            Wenn du dann Trotzdem noch die Anzeige erhälst, dass ein Service versucht eine Meldung anzuzeigen, bin ich erstmal verwirrt ;-)

                            P.S.: Hier nochmal zum Vergleich unsere Installation

                            RunAs('.\Extern$\Msidata\setup.exe','/s /v"SETMULTIUSER=1  /qn"','','','30',raUseSisAccount+WaitForExecution+UndoneContinueParentScript)/TW

                            • 11. Re: [SOLVED] Lotus Notes 8.5.3
                              simon.wagner@ortenaukreis Rookie
                              Also noch einmal vielen Dank an alle,
                              ich habs jetzt hinbekommen, war wirklich nur möglich über den Autoinstaller.

                              Vielen Dank nochmal