1 2 Previous Next 15 Replies Latest reply on Apr 13, 2012 4:09 AM by sbudget

    [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout

    sbudget Apprentice
      Hallo Community,

      ich habe folgendes Problem:
      Und zwar schaffe ich es nicht, einen Windows Server 2008 R2 x64 als Terminalserver aufzusetzen. Er kommt bis zur Installation der Roles, dabei stimmt aber was nicht und er macht einfach weiter. Ich bekomme unter der eMMC dann bei "Assigned Software" beim "Post OS Action Package" die Meldung: "[ClientProxy] Could not resolve all variables."

      Verwendete Pakete:
      Pre OS Action Package Partitioning and Formatting (Version 7.0.2.1535)
      41_Windows Server 2008 R2 Member (Version 7.0.2.1535) OS Config Package
      Post OS Action Package Server 2008 Full UI (Version 7.0.2.1535)
      Default Post OS Action Package (Version 7.0.2.1535)

      Meine Frage:
      Was muss im "Post OS Action Package Server 2008 Full UI" verändert werden, damit die Installation der Roles und Features funktioniert?

      ServerRolesPOSAP.log :
      Mon 03/05/2012 14:25:26.12 Installing Server Roles...
      Mon 03/05/2012 14:25:26.12 Application-Server enabled, installing...
      Mon 03/05/2012 14:25:26.12 Installing Application-Server with all SubFeatures ...
      Mon 03/05/2012 14:26:26.00 Installation finished with return code: 0
      Mon 03/05/2012 14:26:26.00 Installing RDS-RD-Server ...
      Mon 03/05/2012 14:26:29.96 Installation finished with return code: 3010
      Mon 03/05/2012 14:26:29.96 Role installation requires a reboot...
      Mon 03/05/2012 14:27:08.22 Installing Server Roles...
      Mon 03/05/2012 14:27:08.22 Application-Server enabled, installing...
      Mon 03/05/2012 14:27:08.22 Installing Application-Server with all SubFeatures ...
      Mon 03/05/2012 14:27:12.69 Installation finished with return code: 1003
      Mon 03/05/2012 14:27:12.70 Role/Feature is already installed...
      Mon 03/05/2012 14:27:12.70 Installing RDS-RD-Server ...
      Mon 03/05/2012 14:27:13.61 Installation finished with return code: 1003
      Mon 03/05/2012 14:27:13.61 Role/Feature is already installed...
      Mon 03/05/2012 14:27:13.61 Installing Server Role finished...
      Mon 03/05/2012 14:27:13.61 Action finished...


      PS: Die Optionen in der Site-Config bzgl. WTS wurden gesetzt und als zu installierende Roles wurde Application Server und Terminalserver gewählt.

      Ich hoffe, einer von euch hatte sowas schonmal.

      Schöne Grüße
      sbudget
        • 1. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
          Markus.Zierer Expert

          Meine Frage:
          Was muss im "Post OS Action Package Server 2008 Full UI" verändert werden, damit die Installation der Roles und Features funktioniert?



          Wieso ? Funktioniert doch

          ServerRolesPOSAP.log :
          Mon 03/05/2012 14:25:26.12 Installing Server Roles...
          Mon 03/05/2012 14:25:26.12 Application-Server enabled, installing...
          Mon 03/05/2012 14:25:26.12 Installing Application-Server with all SubFeatures ...
          Mon 03/05/2012 14:26:26.00 Installation finished with return code: 0
          Mon 03/05/2012 14:26:26.00 Installing RDS-RD-Server ...
          Mon 03/05/2012 14:26:29.96 Installation finished with return code: 3010
          Mon 03/05/2012 14:26:29.96 Role installation requires a reboot...
          Mon 03/05/2012 14:27:08.22 Installing Server Roles...
          Mon 03/05/2012 14:27:08.22 Application-Server enabled, installing...
          Mon 03/05/2012 14:27:08.22 Installing Application-Server with all SubFeatures ...
          Mon 03/05/2012 14:27:12.69 Installation finished with return code: 1003
          Mon 03/05/2012 14:27:12.70 Role/Feature is already installed...
          Mon 03/05/2012 14:27:12.70 Installing RDS-RD-Server ...
          Mon 03/05/2012 14:27:13.61 Installation finished with return code: 1003
          Mon 03/05/2012 14:27:13.61 Role/Feature is already installed...
          Mon 03/05/2012 14:27:13.61 Installing Server Role finished...
          Mon 03/05/2012 14:27:13.61 Action finished...



          Installation vom Application Server war Erfolgreich, ReturnCode 0. Installation vom RDS-RD Server ebenso, ReturnCode 3010. Der ReturnCode bedeutet allerdings, dass ein Neustart benötigt wird um die Installation abzuschliessen. Und da ein TS etwas anders konfiguriert ist, wie ein normaler Server, wird dies beim nächsten Neustart ausgeführt.

          Deine weiteren Installationsversuche, sind dann Erfolglos gewesen, ReturnCode 1003. Dieser ReturnCode besagt, es ist keine Änderung notwendig, daher wird der Servermanager wieder beendet.

          Das PostOS Package verwendet an dieser Stelle auch nur die Servermanagercmd.exe vom Windows Server. Da die Funktionen an dieser Stelle doch recht allgemein sind, würde ich mir an deiner Stelle überlegen, ob ich mir nicht ein eigenes eScript bastele, welches mir über die ServermanagerCmd.exe den bzw. die Server so konfiguriert wie ich's wirklich brauche. Denn das Ziel sollte es ja sein, dass ich möglichst wenig Nacharbeit habe, nachdem ich den Server mit der DSM deployed hab.
          • 2. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
            sbudget Apprentice
            Hab das PostOS Package umgeschrieben und jetzt funktionierts.
            Dazu musste ich die Zeile mit dem Ping im Boot_Delay löschen.

            Das Rollout läuft super, bis auf die Meldung "Could not resolve all variables".
            Die stört mich zwar nicht wirklich, aber wenn jemand einen Vorschlag hat, wie man die wegbekommt, wäre ich dankbar.

            sbudget
            • 3. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
              Frank.Scholer Master
              Hallo sbudget,

              ersetze im OS Config Package und in den Post OS Action Package bei allen Umgebungsvariablen die einfachen %-Zeichen durch doppelte, dann ist die Meldung weg...

              HTH, Grüße Frank
              • 4. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
                _Mel_ Master
                in zeile 68 muß es %%Feature%% anstatt %Feature% heißen.
                bei den installationparameter.* sind die einzelnen % korrekt.
                • 5. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
                  Frank.Scholer Master
                  Oh stimmt, hatte garnicht gelesen, dass er schon die ganzen neuen Pakete (1535er) verwendet...
                  • 6. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
                    sbudget Apprentice
                    Danke für den Tipp mit den %-Zeichen. Hab das so geändert und damit die Fehlermeldung bzw. den Fehler behoben.

                    Schöne Grüße
                    sbudget
                    • 7. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
                      sbudget Apprentice
                      Ich hätte da noch eine Frage:

                      Beim Bau eines "OS Installation Set" habe ich im Fenster "Choose Operating System Flavor" bei Auswahl eines Windows Server 2008 R2 (x64) nur die Möglichkeiten die Enterprise oder Standard Edition auszuwählen.
                      Ich würde aber die Datacenter Edition benötigen.

                      Ist das in Zukunft mal möglich, oder wird das voraussichtlich so bleiben?

                      Grüße
                      sbudget
                      • 8. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
                        _Mel_ Master
                        das kommt an der stelle darauf an für welche flavors templates im system sind.
                        einfach das vorhandene template kopieren, die kopie für das zusätzliche flavor zulassen und dann sollte es gehen.
                        • 9. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
                          sbudget Apprentice
                          Hat super funktioniert, dankeschön.
                          • 10. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
                            sbudget Apprentice
                            Und die nächste Frage:

                            An was kann das liegen, das das Extended Reporting am Client und am Server nicht ordentlich funktioniert?

                            In der Logdatei "ExRSend_OBAThread_SYSTEM_0000000002.log" bekomme ich immer:

                            E Warning (Module:ExRSend.exe, Severity:0x03): FPS.dll  Failed to get file info about 'Exr.{56c74a85-ef29-4772-ba4b-d19494893eff}.Lck'.
                            The system cannot find the file specified.

                            Am DSM-Server befinden sich im Ordner InboxAgent-->Inbox die Dateien: NCP.xml,  NCP_SmiAA.xml, properties.dav und Exr.{73349da0-9b41-4280-84f0-39910146a4f2}.Lck.

                            Hab im Forum schon ewig gesucht, aber keine passende Lösung gefunden.

                            sbudget
                            • 11. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
                              sbudget Apprentice
                              zusätzliche Info:

                              Am Server im Logfile ExrDbAgnThread_SYSTEM_00000000152.log :

                              13:32.12.219  E Warning (Module:mgmtagnt.exe, Severity:0x03): exrmaext.dll  SQL statement failed
                              String length of statement: 109
                              Statement:
                              INSERT INTO tblEventLogHist SELECT * FROM tblEventLog WHERE iEventLogID >= 00000000000 AND WorkstationOID = ?
                              Error 80040e2f not found, reason: 00000002
                              13:32.12.219  2 exrmaext.dll  SQL Err(0): The statement has been terminated., Src: Microsoft OLE DB Provider for SQL Server
                              13:32.12.219  2 exrmaext.dll  SQL Err(1): Violation of PRIMARY KEY constraint 'PK_tblEventLogHist'. Cannot insert duplicate key in object 'dbo.tblEventLogHist'. The duplicate key value is (354528ea-4cdf-4c1b-b9b1-a222ef55e207, 0)., Src: Microsoft OLE DB Provider for SQL Server
                              13:32.12.219  2 exrmaext.dll  SQL error: INSERT INTO tblEventLogHist SELECT * FROM tblEventLog WHERE iEventLogID >= 00000000000 AND WorkstationOID = ?
                              13:32.12.219  2 exrmaext.dll  SQL-Command failed: INSERT INTO tblEventLogHist SELECT * FROM tblEventLog WHERE iEventLogID >= 00000000000 AND WorkstationOID = ?
                              • 12. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
                                Frank.Scholer Master
                                Wie kommst du denn darauf, dass "Extended Reporting am Client und am Server nicht ordentlich funktioniert"? Machst du das nur an irgendwelchen Einträgen in den Logfiles fest oder fehlen dir im ExR Daten?

                                Weil, es gibt recht häufig Einträge in den Logs die wie Fehler aussehen, in Wirklichkeit aber garkeine sind. Alleine darauf solltest du dich nicht verlassen...

                                HTH, Gruß Frank
                                • 13. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
                                  sbudget Apprentice
                                  Hallo Frank,

                                  mit nicht ordentlich meine ich, dass er mir zwar bei Softwarepaketen wie z.B. 7zip den Rollout-Status im Reporting anzeigt, aber beim OSD nicht, obwohl bei beiden Paketen unter "Entry in Extended Reporting" "On error and success" eingetragen ist.

                                  Kannst du mir da vielleicht weiterhelfen?

                                  sbudget
                                  • 14. Re: [SOLVED] Suche Hilfe bei Windows Server 2008 R2 x64 Rollout
                                    Frank.Scholer Master
                                    Hi sbudget,

                                    dass OSD-Pakete im Extended Reporting angezeigt werden, wäre mir neu... da ist ja noch garkein DSM-Client vorhanden, der mit dem ExR-Server kommunizieren will. Wenn dir nur die OSD-Pakete fehlen und Rest funktioniert, dann hast du kein Problem (behaupte ich mal ;-)

                                    Grüße Frank
                                    1 2 Previous Next