5 Replies Latest reply on Jul 2, 2012 3:05 AM by tphilipp

    Remove Icon

    Specialist
      Hallo Zusammen,

      irgendwie stehe ich gerade voll auf dem Schlauch, dabei möchte ich doch nur ein Icon im "Öffentlichen Desktop" entfernen

      Ist das so schwer??
      Oder hab ich nur einen Denkfehler

      Wäre nett wenn einer mir auf's Pferd helfen könnte
        • 1. Re: Remove Icon
          NicoS1 Master
          1. Frage: Ist der Befehl auch per Service geflaggt?
          2. Frage: Hast du den "Users" Ordner per unattend.xml zufällig auf ne andere Parition verschoben?
          Falls ja: http://www.fake-wings.de/itblog/?p=11
          • 2. Re: Remove Icon
            CalumField1 Expert
            Tagchen,

            Wenn du eine Fehler bekommst (exitproc) bitte melden mit entsprechende Log an unsere Service Center.

            Sonst wäre ein Log hilfreich.
            • 3. Re: Remove Icon
              NVUser Specialist
              Bei win7 muß Du per Service flaggen, da Normalo im AllUsers keine Ändern-Rechte mehr hat. Und der Link Name muß natürlich exakt passen (Leerzeichen etc)...

              Grüße,
              Torsten
              • 4. Re: Remove Icon
                Andree Apprentice
                vielleicht keine LNK Dateiendung???

                Wie wäre es mit "Delete File"
                • 5. Re: Remove Icon
                  tphilipp Apprentice
                  [email protected],

                  habe das selbe Problem, sowohl für Folder, Icons als auch Verknüpfungen.

                  - als Service geflaggt
                  - AllUser gesetzt
                  - Name 1:1 i.O.

                  Wenn ich RemoveLink benutze steht im Log folgendes:


                  10:19:00.275 2 -> RemoveLink('HP Operations Manager for UNIX','','C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Java Console Plugin',cgAsCommon)

                  10:19:00.283 2 -> RemoveLink('HP Operations Manager for UNIX','','C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Java Console',cgAsCommon)



                  Fehler werden keine ausgeworfen. Ich probier das jetzt noch mit DeleteFile allerdings sollte RemoveLink doch auch klappen.

                  Gruß


                  EDIT:

                  Ursache -> Timingproblem

                  Für die DSM war der Prozess bereits beendet und damit alles i.O. nur waren die Verknüpfungen noch nicht erzeugt und konnten somit auch nicht entfernt werden.

                  Lösung: via Setup Parameter auf Beenden von Child Prozessen warten oder über eine WMI Abfrage den Prozess abfragen der die Verknüpfungen erzeugt.