5 Replies Latest reply on Mar 23, 2012 3:29 AM by mwill

    Installatio secondary BLS

    mwill Apprentice
      Moin,

      ich stehe vorm Berg und weiß nicht weiter. Ich versuche gerade, einen secondary BLS zu installieren. Also Server 2008 R2, IIS Rolle und dann in die Infrastruktur und als Management Point hinzufügen. Installationsvoraussetzungen werden geprüft - alles in Ordnung.


      Der Installer läuft los und meldet dann ziemlich sofort:

      Fehler beim Hinzufügen des Benutzers '%s' zur Datenbank-Rolle 'db_owner'


      Was genau mache ich falsch?


      Gruß,
      Matthias
        • 1. Re: Installatio secondary BLS
          Markus.Zierer Expert
          Das Problem hatte ich kürzlich auch. Wenn ich mich richtig erinner, lag es daran, dass auf dem SQL Server keine Mixed Mode Authentifizierung aktiviert war, nur die Windows Authentifizierung.

          Das wäre aber eigentlich ziemlich Unlogisch, da Du nur einen SQL Server brauchst. Falls Du also versuchen solltest, bei der Installation einen zweiten SQL Server anzugeben, wird das nicht funktionieren. Du musst hier den SQL Server angeben, welcher auch im Primary BLS hinterlegt ist.

          Wenn Du nen BLP (BusinessLogic Proxy) installieren würdest, DANN würdest du einen extra SQL Server für den brauchen. Aber nicht für einen weiteren BLS
          • 2. Re: Installatio secondary BLS
            mwill Apprentice
            Markus,

            danke erstmal, das war's aber nicht, der SQL-Server ist im Mixed mode.

            Nein, ich will keinen zweiten SQL Server installieren oder BLP, ich will schlicht einen zweiten BLS installieren. Geht ja seit der 7er Version. Leider bin ich SQLphob und habe keine genaue Ahnung, was SQL mir sagen will. Ich frage mich, warum will DSM einen User (und welchen bitte?) als db_owner in die Datenbank eintragen? Es müssten doch schon alle User drinstehen.

            In den Logfiles stand nichts genaues, nur dass die BLS Installation jetzt beendet wird. Ach ja, mit dem DSM Infrastruktur User anmelden habe ich es auch probiert, ich bekomme aber die gleiche Fehlermeldung.


            Gruß,
            Matthias
            • 3. Re: Installatio secondary BLS
              axellamparth Apprentice
              Hallo Matthias,

              idealerweise startest Du die BLS Installation auf dem Server, auf dem Du den BLS installieren möchtest.
              Die Installation greift dann remote auf den SQL Server zu, und dies muss in den SQL Einstellungen auch zugelassen sein.

              Ich zumindest hatte diese Meldung gelegentlich in unserer Schulungsumgebung, dort ist der SQL Server auf dem ersten BLS mit installiert.
              Bei mir war in diesem Fall der SQL Server Browser deaktiviert.

              Viele Grüße,
              Axel
              • 4. Re: Installatio secondary BLS
                mwill Apprentice
                Manchmal braucht man einfach den Support...

                1) enteo Konsole mit erhöhten Rechten ausführen, auch wenn die UAC aus ist, weil das ein 2008 R2 ist und die MS des so wollen tut

                2) die enteo Konsole nur vom Master Depot starten, sonst geht das auch nicht

                Und schon tut's. Ich habe zwar noch gefühlte dreißig Fehlermeldungen bekommen, aber nach einem Neustart ging's dann.


                Vielen Dank an alle, die geantwortet haben.


                Gruß,
                Matthias
                • 5. Re: Installatio secondary BLS
                  luckydevil Specialist


                  ...
                  Der Installer läuft los und meldet dann ziemlich sofort:
                  Fehler beim Hinzufügen des Benutzers '%s' zur Datenbank-Rolle 'db_owner'

                  Was genau mache ich falsch?
                  ...



                  Hallo,

                  ... falls der Servername mit einem Zahlzeichen anfängt, läuft vermutlich das DSM-SQL-Script an dieser Stelle nicht richtig.
                  Aktuell auch noch bei DSM 7.2 aufgetreten.
                  Also: Servernamen immer mit einem Buchstaben anfangen lassen.
                  Evtl. wird es ja mal gefixt.

                  Viele Grüße
                  lucky devil