8 Replies Latest reply on Jul 25, 2013 8:57 AM by _Mel_

    Problem bei Prepare Imaging Script

    Dimitrij Apprentice
      Hallo.

      ich hab ein Problem, welches in nicht nachvollziehen kann.
      Wenn ich ein Prepare Imaging Script ausführe und danach Niinst32 /ai auf dem Client ( x32 oder x64 ) bekomme ich folgende Fehlermeldung:

      13:35:02.112 1        Evaluating condition "not _ReturnVar_='0'"
      13:35:02.113 0         Comparing '87' with '0'
      13:35:02.113 2        Condition TRUE  -> entering IF part

      13:35:02.114 2        ->  ExitProcEx(Failed,'Image preparation failed, Returncode=87')
      13:35:02.142 2        New last error from script command is 1627 (0x0000065b)
      13:35:02.143 2        Resolved new last error from script command is: Beim Ausführen der Funktion ist ein Fehler aufgetreten.
      13:35:02.170 2         ER: Creating event manager
      13:35:02.170 1         ER: file name is C:\Program Files (x86)\NetInst\ExR\Event.erl
      13:35:02.170 1         ER: user name is AD Credentials
      13:35:02.171 1        Logging up ExR event 3003 (0x00000bbb)
      13:35:02.171 0        Check if sending data is on: ExrClientOptions.ExrSendingActivated

      13:35:02.171 1        ExR is allowed to send data.
      13:35:02.172 1        Loading SI.dll ...

      13:35:02.189 1        SI: Starting ExRSend.exe ...
      13:35:02.189 2        SI: Rewriting SI client state data...
      13:35:02.189 1         SI: Reading client state...
      13:35:02.204 0         SI: Getting IP addresses...
      13:35:02.205 0         SI: Getting MAC addresses...
      13:35:02.205 1         SI: Writing possible changes of client state..

      und das bekomme ich in DSMC:

      Image preparation failed, Returncode=87 Number of tried ......usw

      hatte jemand von euch schon so ein Problem ?

      P.S. vor ungefähr noch 3 Stunden hat dieser Script noch funktioniert und ich konnte System zurück setzen
        • 1. Re: Problem bei Prepare Imaging Script
          _Mel_ Master
          das müßte der niprep.exe aufruf sein, der da schief geht, oder ?
          die sollte ein logfile schreiben. schau da doch mal nach.
          • 2. Re: Problem bei Prepare Imaging Script
            Dimitrij Apprentice
            Danke Mel, ich werd mal nachschauen.
            Ich hab hier in Forum einen Eintrag von dkoenig gefunden, der empfehlt /includedriver und /includepatche zu deaktivieren. Das hab ich ausprobiert und das hat auch funktioniert. Zwar ist das für mich keine Lösung den die Patche möchte ich schon in meinen Image behalten..
            • 3. Re: Problem bei Prepare Imaging Script
              _Mel_ Master
              die treiber und patche bleiben auch im image - nur der server merkt sich nicht, daß die schon drin sind.
              ich bin mir auch nicht sicher, ob es überhaupt was bringt die zu includen, denn gelbe policyinstanzen sollte es auf dem rechner auf den das image deployed wird ohnehin keine geben, da der ja keine offenen vulnerabilities hat.
              • 4. Re: Problem bei Prepare Imaging Script
                Dimitrij Apprentice
                wir verwenden diesen Image nicht nur für ein Hardware Typ, deshalb sollten auch die Treiber gelöscht werden, und patche möchte ich mit Imagen um die Installation von Windows etwas zu beschleunigen und nicht stunden lang auf die Patche warten
                • 5. Re: Problem bei Prepare Imaging Script
                  _Mel_ Master
                  ok, ob die treiber übernommen werden sollen, kann man ja dem sysprep mitgeben (in der xml, ich glaube da gibt's keinen installationsparameter)

                  aber sysprep entfernt keine patche. d.h. die patche, die schon drin sind bleiben auch drin.

                  aber /includepatches sorgt nur dafür, daß die installierten patche (bzw die, für die es eine policy gibt) in dem imageobjekt auf dem BLS landen - in der imagedatei sind sie immer. da sollte also so oder so nichts mehr installiert werden.
                  • 6. Re: Problem bei Prepare Imaging Script
                    DSMForum Master
                    Hi leute ich habe auch bei den Eisenfeldern das problem das Golgalath bei mir nicht auftaucht.... Ich habe auch schon die ganze map abgesucht und alle schatten getötet Die einzigen gegner die auftauchen sind die nachtmahren auf den berg alle 30s spawnen die neu
                    • 7. Re: Problem bei Prepare Imaging Script
                      DSMForum Master
                      Hi leute ich habe auch bei den Eisenfeldern das problem das Golgalath bei mir nicht auftaucht.... Ich habe auch schon die ganze map abgesucht und alle schatten getötet Die einzigen gegner die auftauchen sind die nachtmahren auf den berg alle 30s spawnen die neu
                      • 8. Re: Problem bei Prepare Imaging Script
                        DSMForum Master
                        Hi leute ich habe auch bei den Eisenfeldern das problem das Golgalath bei mir nicht auftaucht.... Ich habe auch schon die ganze map abgesucht und alle schatten getötet Die einzigen gegner die auftauchen sind die nachtmahren auf den berg alle 30s spawnen die neu