5 Replies Latest reply on Nov 27, 2014 5:05 AM by derniwi

    Lync 2013 Installation

    ralpho Apprentice
      Hallo Zusammen,

      wir wollen demnächst OCS durch Lync 2013 ersetzten.

      Die Sache ist nun, das die Installation einwandfrei funktioniert solange ich mit F7 eine lokale Installation ausführe. Führe ich eine Pilotinstallation durch scheitert das Setup mit folgendem Fehler weil die Anführungsziechen fehlen.

      Command line: setup.exe /config c:\Program Files (x86)\Common Files\enteo\RepositoryCache\120076\rev\1\Extern$\Lync\x86\lync.ww\config.xml
      2014/11/25 13:19:35:412::[4340] Parsing command line.
      2014/11/25 13:19:35:412::[4340] Config XML file specified: c:\Program
      2014/11/25 13:19:35:412::[4340] Unrecognized command line parameter: FILES

      Aber im Nilog wird der Befehl korrekt ausgegeben.

      ExecuteEx('"\\ssta-netap2.paricorp.net\enteo$\Work\Master\Projects\120076\Extern$\Lync\setup.exe" /config "\\ssta-netap2.paricorp.net\enteo$\Work\Master\Projects\120076\extern$\Lync\x86\lync.ww\config.xml"','_RV','10')/?

      Ich verstehe nicht warum er bei der Pilotinstallation keine Anführungszeichen setzen kann/möchte/will

      Hat jemand vielleicht einen Tipp?

      Viele Grüße

      Ralph
        • 1. Re: Lync 2013 Installation
          Ludwig Apprentice
          Hallo Ralph,

          bist du sicher das "/config" überhaupt notwendig ist? Wir führen nur Setup.exe aus und dieses findet "config.xml" selber im Verzeichnis "lync.ww". Probiers mal ohne "/config".

          Grüsse Ludwig
          • 2. Re: Lync 2013 Installation
            _Mel_ Master
            versuch's mal mit runasex und "use the logged on user"
            der macht weitgehend dasselbe, muß aber nicht versuchen die kommandozeile zu parsen, weil programm und parameter da getrennt angegeben werden
            • 3. Re: Lync 2013 Installation
              ralpho Apprentice
              Besten Danke an beide. Ich habe des Setup abgeändert und jetzt funktioniert es. Ich hatte x86 und x64 Sourcen zusammen, da hat sich dann das Setup verlaufen. Blöder Fehler
              Habe mal beide Ansätze getestet und die funktionieren ebenfalls.

              Grüße

              Ralph
              • 4. Re: Lync 2013 Installation
                NicoS1 Master
                Hallo Ralph,

                noch ein kleiner Tipp: Wenn man Lync 2013 inkl. SP1 ausrollt, gibt es Probleme, sowohl aus den Office 2013 inkl. SP1 Sourcen als auch den Standalone Sourcen.

                Wir haben Lync 2013 via MSP File versucht auszurollen, und hatten das Problem, dass die Installation durchgeführt wurde (ohne Fehler), aber Lync nicht drauf war. Erst wenn man dann gesagt hat "reparieren" (über die Systemsteuerung, nicht über DSM), dann ist Lync korrekt drauf gewesen.

                Das ganze kommt von einem Bug im Office Customization Tool und betrifft Lync und noch 1-2 andere Produkte der Office Suite.

                Abhilfe: Aktuelle OCT (OAT auf Deutsch) runterladen und in den Sourcen austauschen:
                http://www.microsoft.com/en-us/download/details.aspx?id=35554

                Über die Config.xml hatte es zwar auch so geklappt bei uns, aber dort war die Schwierigkeit, dass wir die Office 2013 Tools nicht mit haben wollten, da eigentlich Office 2010 im Einsatz war, diese Option wurde über die Config.xml grundlegend ignoriert und es wurden immer die 2013er Tools mitinstalliert.

                Gruß
                • 5. Re: Lync 2013 Installation
                  derniwi Master
                  Hallo,

                  ist etwas Off-Topic, aber trotzdem passt es irgendwie hierher:
                  Ist es sinnvoll, bei Office 2010 oder neuer die Anwendung mit Service Pack zu installieren, wenn man eh eine Verteilung für die Patches hat (Patch Management oder WSUS)? Microsoft hat doch den Mechanismus der Installation inkl. Updates geändert, dass zuerst das Office-Paket ohne SP installiert wird und im Anschluss alle Updaets aus dem Update-Verzeichnis.

                  Ich denke, das wird bei Lynx analog ablaufen. Hat man also eine Installation mit SP1 und es kommt ein (kumulatives) SP2, dann werden zuerst die Software, dann SP1 installiert und irgendwie über die Update-Auslieferung dann noch das SP2. Insofern könnte man sich die Installation inkl. SP1 vereinfachen und beschleuningen, wenn die Software ohne SP installiert wird und der Update-Mechanismus das zuletzt intern freigegeben SP ausrollt.

                  Damit muß man das Paket bei Erscheinen eines neuen SPs nicht mehr anfassen, und die vorhandenen Installationen erhalten ebenfalls das SP.

                  Oder gibt es etwas, was dagegen spricht?

                  Gruß
                  Nils