11 Replies Latest reply on Aug 28, 2015 12:12 AM by ITSupportLaupheim

    [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht

    ITSupportLaupheim Apprentice
      Hallo zusammen,

      ich habe das Problem das ich seit kurzem keine MSI Pakete mehr erstellen kann. Bevor ich auf Fertigstellen klicke ist das MSI Paket schon wieder gelöscht. Eine Fehlermeldung kommt leider keine.

      Das Log zeigt allerdings Fehler (siehe Anhang)

      Leider sagt mir das garnichts, warum die MSI Pakete wieder gelöscht werden.

      Über Hilfe zu dem Problem wäre ich sehr dankbar.

      Grüße
      Alex Ludwig
        • 1. Re: [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht
          derniwi Master
          Hallo Alex,

          in Zeile 165 Deines Protokolls steht, dass eine Datei nicht kopiert werden kann:
          MsiConsoleExt: Could not copy source file to temp folder - error: 3


          Fehler 3 sagt leider auch nicht viel.

          Kann es ein Problem mit dem Kennwort des entsprechenden Benutzers sein?
          Wird das Verzeichnis auf dem Server angelegt?
          Wurden Kennwörter geändert?

          Ich habe ein solches Problem, wenn ich mein Windows-Kennwort ändere und noch mit dem Server verbunden bin. Dann hilft ein Neustart. Wenn noch eine Konsole zum Server geöffnet ist, auch dort abmelden.

          Gruß
          Nils
          • 2. Re: [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht
            Frank.Scholer Master
            Hi Alex,

            Error 3 heißt in aller Regel "File not found" (in cmd ein net helpmsg 3 eingeben).... ne Idee, warum das Sourcefile nicht da sein könnte?

            HTH, Gruß Frank
            • 3. Re: [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht
              derniwi Master
              @Frank:
              laut [URL="https://msdn.microsoft.com/en-us/library/windows/desktop/ms681382%28v=vs.85%29.aspx"]Microsoft-Webseite ist das eher folgender Fehler:
              ERROR_PATH_NOT_FOUND
                  3 (0x3)
                  The system cannot find the path specified.


              Fehler 2 wäre "Datei nicht gefunden".

              Die offene Frage: hält sich FrontRange daran?
              Und wenn: welcher Pfad wird nicht gefunden? Quelle oder Ziel?
              • 4. Re: [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht
                Frank.Scholer Master
                @derniwi - da hast du natürlich recht...
                • 5. Re: [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht
                  Klaus Salger Expert
                  Hallo Alex,

                  bekommst Du den Fehler mit jeden x-beliebigen MSI oder nur mit diesem?
                  Passiert das nur wenn Du das Admin-Setup ausführen lässt oder auch ohne das?

                  Der Paketname bzw. die MSI Description "A simple windows monitor agent for (amongst others) Nagios" ist jedenfalls in diesem Fall etwas ungewöhnlich.
                  Wenn ich mal wild spekuliere - statt des Namens wird wegen eines DSM-Bugs der CN mit den per "\" escapten Klammern für das Anlegen eines temporären Verzeichnisses verwendet, das geht wegen der "\" im Dateinamen schief und entsprechend kann die Quelle danach auch nicht gefunden werden.

                  Das sollte dann allerdings mit anderen MSIs kein Problem sein.
                  Wenn es das nicht ist hätte ich noch einen Schuss ins Blaue: Virenscanner?

                  @derniwi: ich glaube FrontRange / Heat muss sich da nicht mühevoll an irgendwelche MS-Standards halten sondern nur einfach den Fehlercode ins Log schreiben, den die entsprechende Komponente vom OS zurück bekommen hat.

                  Ciao
                    Klaus
                  • 6. Re: [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht
                    NicoS1 Master
                    Hallo,

                    grundsätzlich fände ich interessant:
                    Passierts nur bei einem bestimmten MSI oder bei allen?
                    Paketierst du von einem Client aus, oder direkt auf dem DSM Server?
                    Tritt das Problem auf mehreren Rechnern auf oder nur auf einem?
                    Adminsetup oder reines kopieren des Files?
                    Und welche DSM Version?

                    Ich meine mich Dunkel an ein Problem bei einem Kunden erinnern zu können, der irgendetwas ähnliches in der Art hatte beim paketieren von MSI Anwendungen. Ich meine da war ein Problem mit Windows 8.1 und der UAC. Die DSMC wurde non-elevated gestartet, und während des Setups kam "irgendwie" die UAC hoch (automatische Setuperkennung?). Das Problem war dann das, dass die non-elevated DSMC nicht auf das zugreifen konnte, was das Adminsetup im Elevated Modus gemacht hat. Lösung war die DSMC einfach auch Elevated zu starten. Kann es leider nicht hundert Prozent genau beschreiben, da ichs nicht persönlich untersucht hatte, sondern nur das zur Verfügung hatte was der Paketierer mir lieferte

                    Ansonsten gehe ich bei sowas erstmal mit ProcMon ran und schaue was denn überhaupt passiert
                    • 7. Re: [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht
                      derniwi Master
                      @Klaus: ich meinte eigentlich nur, dass ich unsicher bin, ob FrontRange den Fehler 3 intern eigenständig erzeugt oder ob das wie von Dir genannt einfach eine Weiterleitung der Meldung der Windows-API ist. Es könnte ja durchaus sein, dass der Fehler DSM-spezifisch ist und somit die 3 etwas ganz anderes aussagt.
                      • 8. Re: [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht
                        ITSupportLaupheim Apprentice
                        Hallo zusammen,

                        danke für die schnelle Reaktion. Leider war ich bis heute nicht im Büro.

                        Hallo,

                        grundsätzlich fände ich interessant:
                        Passierts nur bei einem bestimmten MSI oder bei allen?
                        Paketierst du von einem Client aus, oder direkt auf dem DSM Server?
                        Tritt das Problem auf mehreren Rechnern auf oder nur auf einem?
                        Adminsetup oder reines kopieren des Files?
                        Und welche DSM Version?


                        Es passiert nur bei MSI Paketen. Genutzt wird das DSM an einem Windows 7 Client.
                        Auftreten tut das Problem überall. Auch am Server (2012 kein R2).
                        Ob ein Adminsetup erzeugt wird oder nur kopiert wird ist egal. Der Fehler ist der selbe.

                        Die Version ist 2015.1 (7.02.004.2867).

                        Ich meine mich Dunkel an ein Problem bei einem Kunden erinnern zu können, der irgendetwas ähnliches in der Art hatte beim paketieren von MSI Anwendungen. Ich meine da war ein Problem mit Windows 8.1 und der UAC. Die DSMC wurde non-elevated gestartet, und während des Setups kam "irgendwie" die UAC hoch (automatische Setuperkennung?). Das Problem war dann das, dass die non-elevated DSMC nicht auf das zugreifen konnte, was das Adminsetup im Elevated Modus gemacht hat. Lösung war die DSMC einfach auch Elevated zu starten. Kann es leider nicht hundert Prozent genau beschreiben, da ichs nicht persönlich untersucht hatte, sondern nur das zur Verfügung hatte was der Paketierer mir lieferte



                        Genau das ist die Lösung. Warum allerdings erst jetzt das passiert ist, ist mir ein Rätsel. Vorallem war das bei der 2013.x Version unseres früheren Systems nicht so.
                        Durch das Elevated starten gibt es nur 1 Problem:
                        Die ganzen Netzlaufwerke werden nicht mehr angezeigt (Ja mein User ist lokaler Admin).
                        Gibt es da einen Trick17?

                        Grüße und schonmal vielen Dank.
                        • 9. Re: [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht
                          Klaus Salger Expert
                          Das sollte klappen wenn Du das DWORD-Value "EnableLinkedConnections" unter HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System auf 1 setzt.
                          • 10. Re: [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht
                            ITSupportLaupheim Apprentice
                            Hallo Klaus,

                            das hat schonmal wunderbar funktioniert. Nur ist mir gerade aufgefallen, dass sich das DSMC nicht mehr richtig schließt (GUI ist weg, aber Prozess bleibt hängen).

                            Die Logs sagen aber nix darüber.

                            Kennt jemand die Problematik?
                            • 11. Re: [SOLVED] Neu erstelltes MSI Paket wird sofort wieder gelöscht
                              ITSupportLaupheim Apprentice
                              So nach langem hin und her bleibt für uns im Moment folgende Lösung:
                              Die MSI's werden vom DSM nur ins Paketverzeichnis kopiert. Änderungen per MST werden mit ORCA erstellt und dann manuell angehängt. Das funktioniert super und man muss DSM nicht jedes Mal als Administrator starten.