1 2 Previous Next 22 Replies Latest reply on May 22, 2017 1:01 AM by saimen

    AutoLogon und NiAgnt32 start

    SitzRieSe Expert
        • 1. Re: AutoLogon und NiAgnt32 start
          derniwi Master
          Hallo Alex,

          dieses Problem habe ich auch ab und an. Das scheint aber ein großes Problem von Microsoft selbst zu sein, wenn beim Start des Rechners das Netzwerk nicht komplett initialisiert wird, bis die Anmeldung losgeht.

          Ich formuliere das mal so (nach meinen Beobachtungen und Vermutungen):
          Der Rechner fährt hoch. Dann werden die Netzwerkdienste gestartet. Hier bekommt das Netz ein paar Sekunden Zeit, sich zu initialisieren. Das klappt dann wohl auch mehr oder weniger gut, aber mit manchen Netzwerkkarten etwas schlechter als mit anderen. Irgendwann meldet der Netzwerkkartentreiber, dass er fertig ist mit der Initialisierung, hat zu diesem Punkt aber keine IP-Adresse erhalten. Dann kann sich aber ein Benutzer wegen der "Cached Credentials" anmelden, was dann auch durchgeführt wird. Jetzt wird aber das Logon-Skript nicht abgearbeitet (falls eines vorhanden ist). Aber manchmal bekommt der Rechner dann zu diesem Zeitpunkt doch noch eine IP-Adresse und führt das Skript aus - aber nicht immer.

          Manchmal sehe ich in der Ereignisanzeige auch, dass kein Domänenserver gefunden wurde. Da wir hier Trusts zu Standorten weltweit haben, kann diese Suche auch etwas länger dauern, bis die Liste der Domänenserver vorhanden ist (auch wenn das wohl in den meisten Fällen nicht nötig ist). Und dann werden wohl auch die "Cached Credentials" verwendet... da ja während der Installation eine Anmeldung mal funktioniert hat, scheint dass dann auch zu klappen.

          Aber wie gesagt, das sind nur Vermutungen, so richtig schlau bin ich aus den Protokollen und Einträgen bei diesem Verhalten noch nicht geworden. Und das Problem ist nicht reproduzierbar. 20 mal kein Problem, und dann tritt dieses Phänomen mal wieder auf. Und nur mit bestimmten Netzwerkkarten... manchmal geht es (gefühlt) mit anderen Treiber-Versionen besser. Und dann gibt es auch Fälle, wo alles sehr lange ohne Probleme klappt.

          Ob es hier Werte in der Registry gibt, die man anpassen kann (Timeout für die Suche nach Logon-Servern, Warten auf DHCP), bevor dann eine Anemdlung ausgeführt werden soll, weiß ich nicht.

          Vielleicht kann da noch jemand etwas dazu sagen oder hat auch Erfahrungswerte...

          Gruß
          Nils
          • 2. Re: AutoLogon und NiAgnt32 start
            SitzRieSe Expert
            Hi Nils,

            bei mir ist das Problem leider ziemlich genau reproduzierbar. Es tritt in meinem Fall jetzt immer nach der OS Installation bei diesem Gerät an dieser Site auf. Es gibt kein Versuch wo der erste Start nach der OS Installation den Agent erfolgreich startet.

            Alle weiteren Reboots lösen den Agenten zuverlässig aus! Daher glaube ich nicht das ich hier ein Timing Problem habe...
            • 3. Re: AutoLogon und NiAgnt32 start
              MTheis Specialist
              Hallo,

              ich gehe mal davon aus, dass es sich um Windows 10 handelt?

              Das in dem Log sieht schon komisch aus, aber wie wird denn der Agent getriggert? Per GPO oder über das Benutzerkonto? Per Loginskript über das NETLOGON Verzeichnis? Wird das NIAI Log erstellt oder verläuft der Aufruf des Agents im Sande? Dann könnten wir dazu noch was im Eventlog von Windows selber finden.

              Bei GPO ... was sagt gpresult /r? Werden die Richtlinien gezogen?

              Es kann in diversen Konstellationen Probleme beim Zugriff unter Windows 10 auf die DC geben (siehe auch [url=https://social.technet.microsoft.com/Forums/en-US/f4d77de7-17df-4463-b751-d1892829e7ab/windows-10-cannot-be-access-sysvol-netlogon-folder-on-the-server-2012-r2?forum=win10itprogeneral]hier).

              Das Gerät hat ja scheinbar noch eine Mobile Netzwerkkarte für UMTS/LTE. Was passiert, wenn man die im BIOS testweise deaktiviert? Kommt er evtl. mit der Reihenfolge der Karten durcheinander, was ein Firmware oder Treiberupdate lösen könnte?

              Ist die SSD zu schnell? http://www.gruppenrichtlinien.de/artikel/ssd-zu-schnell-synchroner-startvorgang-nicht-moeglich/

              Würde ein zusätzlicher Reboot durch den SI helfen?

              Gruß, MTheis
              • 4. Re: AutoLogon und NiAgnt32 start
                derniwi Master
                Die zweite Netzwerkkarte... hast Du die Treiber schon bei der OS-Installation dabei? Oder am Paket den Haken gesetzt, dass der Treiber da noch nicht installiert werden soll?
                • 5. Re: AutoLogon und NiAgnt32 start
                  SitzRieSe Expert
                  Hi,

                  die Treiber werden bei der OS Installation bereits installiert. Der Agent wird an der Stelle noch über das Login Skript getriggert welches wir per GPO verteilen. Das funktioniert auch! Der Agent wird definitiv gestartet.

                  Ich werde mal den Haken setzen den Nils meint und es nochmal probieren.
                  • 6. Re: AutoLogon und NiAgnt32 start
                    ChristophSteckelberg Expert
                    Hi,

                    hast Du mal vor der Neuinstallation den Computer aus dem AD gelöscht ? Wir hatten vor kurzem genau das selbe Problem mit HP Hardware und es hat praktisch _immer_ geholfen wenn die Geräte beim Neuaufsetzen keine alten Computerobjekte im AD "hijacken" konnten.
                    • 7. Re: AutoLogon und NiAgnt32 start
                      SitzRieSe Expert
                      Haben wir jetzt in dem Fall nicht, allerdings war der Rechner initial noch nicht im AD vorhanden. Das teste ich aber auch nochmal gerne

                      Den Treiber aus der OS Installation rauszunehmen führte jetzt dazu das er kein Domain Join mehr hinbekommt Ich werde es vielleicht nochmal mit einem anderen Treiber probieren.
                      • 8. Re: AutoLogon und NiAgnt32 start
                        derniwi Master

                        Den Treiber aus der OS Installation rauszunehmen führte jetzt dazu das er kein Domain Join mehr hinbekommt Ich werde es vielleicht nochmal mit einem anderen Treiber probieren.


                        Der UMTS-Treiber? Das würde ja bedeuten, dass die Installation über UMTS laufen würde und Ethernet gar nicht funktioniert...

                        Gerade bei Mobilgeräten kann es durchaus problematisch sein, wenn zwei Netzwerkkarten vorhanden sind, die im gleichen Netz enden. Sprich, eine Anfrage an einen Server könnte dann über die Ethernet-Karte abgeschickt werden, die Antwort kommt dann aber über WLAN. Wir hatte das hier immer mal wieder, was dazu führt, dass die betroffenen Rechner sehr langsame Übertragungen im Netzwerk haben.

                        Bei einigen Herstellern (z.B. DELL) kann man im BIOS der Geräte einstellen, dass die WLAN-/WWAN-Verbindungen deaktiviert werden, sobald eine Verbiung über LAN erkannt wird. Dazu muss aber der WLAN-/WWAN-Treiber installiert sein.
                        • 9. Re: AutoLogon und NiAgnt32 start
                          SitzRieSe Expert
                          Hi,

                          nene... ich hab den Ethernet Adapter mal rausgenommen und gehofft Windows bringt evtl was mit. Die anderen Device werden erst mit eScripte installiert. Das heißt die kommen bei der OS Installation garnicht vor.

                          Wir haben den Client jetzt soweit das die IP Adresse vergeben ist und die Sitezuordnung funktioniert. Danach kommt aber leider das:

                          11:27:52.934 : --------------------------------------------------------------------------------
                          11:27:5----- [Significance: 35] --- [Errors: 0] --- [Warnings: 2]------------------------------
                          11:27:52.934 : --------------------------------------------------------------------------------
                          11:27:52.934 :  LogFile C:\Program Files (x86)\Common Files\enteo\NiLogs\NiAgnt32_1.log, started 21.04.2016 11:27
                          11:27:52.934 :  Application : C:\Program Files (x86)\NetInst\NiAgnt32.exe(PID: 3628 [0e28])
                          11:27:52.934 :  Version : 7.03.000.3181
                          11:27:52.934 :  Params:      
                          11:27:52.934 :  OS: Windows 10 (x64), Windows NT 6.2 (Build 9200)
                          11:27:52.934 :  Product Type: WinNT, Terminal Server, DSM Patch Level: 7.3.0.3261
                          11:27:52.934 :  User lang: German, System lang: German
                          11:27:52.934 :  Reportlevel: 0
                          11:27:52.934 :  Username: Install (not local admin), Workstation: 5CG61307BB, FQDN: 5CG61307BB.***
                          11:27:52.934 :  siClnt32.dll: 7.03.000.3181 (11.11.2015 01:16:26)
                          11:27:52.934 : --------------------------------------------------------------------------------
                          11:27:52.934 0 Caller requests logrogue legacy logging
                          11:27:52.934 0 Successfully enabled logrogue legacy logging

                          11:27:52.934 1 > Action 'NetInstall Agent' started

                          11:27:52.934 1  siClnt32: > Action 'Validate Client State' started
                          11:27:52.950 1   siClnt32: > Action 'Validate Client State' completed without warnings (Action took 16 ms.)
                          11:27:52.950 2  The installer has not yet been started in this user session
                          11:27:52.950 0  Importing NCP Support from loaded NiCfgPrv.dll

                          11:27:52.965 1  NiCfgPrv: > Action 'Initializing NetInstall Config Provider [0x0005] ...' started
                          11:27:52.965 0   NiCfgPrv: Max duration: 90
                          11:27:52.965 1    NiCfgPrv: NiCfgPrv.dll  - Date 11.11.2015 01:16:24, Version:  7.03.000.3181, Path: C:\Program Files (x86)\NetInst\NiCfgPrv.dll
                          11:27:52.965 0    NiCfgPrv: Entering CNcpDb::Load...

                          11:27:52.965 2    NiCfgPrv: Loading configuration information from C:\Program Files (x86)\NetInst\NiCfgLcl.ncp...
                          11:27:52.965 1    NiCfgPrv: Database file time: 21.4.2016 11:03:04
                          11:27:52.965 0    NiCfgPrv: Determining site via ICDB-Service
                          11:27:53.059 0    nwcmclnt.dll: Role based login succeeded with ***
                          etinst_run
                          11:27:53.059 0    FPSClnt.dll: Failed to access the depot.
                          Zugriff verweigert (0x00000005)
                          11:27:53.059 0    nwcmclnt.dll: Logout Nwcm succeeded with ***
                          etinst_run
                          11:27:53.059 0    FpsClntHlp.dll: Unable to determine if the depot is in update mode
                          Zugriff verweigert (0x00000005)
                          11:27:53.059 E    Warning (Module:NiCfgPrv, Severity:0x03): Failed to determine if current server is usable.
                          Zugriff verweigert (0x00000005)
                          11:27:53.075 0    NiCfgPrv: The current server isn't available, relocating....
                          11:27:55.497 0    NiCfgPrv: IP address name resolUtion for server access: off
                          11:27:55.497 1     NiCfgPrv: RegValue 'ProgramFilesDir' resolved as 'C:\Program Files (x86)'
                          11:27:55.497 2    NiCfgPrv: >> NetInstall path set to \\dsmserver\dsm$\, context is dsmserver.***

                          11:27:55.497 0    NiCfgPrv: Trying to remove preferred server entry
                          11:27:55.497 0    NiCfgPrv: Failed to open NCP cache.

                          11:27:55.497 1    NiCfgPrv: -------- Mapping network drives  ----------------------------------------------

                          11:27:55.497 1    NiCfgPrv: Client init complete.
                          11:27:55.497 1   NiCfgPrv: > Action 'Initializing NetInstall Config Provider [0x0005] ...' completed with 1 warnings (Action took 2547 ms.)
                          11:27:55.497 0  csmancln.dll: Update initiated for computer with flags 0x0000200e
                          11:27:59.603 2  CSM: Process should continue, Reason:Eine Aktualisierung ist nicht erforderlich (0x60080327)
                          11:27:59.603 2  CSM system status code is 'Der Vorgang wurde erfolgreich beendet. (0x00000000)'
                          11:27:59.603 1  siClnt32: Created registry key 'SOFTWARE\NetSupport\NetInstall\ModuleStates'
                          11:27:59.603 1  Sleeping 30 seconds...
                          11:28:29.659 0  siClnt32: Importing NCP Support from loaded NiCfgPrv.dll
                          11:28:29.659 1  NiCfgPrv: The current measured network throughput is 1487
                          11:28:29.659 1  NiCfgPrv: The network threshold level defined for the current site is 20
                          11:28:29.675 0  nwcmclnt.dll: Role based login succeeded with ***
                          etinst_run
                          11:28:29.675 0  FPSClnt.dll: Failed to access the depot.
                          Zugriff verweigert (0x00000005)
                          11:28:29.675 0  nwcmclnt.dll: Logout Nwcm succeeded with ***
                          etinst_run
                          11:28:29.675 0  FpsClntHlp.dll: Unable to determine if the depot is in update mode
                          Zugriff verweigert (0x00000005)
                          11:28:29.675 E  Warning (Module:siClnt32, Severity:0x03): Not OK to start installer: Failed to determine if Update.$$$ exists
                          Zugriff verweigert (0x00000005)
                          11:28:30.003 2  Starting fastinstall server thread
                          11:28:30.003 2  Creating pipe with name \\.\PIPE\NIAgent$
                          11:28:35.011 0   NiCfgPrv: Determining site via ICDB-Service
                          11:28:35.027 0   nwcmclnt.dll: Role based login succeeded with ***
                          etinst_run
                          11:28:35.027 0   FPSClnt.dll: Failed to access the depot.
                          Zugriff verweigert (0x00000005)
                          11:28:35.027 0   nwcmclnt.dll: Logout Nwcm succeeded with ***
                          etinst_run
                          11:28:35.027 0   FpsClntHlp.dll: Unable to determine if the depot is in update mode
                          Zugriff verweigert (0x00000005)
                          11:28:35.027 E   Warning (Module:NiCfgPrv, Severity:0x03): Failed to determine if current server is usable.
                          Zugriff verweigert (0x00000005)
                          11:28:35.027 0   NiCfgPrv: The current server isn't available, relocating....
                          11:28:37.249 1    NiCfgPrv: RegValue 'ProgramFilesDir' resolved as 'C:\Program Files (x86)'
                          11:28:37.264 0   nwcmclnt.dll: Role based login succeeded with ***
                          etinst_run
                          11:28:37.280 0   FPSClnt.dll: Failed to access the depot.
                          Zugriff verweigert (0x00000005)
                          11:28:37.280 0   nwcmclnt.dll: Logout Nwcm succeeded with ***
                          etinst_run
                          11:28:37.280 0   FpsClntHlp.dll: Depot is not accessible
                          Zugriff verweigert (0x00000005)
                          11:28:37.280 1   ->>> No current site, retrying in next polling interval
                          11:28:37.280 1   Set polling interval to 1440 minutes



                          Teste ich den manuellen Zugriff auf das Depot funktioniert das! ich komme überall hin und kann auch Sachen kopieren. Beende ich den Agent starte ich Ihn erneut, den gleichen Fehler. Starte ich den PC, funktioniert es!

                          Jemand eine Idee?
                          • 11. Re: AutoLogon und NiAgnt32 start
                            MTheis Specialist
                            Bei Zugriff verweigert müsste im Securitylog des entsprechenden DSM Servers was zu finden sein.

                            Klingt für mich so, als würde er in der SItzung erst der Domäne beitreten (Zugriff klappt nicht, weil noch nicht in der Domäne authentifiziert, da dazu der Neustart erforderlich ist) und nach dem Neustart, wenn das Computerkonto in der Domäne ist, funktioniert es.

                            Ist evtl. der Domain-Join vorher schon fehlgeschlagen?

                            Gruß, MTheis
                            • 12. Re: AutoLogon und NiAgnt32 start
                              SitzRieSe Expert
                              Hi,

                              mh ne der Domain Join funktioniert sauber! Der AutoLogon User ist auch ein Domain User! Das sollte also funktionieren! Auf dem DSM Server kann man in der Tat die Anmeldeversuche im Ereignislog sehen und dort kriegen wir eine Erfolgsmeldung!

                              Timing Problem... mh bin ich mir nicht mehr sicher, nach meinem Verständnis müsste es dann ja reichen den NiAgnt32 zu beenden und wieder zu starten wenn man ein paar Minuten gewartet hat. Dann kommt der Fehler aber wieder! Erst wenn ich neustarte gehts weiter.

                              Ich setz mal noch den Regkey von Nils und versuch es erneut.

                              Danke erst einmal bis hier!

                              Gruß

                              Alex
                              • 13. Re: AutoLogon und NiAgnt32 start
                                ChristophSteckelberg Expert
                                Joinen die Rechner in eine bestimmte OU, auf die GPOs wirken ? Kannst Du das HP Gerät testweise mal direkt nach Computers joinen lassen ?
                                • 14. Re: AutoLogon und NiAgnt32 start
                                  SitzRieSe Expert
                                  Hi,

                                  also ich kann das gerne auch testen, aber hälst du das für logisch? Die GPO's ziehen bereits in der ersten Anmeldung... wieso sollte es dann beim nächsten Neustart funktionieren?

                                  Aber ja, der Computer wandert in eine OU wo auch GPO's ziehen.
                                  1 2 Previous Next